Hi, I´ve used Ubuntu before in y former PC (DELL Dimension 8250) an I never had any problems with it (Since 6.10-7.08). I built my new PC in which no matter what Ubuntu CD y want to try (Live or Alternate) it won´t log in nor install, it hangs at:

[182.636422] Time: hpet clocksource has been installed
(this is when i try to boot with the noapic nolapic option, but if i try to boot normal mode it just shows a blinking cursor)

I need help, I´m currently using Vista Ultimate with no problems, and I´ve tried to install it from within windows, but it just hangs and never installs it shows an "Insert CD" error (and it is not a hardware problem, because i can still see the CD contents at that point, and I´ve also tried mounting the ISO to install)

I´ve tried downloading new Ubuntu images, and with all CDs that i´ve tried to install it on this PC, a have succeeded the installation process on another PC (my old laptop HP nx6125)

I´m hoping the problem is not related to hardware, however this are the PC SPECS:
MOBO: abit Fata1ity F-190HD
CPU: Intel Q6600 @ 2.4GHz
HD: Seagate Barracuda 360GB
RAM: 4x1GB Kingston 6400 DDR2 800MHz
CPU Cooling: Coolermaster Gemini II (with 2x120mm Coolermaster Silent fans)
Case: Coolermaster CM690 with 2x140mm Coolermaster Silent fans and 2x120mm Coolermaster Silent Fans

If you have any clues, let me know i´m desperate, want to go back to Ubuntu side.