Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Google Earth blinking problem

  1. #1
    Join Date
    Apr 2008
    Beans
    30

    Google Earth blinking problem

    Hi, I installed GoogleEarth. When I run it, I can see the earth - the whole canvas blinking. Like refreshing. I had my closed ATI drivers, so I installed ENVY to solve this. But its blinking even with ENVY. Does anybody have similar issue? Thanks

  2. #2
    Join Date
    Apr 2007
    Location
    Mallorca, Spain
    Beans
    46
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Google Earth blinking problem

    I am having the same problem. It seems like dialog boxes are fighting to be the active one. I am going to investigate along those lines. It is certainly ATI related. I had GoogleEarth working with this computer under 7.06, now using 8.04. (Automatix broke my upgrade to 7.10. Now using clean install 8.04)
    Computers are incredibly fast, accurate and stupid.
    Humans are incredibly slow, inaccurate and brilliant.
    Together they are powerful beyond imagination.

  3. #3
    Join Date
    Oct 2007
    Location
    Ocoee, Florida
    Beans
    77
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Google Earth blinking problem

    I don't think it's an ATI problem. I have a Dell E1505/6400 with a Intel Corporation Mobile 945GM chipset and I have the same problem. It seems that GoogleEarth doesn't play well with desktop effects. See this link: http://ubuntuforums.org/showthread.php?t=505068.

    Well, just found out ATI and Intel drivers both have this problem. See this link: http://forum.compiz-fusion.org/showthread.php?t=3367.

    I'll try disabling Compiz and see if that solves the problem.
    'Among the tales of sorrow and of ruin that come down to us from the darkness of those days there are yet some in which amid weeping there is joy, and under the shadow of death, light that endures.' The Silmarillion by J.R.R. Tolkien

  4. #4
    Join Date
    Oct 2007
    Location
    Ocoee, Florida
    Beans
    77
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Google Earth blinking problem

    Yep, that seems to be the cure. If I stop compositing it definitely solves my blinking problems with GoogleEarth. Since I have Compiz Fusion Icon installed, all I need to do is change the window manager to Metacity, and then back to Compiz once I'm done.
    'Among the tales of sorrow and of ruin that come down to us from the darkness of those days there are yet some in which amid weeping there is joy, and under the shadow of death, light that endures.' The Silmarillion by J.R.R. Tolkien

  5. #5
    Join Date
    Apr 2008
    Location
    Ireland
    Beans
    9
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Google Earth blinking problem

    Hi. I'm a total Ubuntu newbie but so far I'm having a blast.

    In relation to Google Earth blinking, I'm having that problem too. However, I'm pretty sure I don't have Compiz running on my machine. How do I check if Compiz is installed or not?

  6. #6
    Join Date
    Oct 2007
    Location
    Ocoee, Florida
    Beans
    77
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Google Earth blinking problem

    Quote Originally Posted by John The Bad View Post
    Hi. I'm a total Ubuntu newbie but so far I'm having a blast.

    In relation to Google Earth blinking, I'm having that problem too. However, I'm pretty sure I don't have Compiz running on my machine. How do I check if Compiz is installed or not?
    Here is the best way you can check to see if you're running Compiz, and also how to disable compositing. Go to your menu and select System --> Preferences --> Appearance. Then select the Visual Affects tab. If anything is selected other than "None", then you are probably running Compiz. To disable compositing, select "None". If it is already selected, then the problem may be that you don't have enough system resources to properly run GoogleEarth. Of course, this is just speculation on my part as I don't have any information about your system.

    I hope this helps!

    By the way, I've been running Ubuntu for about 9 months and this is the most fun I've had with an operating system since Windows 98. As you are, I also am having a blast!
    'Among the tales of sorrow and of ruin that come down to us from the darkness of those days there are yet some in which amid weeping there is joy, and under the shadow of death, light that endures.' The Silmarillion by J.R.R. Tolkien

  7. #7
    Join Date
    Jun 2008
    Beans
    1

    Re: Google Earth blinking problem

    Hi all,

    when launching GoogleEarth 4.3.7204.0836 (beta) in Ubuntu 8.04 the default settings have "Atmospheric" layer on (in 'View'), resulting in a "graying-out" of parts of the window at every mouse-click anywhere. After unchecking "Atmospheric" layer the GUI behaves almost normal, although there is a short blinking left

    When clicking and holding mouse button the Earth disappears, so i guess its a problem with the mouse, not the video card

    cheers
    Last edited by Diego_R; June 1st, 2008 at 06:58 PM.

  8. #8
    Join Date
    Jan 2008
    Beans
    103

    Re: Google Earth blinking problem

    I have this problem with google earth and vlc and it's definately a compiz related problem. It doesn't happen with compiz disabled. I've also discovered that when running either in full screen mode the problem disappears.

  9. #9
    Join Date
    Oct 2007
    Beans
    11

    Re: Google Earth blinking problem

    I have the new intrepid install. And have disabled compiz, yet still have the blinking screen! What am i mising guys, i do have an ATI Mobility Radeon card, is that it??

  10. #10
    Join Date
    Apr 2005
    Location
    UK
    Beans
    148
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Google Earth blinking problem

    It appears that opengl applications don't work well with DRI (direct rendering infrastructure v1) - this is quite a major hurdle, apparently, and requires reworking all the drivers to use DRI2. I understand that Intel driver do this, but only for a more recent kernel than will be in jaunty.

    Conclusions:
    1) for the time being, Intel has the best open source graphics driver supprt. Buy intel graphics, for now.
    2) ubuntu will have this problem until the next release.
    3) try a really recent alpha fedora live cd/dvd, which has a 2.6.29 kernel and bleeding edge drivers.
    4) the compiz/metacity switcher applet is the best workaround.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •