Results 1 to 4 of 4

Thread: 8.04 Server install on Parallels/Mac

  1. #1
    Join Date
    Apr 2008

    Question 8.04 Server install on Parallels/Mac

    Greetings. Very new to linux and I am trying to install the 8.04 server onto a parallels virtualization. I can run the install complete however when it restarts I get the error:

    This kernel requires the following features not present on the CPU: 0:6
    Unable to boot - please use a kernel appropriate for your CPU.

    Any ideas on where to start with this one?

  2. #2
    Join Date
    Apr 2008

    Re: 8.04 Server install on Parallels/Mac


    Sorry for the bunch of technical details that follow, but as far as I know, Parallels does not support PAE extensions in the virtualized hardware but the Ubuntu server kernel needs to use them to be able to address more than 4 GB of RAM in 32-bit mode, hence the fault.

    To install a Ubuntu command-line system in Parallels, please use either the Alternate CD instead of the Server CD (if offers to install a command-line system at the beginning of installation, among other things), or try to download and install JeOS,

  3. #3
    Join Date
    Mar 2006

    Re: 8.04 Server install on Parallels/Mac

    alternative is vmware fusion

    Ubuntu on virtual machine on host Lion 10.7.4
    hacktosh i7 3.4 cpu 8gigs ram asus maximus IV gene-z mb

  4. #4
    Join Date
    Dec 2007
    NH, USA
    Ubuntu 8.04 Hardy Heron

    Talking Re: 8.04 Server install on Parallels/Mac

    I had just come across this myself.
    I definitely wanted to use the server version but had the same error come up.

    Parallels KB#4934 : Ubuntu Server does not boot

    Using this I was able to get it booted using the generic kernel.
    After you've gotten it to boot you may choose to recompile the kernel without PAE support. When I get around to doing this I'll post those results as well.

    NOTE: After many attempts at installing the generic kernel I found there is one thing not mentioned in their instructions. They are assuming you've installed normal partitions and are not using LVM. I tried many times to fix grub, but was unsuccessful. Anyone familiar with this please chime in. When you are running the initial install of Ubuntu server, when asked about the partitioning scheme, pick "Guided", not "Guided ...LVM" or "Guided Encrypted LVM".

    -Create new VM in Parallels set to boot of install CD or ISO.
    -Run Ubuntu Server Install
    -Choose first option "Guided" when get to the partitioning screen.
    -Reboot off the CD or ISO once more.
    -Run Ubuntu Rescue Mode
    -When asked, drop to a shell in the installed system.
    -Run this command: "apt-get install linux-generic"
    -Shutdown VM and reconfigure to boot off the 'HD'
    -When booting, make sure you hit ESC to get to the grub menu.
    -You will have the option of both the server and generic kernel, pick the generic kernel.

    At this point you will have a working install.
    You may choose to either update grub so it boots the generic kernel as the default, or start building the server kernel without PAE support.

    Have fun!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts