Results 1 to 3 of 3

Thread: virt-manager, KVM and eth0 briged problem

  1. #1
    Join Date
    Apr 2005
    Location
    Argentina - SGO
    Beans
    47

    Angry [SOLVED] virt-manager, KVM and eth0 briged problem

    i want to create a VM with virt-manager and KVM, but when i going to select the connection method i want to select "Shared physical device" because i want to see the VM from my local network, but when i choose this option i see all my networks like this:

    wlan0 (Not bridged)
    wmaster0 (Not bridged)
    eth0 (Not bridged)

    and i can't select anything (i am connected via eth0 with static ip).

    i googled but i can't find any information about this problem.

    if i can't use virt-manager to create a VM with bridged network what i can use? (i don't want Xen or Vmware or another, only KVM+something) is the solution is via manual configuration is ok!.

    Grettings
    insulae
    Last edited by insulae; April 29th, 2008 at 08:32 PM. Reason: put [solved] to the title
    Juan Matias Granda
    http://www.insulae.com.ar
    GPG FINGERPRINT:459C 4A2D 330C CB8C 0C44 0C3A 572C CBCA 5457 508B

  2. #2
    Join Date
    Feb 2006
    Location
    Europe
    Beans
    25

    Re: virt-manager, KVM and eth0 briged problem

    Not sure about virt-manager, never used it. You need to:

    - Make a new bridge
    - Make a new Tap interface
    - Add your to-be-bridged interface to it
    - Add your tap interface to the bridge
    - Reassign your IP to the bridge interface since the eth0 interface is in the bridge now
    - Start qemu making sure your tap interface maps to eht0- in the VM

    There is a howto located here:
    http://wiki.centos.org/HowTos/KVM

  3. #3
    Join Date
    Apr 2005
    Location
    Argentina - SGO
    Beans
    47

    Re: virt-manager, KVM and eth0 briged problem

    (sorry for my english )

    geertn thanks for the quick response. i resolv my problem installing bridge-utils and then editing /etc/network/interfaces and then i put:

    Code:
    auto br0
    iface br0 inet dhcp
    bridge_ports eth0
    bridge_stp off
    bridge_maxwait 5
    then i restart the service: networking, kvm and libvirt and then in virt-manager wizard i see the new virtual network br0, with this network i can use the option "Shared physical device".

    Grettings
    insulae
    Juan Matias Granda
    http://www.insulae.com.ar
    GPG FINGERPRINT:459C 4A2D 330C CB8C 0C44 0C3A 572C CBCA 5457 508B

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •