Results 1 to 9 of 9

Thread: How do I enable direct rendering on an ATI Rage Mobility M3?

  1. #1
    Join Date
    Apr 2007
    Beans
    26

    Question How do I enable direct rendering on an ATI Rage Mobility M3?

    I've got an old Dell Latitude C600 onto which I've just installed Hardy. The graphics card is reported as "ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)". The native resolution of the C600's screen is 1024x768. Out of the box, the screen displays as 800x600, which I fixed by adding lines to xorg.conf as detailed here:

    http://www.shahidhussain.com/blog/?p=12

    However, glxinfo reports that direct rendering is not enabled. I tried the instructions posted here:

    http://ubuntuforums.org/archive/index.php/t-370219.html

    but it made no difference.

    I understand that this card is used in a lot of laptops. Does anyone know how to get it working?

    Many thanks!
    Attached Files Attached Files

  2. #2
    Join Date
    Apr 2005
    Location
    Berlin/Germany
    Beans
    8
    Distro
    Dapper Drake Testing/

    Re: How do I enable direct rendering on an ATI Rage Mobility M3?

    Hey,
    I configured my display/graphic card with "displayconfig-gtk" (as sudo).

    In my xorg.conf I changed the driver "ati" with "r128" and default depth to 16. Now direct rendering works fine.

    But with my Dell C600 I have a suspend problem. The laptop goes to sleep but the display doesn't turn off. Do you have the same issue with yours?

    Best regards,

  3. #3
    Join Date
    Apr 2007
    Beans
    26

    Re: How do I enable direct rendering on an ATI Rage Mobility M3?

    @alphabeta23

    Thanks for your suggestions.

    > I configured my display/graphic card with "displayconfig-gtk" (as sudo).

    I tried this, and after a reboot X would only load in safe graphics mode, so I had to revert to my old xorg.conf.

    > In my xorg.conf I changed the driver "ati" with "r128" and default depth to 16. Now direct rendering works fine.

    The default depth in my previous xorg.conf was already at 16, but it didn't seem to help. Running the config tool above added the Driver "r128" line, but this seemed to break things.

    > But with my Dell C600 I have a suspend problem. The laptop goes to sleep but the display doesn't turn off. Do you have the same issue with yours?

    Yes, I get this too - that's the next problem to solve...

    Does anyone have any other ideas?

  4. #4
    Join Date
    Apr 2007
    Beans
    26

    Re: How do I enable direct rendering on an ATI Rage Mobility M3?

    Ah - I've just realised that I needed to add

    DefaultColorDepth 16

    to the Monitor section. What confused me is that the new version of X.org in Hardy seems to use a very cut-down version of xorg.conf, and this line (along with many others I'm used to seeing) is actually missing altogether. I now get about 500 fps in glxgears as opposed to 120 fps before.

    I'll see if I can find out anything about the backlight staying on on standby...

  5. #5
    Join Date
    Jun 2008
    Beans
    2

    Re: How do I enable direct rendering on an ATI Rage Mobility M3?

    Hi Guys!

    I have the same video card built in my laptop. I couldn't get the direct rendering going even with your modifications of xorg.conf.

    Maybe I did something wrong. Is is possible to post your xorg.conf here?

    THX, EvilK

  6. #6
    Join Date
    Nov 2008
    Location
    Hawley, Pennsylvania USA
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Talking Re: How do I enable direct rendering on an ATI Rage Mobility M3?

    I'm Not sure about distribution differences, but this worked for me on Xubuntu 8.10 with the same hardware. Unfortunately it's not capable of playing the latest and greatest of games from what I could read: however I was happy to finally get it to work at all I scanned posts and howto's all over the web for weeks. I'm still fairly new to all of this and have no intentions of reverting to windows especially now. I just found this thread http://ubuntuforums.org/archive/index.php/t-370219.html. The very last post is what tipped me over the edge the steps that i took before that was to manually configure xorg.conf which supposedly does not get read in Xubuntu 8.10. Anyway here are some commands to run through first.

    This is exactly what I did

    sudo apt-get remove --purge fglrx*
    sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
    sudo apt-get install xserver-xorg-video-ati
    dpkg-reconfigure -phigh xserver-xorg

    Then back up your xorg.conf located at /etc/X11/xorg.conf

    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

    Then I edited the xorg.conf file located at /etc/X11/xorg.conf to look like this

    sudo gedit /etc/X11/xorg.conf

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "dbe"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
    EndSection

    Section "Device"
    Identifier "ATI Technologies Inc. Rage Mobility M3 AGP 2x"
    Driver "ati"
    BusID "PCI:1:0:0"
    VideoRam 8192
    Option "AgpMode" "2"
    Option "EnablePageFlip" "true"
    Option "Accel" "true"
    EndSection

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 28-70
    VertRefresh 43-60
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies Inc. Rage Mobility M3 AGP 2x"
    Monitor "Generic Monitor"
    DefaultDepth 16
    EndSection

    Section "DRI"
    Mode 0066
    EndSection

    #
    #
    #Section "Device"
    # Identifier "Configured Video Device"
    #EndSection
    #
    #Section "Monitor"
    # Identifier "Configured Monitor"
    #EndSection
    #
    #Section "Screen"
    # Identifier "Default Screen"
    # Monitor "Configured Monitor"
    # Device "Configured Video Device"
    #EndSection
    #
    #

    Save the file and reboot

    sudo reboot

    If you just copied and pasted that xorg.conf file above you should have booted up in 1024x768 resolution and if you run glxinfo in terminal direct rendering should say yes

    my glx gears were at 420 in 5 seconds when i started this project two weeks ago and about 1 hours ago i finished with the instructions described (i just found them a little before that it didn't take me two weeks to follow them)

    glxgears

    3571 in 5 seconds

    I tested on a myspace app Dragon wars it ran very slow and that is no where near the games out there today but it worked. Hope someone finds this useful

  7. #7
    Join Date
    Dec 2008
    Beans
    2

    Re: How do I enable direct rendering on an ATI Rage Mobility M3?

    Quote Originally Posted by dmatthys View Post
    I'm Not sure about distribution differences, but this worked for me on Xubuntu 8.10 with the same hardware.
    I used your xorg.conf on my old Winbook Z1 laptop with the same video device with both 8.04 and 8.10 and it worked to get it to 1024x768. I have only been using Ubuntu for about two weeks and the screen resolution was my only issue.

    Thanks

  8. #8
    Join Date
    Nov 2008
    Location
    Hawley, Pennsylvania USA
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How do I enable direct rendering on an ATI Rage Mobility M3?

    glad it could help someone you can find online modeline generators to generate modelines for higher resolutions if you need them then you just add them to the list that is there

  9. #9
    Join Date
    Mar 2009
    Beans
    3

    Re: How do I enable direct rendering on an ATI Rage Mobility M3?

    Quote Originally Posted by dmatthys View Post
    If you just copied and pasted that xorg.conf file above you should have booted up in 1024x768 resolution and if you run glxinfo in terminal direct rendering should say yes
    Thank you so much for figuring this one out - I've been tearing my hair out trying to get Kubuntu to boot at 1024x768 on my old C600, and this did the trick!

    By the way, if I only need 2D, do I have to worry about direct rendering? And if not, is there a way of doing 24 bit display depth instead? I did try setting the DisplayDepth line in the xorg.conf above to 24, but the result was a white screen and then a fully functional but completely invisible KDE desktop

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •