Results 1 to 6 of 6

Thread: how to disable automount in 8.04 hardy heron

  1. #1
    Join Date
    Dec 2006
    Location
    Missoula - Montana - USA
    Beans
    45
    Distro
    Ubuntu 10.04 Lucid Lynx

    how to disable automount in 8.04 hardy heron

    Greetings all, I'm having a bugger of a time installing UT2004 and I believe it is due to automount issues. I have the DVD version and after entering the CD-key, it begins the installation and then keeps telling me to Please mount the Unreal Tournament 2004 Play Disc CDROM. Unmounting and remounting the disc does not work.

    While running Gutsy (7.10) the installation worked fine by simply running:
    Code:
    sudo ln -s /media/cdrom0 /media/dvd
    export SETUP_CDROM=/media/dvd/
    mount /media/cdrom0 
    sudo sh /media/cdrom0/linux-installer.sh
    as mentioned in another thread on this forum: http://ubuntuforums.org/showthread.php?t=729319

    This time, it fails running it any way that I've tried. I saw the post by AWalton at http://ubuntuforums.org/showthread.php?t=729319, and I've taken those steps and more. Not only have I told the system to do nothing when any device is connected, I've also tried selecting the "Never prompt or start programs on media insertion" option within Nautilus >> Edit >> Preferences >> Media tab.

    So, it's not just autorun, it's automount I am having a problem with. How do I disable the automount feature in ubuntu 8.04 hardy heron?

  2. #2
    Join Date
    Jun 2007
    Beans
    320
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: how to disable automount in 8.04 hardy heron

    In the configuration editor:
    apps/nautilus/preferences/media _ automount

    Multiple choices... Including "never"

  3. #3
    Join Date
    Oct 2007
    Location
    Siberia
    Beans
    217
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: how to disable automount in 8.04 hardy heron

    You can also stop hal
    Code:
    sudo /etc/init.d/hal stop
    to stop hardware detection completely, but this is not recommended.

    But is this what you realy want to do?
    Registered Ubuntu User # 18873.
    We all create a new world.

  4. #4
    Join Date
    Dec 2006
    Location
    Missoula - Montana - USA
    Beans
    45
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: how to disable automount in 8.04 hardy heron

    Thanks guys. Looks like the gconf-editor option is a go. You're right that I don't want to disable hardware detection, but I found I could run
    Code:
    hal-disable-polling --device /dev/scd0
    if I want to narrow the scope, which is something I might want to do.

    Turns out these didn't help my ut2004 installation problem though. I went back to an older thread (http://www.backports.ubuntuforums.or....php?p=4819407)I used with gutsy to get ut2004 installed and found someone else stumbled upon the solution for installing it in hardy. Seems you have to mount the cd as an ISO9660 image instead of the default UDF. Then it works. Thanks again guys, as I will have need of disabling automounting in other situations I'm sure and this thread will come in handy later.

  5. #5
    Join Date
    Jun 2008
    Location
    Finland Vantaa
    Beans
    28
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: how to disable automount in 8.04 hardy heron

    Quote Originally Posted by bmac View Post
    In the configuration editor:
    apps/nautilus/preferences/media _ automount

    Multiple choices... Including "never"
    This doesn't work for internal harddrives. How to disable automount of internal harddrives? I'm having problems in boot-up because system runs e2fsck for my /home directory, which is already mounted.

    Antti

  6. #6
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,510
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: how to disable automount in 8.04 hardy heron

    Quote Originally Posted by antti64 View Post
    This doesn't work for internal harddrives. How to disable automount of internal harddrives? I'm having problems in boot-up because system runs e2fsck for my /home directory, which is already mounted.

    Antti
    Internal drive are mounted by /etc/fstab - and that also has scan on boot settings.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •