Results 1 to 7 of 7

Thread: Apt-get failing

  1. #1
    Join Date
    May 2006

    Apt-get failing

    Hey Everyone,

    I'm running a server with Dapper Server installed on it. I've had it running for about 1.5 years with no problems at all. However, now when I try to install something, I get the following:

    admin@DapperServer:/etc/apt$ sudo apt-get install bind9
    Reading package lists... Done
    Building dependency tree... Done
    The following extra packages will be installed:
      libdns21 libisc11 libisccc0 libisccfg1
    Suggested packages:
    The following NEW packages will be installed:
    The following packages will be upgraded:
      libdns21 libisc11 libisccc0 libisccfg1
    4 upgraded, 1 newly installed, 0 to remove and 83 not upgraded.
    Need to get 1137kB of archives.
    After unpacking 721kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    0% [Connecting to (]
    It just hangs while trying to connect to My tracepath looks like:

     1: (                          0.366ms pmtu 1500
     1: (                            asymm 36   1.634ms 
     2: (                               10.512ms 
     3: (                         21.382ms 
     4: (                         17.991ms 
     5: (  22.038ms 
     6: (                         35.937ms 
     7: (                           27.181ms 
     8: (     58.297ms 
     9: (                        125.587ms 
    10: (                          163.730ms 
    11: (      139.487ms 
    12: (                        151.579ms 
    13: (                     169.665ms reached
         Resume: pmtu 1500 hops 13 back 13
    I haven't installed anything that would effect this, and none of this traffic would be getting blocked on my end. Any ideas on what might be going on? Is anyone else having this problem?


  2. #2
    Join Date
    Apr 2008
    Novi Sad, Serbia
    Hardy Heron (Ubuntu Development)

    Re: Apt-get failing

    Same problem with me. I have tried several times to do sudo apt-get update, and when it should connect to, terminal line just stands there, and no responce at all. I tried like 3 times, and eventualy, I've downloaded that 400 bytes I've waited for 20 minutes.
    Macbook owner. Ubuntu 8.04 Hardy Heron & Mac OS X 10.4 Tiger user.
    Life is a big char, so just sit & enjoy.
    #include <brain.h>

  3. #3
    Join Date
    May 2006

    Re: Apt-get failing

    Still, it shouldn't be lagging (if it could be called that) this badly. Any ideas on WHY this is happening?

  4. #4
    Join Date
    Jan 2007
    Plano, TX

    Re: Apt-get failing

    Only a Canonical/Ubuntu admin can actually say, but we just released Hardy... I would expect a *lot* of people upgrading. Response time will be from bad to extremely bad.

    It might be a good idea to try a mirror instead of the main archive.
    Hoc volo, sic jubeo, sit pro rationa volontas.

  5. #5
    Join Date
    Jun 2007
    SO ILL
    Ubuntu Development Release

    Re: Apt-get failing

    There has to be something wrong here. It can't just be high network traffic.
    The last update I preformed was one day prior to the final release of hardy. Repos are now failing (security and archive (and also remastersys repo that has nothing to do with the ubuntu repos)) and I have not been able to receive a single update since. The strange thing is that update manager reports "the package information was last updated 5 days ago."
    Last edited by Scotty Bones; April 25th, 2008 at 04:44 PM.
    Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy, its inherent virtue is the equal sharing of misery - Winston Churchill

  6. #6
    Join Date
    Jun 2006
    Ubuntu 9.04 Jaunty Jackalope

    Re: Apt-get failing

    I want to say it's largely a load-balancing problem. Here's my suggestion:

    System - Administration - Software Sources

    Ubuntu Software Tab - "Download from" drop down menu - Other - Select Best Server

    This little known utility will do a pretty good job of picking a good server based on the response time it gets from them. I had the same problem you all are having until I did this and now can max out my connection from an MIT mirror.
    In Maryland? Join the Maryland Team!

  7. #7
    Join Date
    Aug 2007
    Ubuntu 12.04 Precise Pangolin

    Re: Apt-get failing

    Its been so slow because of Hardy's release. apt-get installs took ages to download small packages! However, the speed was improving over time.
    Report Ubuntu bugs here: Ubuntu Launchpad.
    Ubuntu Lucid 10.04 32-bit Desktop

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts