Page 5 of 56 FirstFirst ... 345671555 ... LastLast
Results 41 to 50 of 554

Thread: HOWTO: Wacom in 8.04 Hardy

  1. #41
    Join Date
    Apr 2008
    Beans
    5

    Re: HOWTO: Wacom in 8.04 Hardy

    Quote Originally Posted by mykes View Post
    It seems you have joined two commands together.

    cd linuxwacom-0.7.9-11

    and

    ./configure

    should be typed on separate lines
    Yes, it was my bad. I didn't realise I had to press enter more than once during Step 5 so I still had a command left to enter when I added the next one.

    I have now got the tablet working though had to follow the extra step in order to have hover sensing working.

    Big thanks for this guide =D>

    I've no idea why these things need to be so complicated, Ubuntu is supposed to be easy to use

  2. #42
    Join Date
    Mar 2008
    Beans
    21

    Re: HOWTO: Wacom in 8.04 Hardy

    worked great no problems, and i'm brand new to linux, just installed ubuntu today

  3. #43
    Join Date
    Dec 2007
    Beans
    1

    Re: HOWTO: Wacom in 8.04 Hardy

    It works perfectly by step 16
    Thank you very much

  4. #44
    Join Date
    Apr 2008
    Beans
    7

    Re: HOWTO: Wacom in 8.04 Hardy

    Quote Originally Posted by rajivnavada View Post
    Thanks for your reply Neko18. Here is the output from the 2 commands you requested. It seems like I might have done something wrong but I can't figure out what.

    When I follow step 19) of the How-To, and then issue the command wacomcpl, I get the blank dialog box like in the screenshot I attached in post #25. At this time if I try "sudo wacdump /dev/input/wacom" I get a nice terminal screen where everything seems to be working great. It seems like wacdump detects everything from the stylus in pen-mode or eraser mode and also I get the line at the top where wacdump shows the input streams etc...

    However, when I restart the computer and then issue the command (wacomcpl), I get the dialog box with "pad" listed. Clicking on pad is no use and I can't really do much except exit. Now when I try wacdump, the input stream line does not show and also the different modes of the stylus are not recognized. Almost seems like there is some driver that is conflicting with the wacom driver. Another note here: after running these 2 commands when I make an error in typing in the terminal (anything that normally results in a system beep), X shuts down and I need to re-login.

    Sorry for all this rambling but maybe this extra info might help you debug this problem.

    Thanks.

    hi guys, just like to thank neko and the others for all there help and patience. anyways i've been following rajivnavada's post and i get the same problem on my HP tx2000 with the exact same outputs that he posted and same goes for problem wacomcpl. As for my tablet it works fine with the pen eraser and side button but the touchscreen with my fingers is really off.

    sorry if this post is unspecific i'm very new to ubuntu.

  5. #45
    Join Date
    Apr 2008
    Beans
    10

    Re: HOWTO: Wacom in 8.04 Hardy

    Quote Originally Posted by mykes View Post

    Both the linuxwacom-0.7.9-11.tar.bz and the 0.8 version do not compile in step 6 for me. I had to hack the Makefile to add a -I for the compiler to find pixman.h
    I'm having the same issue whereas "make" kicks out this error:

    Code:
    /usr/include/xorg/miscstruct.h:54:20: error: pixman.h: No such file or directory
    What exactly did you do to the Makefile for it to work? Thanks in advance.

  6. #46
    Join Date
    Apr 2008
    Beans
    2

    Re: HOWTO: Wacom in 8.04 Hardy

    I've had **almost** complete success getting my Intuos 3 working on Hardy with the OP's instructions in post #1. Thanks a TON to neko for posting this and for all the subsequent guidance.

    Two little quibbles remain: the command 'wacomcpl' shows no devices at all, just a basically blank dialog box except for the "exit" command; and the mouse itself is insensitive/inconsistent with respect to the normal left-button click -- sometimes I have to click two or three times before it is recognized.

    If someone could suggest ways to address the above, I'd be very grateful!

    Thanks -- pmosher

  7. #47
    Join Date
    Jul 2005
    Beans
    304
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Wacom in 8.04 Hardy


  8. #48
    Join Date
    Dec 2005
    Location
    Nowhere!
    Beans
    180
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Wacom in 8.04 Hardy

    @rajivnavada
    Follow my instructions for mykes later in this post.

    @not_surt
    Try running through the guide again. If that doesn't work, you can try installing the new 0.8.0 driver (if you don't know how, ask and I'll post instructions when I get a chance).

    @mykes
    1. Open a terminal

    2.
    Code:
    xidump stylus
    3. Move the pen to the upper left corner of the screen and record the "x-axis" and "y-axis" values from the "data" row.

    4. Repeat step 3 with the upper right, lower left, and lower right corner.

    5. Record the "min"/"x-axis", "max"/"x-axis", "min"/"x-axis", and "max"/"x-axis" values.

    6. Reply with those values in your post. Make sure you label which value is which.

    @rospo84
    Try running through the guide again.

    @btnelson
    Follow my instructions for mykes from this post.

    @Icemanyurt
    You missed a line while copying the text into xorg.conf. Here's how to fix it:
    1. Open a terminal

    2.
    Code:
    gksudo gedit /etc/X11/xorg.conf
    3. Find the text that looks like this:
    Code:
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"pad"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"pad"
    	Option		"USB"		"on"

    4. Replace it with this
    Code:
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"pad"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"pad"
    	Option		"USB"		"on"
    EndSection
    5. Save (Ctrl-S) and quit (Ctrl-Q)

    6. Log out then log back in or reboot your computer

    @MikLSP
    I agree, I think Canonical should make Wacom tablets work by default.

    @louishr and @donGoGo
    I'm glad it worked for you

    @r32inc
    Follow my instructions for mykes earlier in this post.

    @provide
    I'm not sure what the problem is with the Makefile. mykes should be able to help you though.

    @pmosher
    First issue: Don't use `wacomcpl`. It doesn't really have anything useful anyway.

    Second issue: It's the same for me. I think it's the hardware though, since I experience the same behavior in multiple operating systems. I use the pen as my primary pointing device and only switch to the mouse if my friends are using my computer (since they're not used to a tablet).

    @nitricacid
    That's what this guide explains how to install

  9. #49
    Join Date
    Apr 2008
    Beans
    21

    Re: HOWTO: Wacom in 8.04 Hardy

    I had already run though a second time with linuxwacom-0.7.9-11 in case I missed anything.

    After going through the process with linuxwacom-0.8.0 the only change is that wacomcpl now lists the devices, though it shows an error message when selecting a device after the first selection.

    Still no pressure sensitivity.

    Thanks for all your help anyway.

  10. #50
    Join Date
    Apr 2008
    Beans
    2

    Re: HOWTO: Wacom in 8.04 Hardy

    Thanks for the speedy reply, neko18. I won't bother with wacomcpl. Everything's working fine anyway with the exception of the click issue I mentioned earlier. Pressure sensitivity is fine, even within WinXP and Photoshop under vmware.

    pmosher

    P.S. For those who are struggling with a tablet within VirtualBox without success -- i.e. no pressure sensitivity -- try vmware server instead. I know it's a more heavyweight solution than you may otherwise require, but at least the tablet works completely within the wirtual machine.

Page 5 of 56 FirstFirst ... 345671555 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •