Results 1 to 2 of 2

Thread: Hardy heron XORG problems

  1. #1
    Join Date
    May 2006
    Beans
    71

    Hardy heron XORG problems

    Hello, I did a clean install of hardy heron, and all is fine except for the screen resolution.

    I have 2 monitors and both detect as plug and play monitor, one is a samtron 98dp ( which I can actually fix by using another samtron monitor in the old config utility /usr/bin/display-config-gtk or somehting like it) but then I loose acces to my ctrl+alt+f# consoles...

    The other monitor and the one I d really like to get going is a Dell 2007 wfp, through the VGA port

    The option in the old config script for it exists, but when I select it I get the extended desktop ( the one that is bigger than your screen and you have to move your mouse around and it movs the screen...)

    So i went to my /etc/X11/xorg.conf, and to my amazement, its very SMALL, its not like the old one that had a lot of screen options for resolution depth etc... nothing its very minimal ( i m not at that computer ATM so cant post it)

    Is there a new file in hardy heron?? if so where is it.

    Any advice on how to configure this properly, i tried https://wiki.ubuntu.com/FixVideoResolutionHowto and could not get it to work properly, installed 915resolution and did not do anything with it aftewards ( did not know where to run it),

    my graphics dirver is a 2 year old intel chipset so pretty standard

    by the way
    Code:
    sudo dpkg-reconfigure xserver-xorg
    asks only questions about keyboard layout, not about screen resoltuion like it used to....
    thank you in advance

    Charles

  2. #2
    Join Date
    Mar 2008
    Location
    Southampton, UK
    Beans
    Hidden!

    Re: Hardy heron XORG problems

    the new xorg in hardy tries to autoconfigure everything, and usually fails. Well it failed on both my PC's, I ended up making it start in low graphics mode so that it loaded the config util, chose a monitor 'close' to mine (instead of it picking plug and play)
    Then once it had done it's stuff, I'd install the nvidia drivers with envyNG. then use nvidia settings to properly fix xorg.conf

    In the end, instead of the daft xorg.conf by default I now have:

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@vernadsky)  Tue Mar  4 20:24:34 UTC 2008
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
    EndSection
    
    Section "Module"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "gb"
    EndSection
    
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "vmmouse"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ExplorerPS/2"
        Option "Emulate3Buttons" "false"
        Option "Buttons" "7"
        Option "ZAxisMapping" "4 5"
        Option "ButtonMapping" "1 2 3 6 7"
    EndSection
    
    Section "Monitor"
        # HorizSync source: xconfig, VertRefresh source: xconfig
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "CRT-0"
        HorizSync       31.0 - 60.0
        VertRefresh     55.0 - 75.0
        ModeLine       "1280x854" 80.0 1280 1309 1460 1636 854 857 864 896 +hsync +vsync
        ModeLine       "1280x768@75" 103.0 1280 1360 1496 1712 768 769 772 802 -hsync +vsync
        ModeLine       "1280x768@60" 80.1 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
        ModeLine       "1280x720@60" 74.5 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
        ModeLine       "1152x768@54" 65.0 1152 1178 1314 1472 768 771 777 806 +hsync +vsync
        ModeLine       "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
        Option         "DPMS"
    EndSection
    
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 7300 GT"
    EndSection
    
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "1280x854 +0+0; 1440x900 +0+0; 1280x960 +0+0; 1024x768 +0+0; 800x600 +0+0; 1152x768@54 +0+0; 640x480 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    ugly, but at least it works

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •