Page 8 of 16 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 156

Thread: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

  1. #71
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    Normally it should have autodetected the "ati" card, I don't know why it opted to use the fallback "vesa" driver, normally that Driver line isn't even there when you reconfigure in Hardy. Could be because of faulty hardware, a bug in X, or a bug in the ati driver. As far as the slowness in firefox, I really don't have an answer for you. You have to remember that this a workaround since the open source drivers are blacklisted for compiz to begin with.
    You may consider starting another thread in this forum so others can try and help you, rather than just me. There have been all kinds of problems with Compiz and Hardy, I'm actually surprised they let Compiz come preinstalled in Hardy which is a LTS version of Ubuntu. Sorry I couldn't nail it down for you, good luck.

  2. #72
    Join Date
    Feb 2006
    Location
    NanJing, China
    Beans
    73
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    I can confirm that, after did
    Code:
    sudo dpgk-reconfigure xserver-xorg -phigh
    It gets back 3D acceleration and compiz effect to Hardy (i upgraded from Gusty). However, you still need to do the trick given in the first post to enable compiz. However, I just want 3D acceleration, but not compiz (i am in fluxbox).

    P.S. I'm using ATI Radeon 9000.
    Think independently.

  3. #73
    Join Date
    Apr 2008
    Beans
    6

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    Quote Originally Posted by Rocket2DMn View Post
    Did you upgrade from Gutsy? The new X doesn't like xorg.conf as much as it used to, so you should try reconfigured X to get a more generic xorg.conf and let X do its new autodetection thing at runtime:
    Code:
    sudo dpkg-reconfigure xserver-xorg -phigh
    then restart X with CTRL+ALT+BACKSPACE
    Hi Rocket,
    I did as you suggested. I issued the following command:
    Code:
    sudo dpkg-reconfigure xserver-xorg -phigh
    and the output of my xorg.conf file after issuing the above command is:

    Code:
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    EndSection
    But when i do enable compiz, the issue with slow scrolling in firefox still exists
    Is this a problem with my card? or hardy ?

  4. #74
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    The_Seeker, I honestly don't know - it could be either. You are not the only person to experience this problem, I have seen other threads with this. Although I don't know if anybody has found a solution, you should search around to see if you find anything. If you do find a fix, please let us know. I really need to start compiling a collection of known (or at least sometimes successful) fixes.

    bronsoja, if you are still reading this thread, have a look here: https://bugs.launchpad.net/ubuntu/+s...iz/+bug/209207

  5. #75
    Join Date
    Oct 2007
    Location
    Boulder, CO
    Beans
    23
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    Tried the above method and recieved this:

    pat@Herbert:~$ compiz --replace
    Checking for Xgl: present.
    Checking for nVidia: not present.
    Checking for Xgl: present.
    Enabling Xgl with fglrx ATi drivers...
    Starting gtk-window-decorator
    /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
    GConf backend: There is an unsupported value at path /apps/compiz/plugins/scale/allscreens/options/initiate_edge. Settings from this path won't be read. Try to remove that value so that operation can continue properly.




    just wondering what to do fix fix it

    thanks

  6. #76
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    It says you are using the fgrlx restricted drivers, what is your video card?
    Code:
    lspci | grep VGA
    Also, have a look at this bug report - https://bugs.launchpad.net/ubuntu/+s...iz/+bug/209207

  7. #77
    Join Date
    Mar 2008
    Beans
    Hidden!

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    Hello,

    I'm having a problem with my graphics card/drivers, using ATI Radeon HD 2400 XT. When I move any window or if I scroll in a window (f.e. Firefox) a huge flickering appears and it takes a lot of time till the window gets to the place I actually moved it to (I created a thread to find a solution for this problem, with no success, yet). I'm not using any special effects or compiz at this time.
    I have tried to install drivers with Envy, which didn't work. I also tried to install drivers from the ATI site, which didn't help either (actually I'm not sure if I even installed it correctly (?) ...).

    Anyway, "$ glxinfo | grep -i direct" returns
    Code:
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    OpenGL renderer string: Mesa GLX Indirect
    As far as I know, direct rendering should return "yes", but I have no clue how to activate it.
    I'm new to Ubuntu and all that driver stuff, so I hope someone can help me because I'm really totally lost (and I can hardly use ubuntu with this annoying problem ...).

    Thank you.

    Best regards,
    terrorsathan

  8. #78
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    Quote Originally Posted by terrorsathan View Post
    Hello,

    I'm having a problem with my graphics card/drivers, using ATI Radeon HD 2400 XT. When I move any window or if I scroll in a window (f.e. Firefox) a huge flickering appears and it takes a lot of time till the window gets to the place I actually moved it to (I created a thread to find a solution for this problem, with no success, yet). I'm not using any special effects or compiz at this time.
    I have tried to install drivers with Envy, which didn't work. I also tried to install drivers from the ATI site, which didn't help either (actually I'm not sure if I even installed it correctly (?) ...).

    Anyway, "$ glxinfo | grep -i direct" returns
    Code:
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    OpenGL renderer string: Mesa GLX Indirect
    As far as I know, direct rendering should return "yes", but I have no clue how to activate it.
    I'm new to Ubuntu and all that driver stuff, so I hope someone can help me because I'm really totally lost (and I can hardly use ubuntu with this annoying problem ...).

    Thank you.

    Best regards,
    terrorsathan
    Unfortunately you are asking in the wrong place since this thread is for those using the open source ati drivers which you card does not take. If I remember correctly, you should be using the radeonhd driver. You seem to have one of the newer, more advanced cards that is still lacking support in linux. You might start with removing the proprietary drivers you installed, reconfiguring X (see posts 72 and 73 on this page), then reinstalling the restricted drivers. Good luck.

  9. #79
    Join Date
    Mar 2008
    Beans
    Hidden!

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    Quote Originally Posted by Rocket2DMn View Post
    Unfortunately you are asking in the wrong place since this thread is for those using the open source ati drivers which you card does not take. If I remember correctly, you should be using the radeonhd driver. You seem to have one of the newer, more advanced cards that is still lacking support in linux. You might start with removing the proprietary drivers you installed, reconfiguring X (see posts 72 and 73 on this page), then reinstalling the restricted drivers. Good luck.
    I see ... didn't know that my card doesn't support open source drivers .
    Anyway, I'll try to do what you said, lets see if it works.

    Thank you.
    Best regards

    EDIT:
    I executed sudo dpkg-reconfigure xserver-xorg -phigh which returned
    Code:
    xserver-xorg postinst warning: overwriting possibly-customised configuration
       file; backup in /etc/X11/xorg.conf.20080505212715
    Doesn't look too good ...
    Last edited by terrorsathan; May 5th, 2008 at 08:30 PM.

  10. #80
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: HowTo: Compiz Fusion in Hardy on cards with "ati"/"radeon" open source drivers

    That is normal, it's just making a backup of your existing xorg.conf file in the format of xorg.conf.YearMonthDayTime and replacing xorg.conf with the stuff it's generating.

Page 8 of 16 FirstFirst ... 678910 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •