Quote Originally Posted by rekster View Post
Have problems as well, please pardon me if I misread or missed something said earlier in these posts, I did read them.

Running Ubuntu 8.04 on Acer Ferrari 4000 notebook that has ATI X700.
I enabled the ATI accelerated graphics driver as well which seemed to work well as 3d gaming is great (not sure if this has anything to do with compiz though lol)

This is the console log:

$ compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 1002:5653 (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
GConf backend: There is an unsupported value at path /apps/compiz/plugins/scale/allscreens/options/initiate_edge. Settings from this path won't be read. Try to remove that value so that operation can continue properly.

Any suggestions?
With your card, you need the restricted ati drivers called fglrx - is that what you are saying you installed? If not, check out EnvyNG - http://albertomilone.com/envyngfaq.html#A
If the problem persists, you may want to reinstall compiz
sudo apt-get remove --purge compiz
sudo apt-get install compiz
If that doesn't work, you should start a new thread to get help with that since this HowTo is for open source ati drivers which you can't use on your card.