Results 1 to 4 of 4

Thread: Problem Hauppauge Nova-T USB2 remote in LIRC

  1. #1
    Join Date
    Feb 2007
    Location
    Madrid
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    [SOLVED ]Problem Hauppauge Nova-T USB2 remote in LIRC

    I've been running Mythtv with Hauppauge Nova-T USB2 (DVB-T turner) in the server for some time. Now I have moved the turner to the HTPC in the living room and would like to use the remote that comes with the turner, but I am getting some trouble configuring it with LIRC.

    I've followed the directions given in the following post:
    http://ubuntuforums.org/showthread.php?t=678835
    and everything works except that when I press a button once the IR-receiver interprets it as two consecutive entries... thus, in mythtv menu I cannot select all entries (jumps two possitions).

    As an example When I check with irw if I press Down, Up and Right, I get the output:

    jose@X2BE:~$ irw
    000000000001006c 00 down hauppauge_nova-t-usb2
    000000000001006c 00 down hauppauge_nova-t-usb2
    0000000000010067 00 up hauppauge_nova-t-usb2
    0000000000010067 00 up hauppauge_nova-t-usb2
    000000000001006a 00 right hauppauge_nova-t-usb2
    000000000001006a 00 right hauppauge_nova-t-usb2


    I remember reading someone having a the same problem some time ago, but I have found no answer searching the forums or googling. I have also tried to change repeat and delay options in .lircrc but with no luck.

    Does anyone know a solution or workaround I could use Or how could I proceed to troubleshoot the problem?

    Thank you very much.
    Last edited by CarloMagno; April 24th, 2008 at 07:11 PM. Reason: Problem solved

  2. #2
    Join Date
    Feb 2007
    Location
    Madrid
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Problem Hauppauge Nova-T USB2 remote in LIRC

    I have solved the problem, it seems that the config file generated by irecord (lircd.conf) had one line wrong.

    I checked the lircd.conf file generated against the one posted in mythtv.org:

    http://www.mythtv.org/wiki/index.php...TV_Nova-T_USB2

    and found that where I had toggle_bit_mask .. (some Hex value) in the file posted in mythtv there was "toggle_bit 0".
    That was all, I changed that line and now everything works. Checking with irw I get only one entry per each key stroke..

    In case anyone is interested i will post my /etc/lirc/lircd.conf file for this remote with all the keys recognized. Be aware thay as suggested in the link of my first post I had changed the names of the keys, so you have to change also the file .lircrc in order to get the keys recognized. Please read that link carefully before replacing your lircd.conf file and do a backup before replacing it (sudo cp /etc/lirc/lircd.conf /etc/lirc/lircd.conf.backupToday)

    Code:
    # Please make this file available to others
    # by sending it to <lirc@bartelmus.de>
    #
    # this config file was automatically generated
    # using lirc-0.8.2(dev/input) on Tue Apr 15 21:32:47 2008
    #
    # contributed by 
    #
    # brand:                       lirc.out1
    # model no. of remote control: 
    # devices being controlled by this remote:
    #
    
    begin remote
    
      name  hauppauge_nova-t-usb2
      bits           16
      eps            30
      aeps          100
    
      one             0     0
      zero            0     0
      pre_data_bits   16
      pre_data       0x1
      gap          199999
      toggle_bit 0
    
          begin codes
              go                       0x0162
              power                    0x0074
              tv                       0x0179
              videos                   0x0189
              music                    0x0188
              pictures                 0x00E2
              guide                    0x016D
              radio                    0x0181
              ok                       0x0160
              up                       0x0067
              down                     0x006C
              left                     0x0069
              right                    0x006A
              back                     0x009E
              menu                     0x008B
              vol+                     0x0073
              vol-                     0x0072
              ch+                      0x0192
              ch-                      0x0193
              prev                     0x016B
              mute                     0x0071
              record                   0x00A7
              stop                     0x0080
              rew                      0x00A8
              ffw                      0x00D0
              play                     0x00CF
              pause                    0x0077
              skipback                 0x0195
              skipfwd                  0x0197
              1                        0x0002
              2                        0x0003
              3                        0x0004
              4                        0x0005
              5                        0x0006
              6                        0x0007
              7                        0x0008
              8                        0x0009
              9                        0x000A
              0                        0x000B
              star                     0x0037
              hash                     0x0029
              red                      0x018E
              green                    0x018F
              yellow                   0x0190
              blue                     0x0191
          end codes
    
    end remote
    
    

  3. #3
    Join Date
    Oct 2010
    Beans
    7

    Re: Problem Hauppauge Nova-T USB2 remote in LIRC

    CarloMango,

    I have been beating my head against the wall with a NovaTD remote....

    The DVB stuff works a treat, but I just cannot get the remote to work at all.

    Any chance that I can grab the configs you are using? The remote that I have is labelled "DSR-0101" inside the battery compartment.

    Any assistance you can offer would be appreciated.

    luke

  4. #4
    Join Date
    Feb 2007
    Location
    Madrid
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Problem Hauppauge Nova-T USB2 remote in LIRC

    Isheaves,sorry for answering this mail a year later, I have had no time to fiddle with Ubuntu this last year.
    For the remote part I can't remember how I got it working in the past and I have lost the config files... the funny thing is that i had some time today and thought it would be a good idea to configure the remote in the new release (11.10) I looked for info in the forums of how to get it working and didn't notice i was reading my 1yr old post until I saw yours... incredible how fragile is my memory.
    Regarding the remote you can see I am of no help now. Last time I checked It was a PITA to set the remote as i liked and thought that perhaps with the new Input2 method all the keys would be associated to an event by the kernel but I have to dig a bit about it.
    (I decide to use a small RF keyboard with trackball instead of a remote.. very useful for writing and surfing but too big to use it as a remote

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •