Results 1 to 5 of 5

Thread: Display problem after installing nvidia display driver

  1. #1
    Join Date
    Apr 2008
    Beans
    2

    [SOLVED] Display problem after installing nvidia display driver

    Hi, I have been installing a display driver from Nvidia's website, after I reboot, I get a message saying I have low resolution, and my screen turns to 800x600 and all the visual effects and not working, do anyone know how I can restore my old driver?
    By the way, I think my xorg.conf is damaged too.

    This is my xorg.conf:

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (wilfred@Wilfred-PC) 三 4月 23 00:49:43 CST 2008

    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "ServerLayout"

    # Uncomment if you have a wacom tablet
    # InputDevice "stylus" "SendCoreEvents"
    # InputDevice "cursor" "SendCoreEvents"
    # InputDevice "eraser" "SendCoreEvents"
    Identifier "Default Layout"
    Screen "Default Screen" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "Synaptics Touchpad"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizEdgeScroll" "0"
    EndSection

    Section "InputDevice"
    Identifier "stylus"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Identifier "eraser"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Identifier "cursor"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "Monitor"
    Identifier "Generic Monitor"
    HorizSync 28.0 - 64.0
    VertRefresh 43.0 - 60.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300]"
    Driver "nvidia"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300]"
    Monitor "Generic Monitor"
    DefaultDepth 16
    SubSection "Display"
    Depth 16
    Modes "1280x800"
    EndSubSection
    EndSection
    Last edited by wilfredlam; April 23rd, 2008 at 07:06 AM.

  2. #2
    Join Date
    Feb 2007
    Beans
    13

    Re: Display problem after installing nvidia display driver


  3. #3
    Join Date
    Apr 2008
    Location
    USA
    Beans
    1,097
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Display problem after installing nvidia display driver

    I have the same problem. I dual boot Windows and Linux. I can't figure it out. I'm new to Linux so I'm not much help.

  4. #4
    Join Date
    Apr 2008
    Location
    USA
    Beans
    1,097
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Display problem after installing nvidia display driver

    Hey, I fixed it. I just chose every single resolution and it seemed to adjust itself. I chose every resolution until it adjusted itself to the resolution I wanted (1280x1024). Try it.

  5. #5
    Join Date
    Apr 2008
    Beans
    2

    Re: Display problem after installing nvidia display driver

    i sloved it, i removed the driver in ubuntu, and then use envy in recoverly mode and install the lastest driver and config it with the nvidia setting tool, and it worked, i got my 1280x800 back.

    1. Go to restricted drivers manager, untick the nvidia box
    2. sudo apt-get install envy
    3 . reboot to recovery mode
    4. type in envy -t, choose number 1
    5. if questioned, answer yes to every question
    6. reboot to normal
    7. login and go in to nvidia settings, make sure using sudo
    8. change 800x600 to auto
    9. apply and save
    10, reboot and see if it works

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •