Results 1 to 10 of 24

Thread: [solved]NVIDIA driver problems

Threaded View

  1. #1
    Join Date
    Apr 2008
    Beans
    18

    [solved]NVIDIA driver problems

    Im am a complete newbie to linux just so you know and I think its great so far. I've been on the edge of giving up and just booting back into vista but I've finally solved my problem and I'd like to share with others that may have the same problem. So far its maybe taken me ~6 hours to figure out. Its was like re-inventing the wheel. But besides that.

    I have the geforce 9600 gt so I used the beta drivers which are out i think 173.08. heres my guide:

    1. intall the driver from the internet <--edit sorry i didnt make it clear.
    just go to the site you get your driver from.

    2. press ctrl+alt+f1

    3. you have some options. you can log into root, use su command just su then log into root or you can use sudo before your commands. Its not that hard. For example when it asks for my username i type root then for password my root password. You can edit this in system--->admin--->users and groups. and just change the pass to what ever you want.

    4. Next step is to type the following go ahead and use sudo for good measures. But if your logged into root I dont think its needed. Im a newb so dont flame.command - sudo /etc/init.d/gdm stop
    this will stop the x server which is basically the gui. Correct me if im wrong.

    5. next is to get a kernal. My problem was when I was installing the first time it said the kernal module was missing. so type- sudo apt-get install update
    the type- sudo apt-get install build-essentials
    Worked for me but I really dont know what it does or what a kernal is even for. I'd like to know so could someone enlighten me?

    6. next is to run the driver. type- sh '/**/NVIDIA-Linux-x86-173.08-pkg1.run'

    ** depends on your file location. for example mine was
    sh '/home/enthrall/Desktop/NVIDIA-Linux-x86-173.08-pkg1.run'

    7. follow the instructions on screen. say yes to every thing. YES

    8. when its done type- sudo /etc/init.d/gdm start

    9. once logged back in do the following. this is a very important step do not miss or you will have to re install on next boot which was my
    problem.

    go to applications then terminal and type- nano /etc/default/linux-restricted-modules-common
    go down the page where is says something like DISABLED_MODULES= ""
    In between the quotations type nv and save this. To use the commands at the bottom use the ctrl key with the letter example- ^c-cancel
    you would press ctrl c. When you do this it asks if you want to save this type y and press enter. Then press enter again and restart the system. VOILÀ it should be working now.
    Last edited by Enthrall; April 23rd, 2008 at 10:22 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •