Results 1 to 4 of 4

Thread: Atheros wifi stopped working in Hardy

  1. #1
    Join Date
    Sep 2006
    Haddonfield, NJ
    Ubuntu 13.04 Raring Ringtail

    Question Atheros wifi stopped working in Hardy

    I have a Fujitsu Stylistic ST5112 Tablet PC that was working fine in Gutsy. I upgraded to Hardy the other day when the Release Candidate came out, and now the wireless doesn't work!

    After I upgraded, Hardy found my Atheros wifi card and hardware abstraction layer drivers. Before then, in Gutsy, I'm not sure which drivers I was using actually... but I guess not the Atheros ones. Anyway, now I can see the wireless networks with my cards, but I can no longer connect to them. When I try, the icon just spins around for 30 seconds or so and then gives up. I've tried disabling the new Atheros restricted drivers but all that does is make me unable to do anything with wireless.

    Does anyone know what might be going wrong, or how I might fix it?


  2. #2
    Join Date
    Mar 2007
    Denver, CO
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Atheros wifi stopped working in Hardy

    Boot into the old kernel and download the madwifi sources.

    Boot back into the new kernel (or simply download the madwifi sources and transfer them from another computer to the hardy computer).

    Install the build-essential and linux-header files from the installation disk.

    Compile and manually install the madwifi drivers. modprobe the madwifi kernel module, use it -- Enjoy!!!

    Get back to me if you need specific instructions.

  3. #3
    Join Date
    Sep 2008

    Re: Atheros wifi stopped working in Hardy

    I'm not sure, but I think that I have experienced something similar when I tried me on the Mint 6. edition. My network card was visible and apparently active. But it did not connect up.
    My question is: how to download madwifi sources to a place where I can find it again so that I can add files to a usb stick.

    And of course, how to find it again in the terminal window so that I get the error corrected when the new os is installed.

    Hope it is ok for me to interfere like this
    Last edited by nigj; November 23rd, 2008 at 02:10 PM.

  4. #4
    Join Date
    May 2007
    On a Repository
    Ubuntu Development Release

    Re: Atheros wifi stopped working in Hardy

    It broke on the upgrade to Hardy because you would have to compile again the driver.

    If you upgrade to Intrepid now and use the builtin driver you shouldn't worry about it anymore. Take a look at the wiki:

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts