Results 1 to 2 of 2

Thread: Aspell problem with currency symbol

  1. #1
    Join Date
    Dec 2007
    Beans
    386
    Distro
    Ubuntu 10.04 Lucid Lynx

    Aspell problem with currency symbol

    Hi there, I'm having a little problem with aspell:

    I am calling aspell to spell check a document and pipe the results to another document with the following command line:

    Code:
    aspell pipe < File1 > File2
    This works exactly as expected and the resulting file contains a series of lines that are either a * to show that the word is spelled correctly, or a line which includes the word, its position in the file, and a list of suggested corrections.

    However, if I type "£2" into the document to be checked (Just in case you cant see that symbol correctly it is a GBP (British Pound) symbol) all subsequent spelling mistakes after that symbol are reported to be one character position before they really are

    So for example, in the phrase "bad spilling", the start of the badly spelled word is in position 4. However, if a GBP symbol had been used before the badly spelled word, it would be reported as being in position 3, which is incorrect.

    Is this a bug of some kind with aspell, or am I missing some option or switch that will make this work. Iv tried setting the language to en-GB etc, but this doesn't seem to make any difference.

    Any help is much appreciated.

    Regards

    Max

  2. #2
    Join Date
    Dec 2007
    Beans
    386
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Aspell problem with currency symbol

    No command line gurus?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •