Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: can't see windows shares in nautilus

  1. #21
    Join Date
    May 2005
    Boston, MA, United States
    Ubuntu 11.04 Natty Narwhal

    Lightbulb Re: can't see windows shares in nautilus

    There are a ton of threads regarding using Nautilus to connect to Windows shared files; have a look around. As for more general Connect to Server issues in Nautilus, particularly the timeout error, see . The advice in that thread fixed the problem for me, but interestingly it didn't help on my boyfriend's computer at all, even though we have the same setup. Still trying to figure out what the issue is on his system.

    'To be nobody but yourself in a world which is doing its best, night and day, to make you like everybody else means to fight the hardest battle which any human being can fight; and never stop fighting.'
    --e.e. cummings

  2. #22
    Join Date
    May 2007

    Re: can't see windows shares in nautilus

    OK, so a new twist on this issue.

    I am currently developing an application that is going to leverage the libsmbclient library to browse samba shares. I am having the same issue, where for some reason, one of my test computers (Windows XP with public shares) is found, but no shares reported. The interesting twist, is this computer used to share just fine. It had a fixed IP address (I run my program in an isolated network for testing). Yesterday, I needed to activate the copy of Windows XP I had on the machine, so I plugged it into my companies main network to DHCP and get on the internet. That worked fine. Once activated, I changed the IP back to fixed and plugged it back into my test network. Since then, no shares are found. its almost like our company DHCP server, or the act of getting a DHCP address in Windows turned off something in samba on the XP box that was not turned back on when I went back to fixed IP.

    I get the SAME behavior using the Gnome file browser to view shares on that computer. It sees the Windows XP computer, but no shares are reported back.

    Now - If I open firefox, and simply do a smb://ip-address, I see the shares fine and can browse from there.

    Does the Nautalis use libsmbclient.a ? Any thoughts ?


  3. #23
    Join Date
    Jun 2008

    Re: can't see windows shares in nautilus

    GNOME Commander works for me, it sees all the shares.

  4. #24
    Join Date
    Feb 2006
    Ubuntu 9.04 Jaunty Jackalope

    Re: can't see windows shares in nautilus

    I dont understand why Nautilus and now Gnome-Commander isnt working properly. I was able to browse my windows network since I first installed Hardy, several months ago. Now after several updates, I cant browse my network. I did find that I could use firefox and use smb://ipaddress. This works just fine, as does using samba from the command line.Has anyone figured out what is wrong with Nautius and Gnome-Commander?


Page 3 of 3 FirstFirst 123


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts