Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Update Manager freezes

  1. #11
    Join Date
    Jan 2008
    Plymouth, MI, USA
    Ubuntu 8.04 Hardy Heron

    Re: Update Manager freezes

    It just doesn't start. I was running FF3 on a clean install Hardy. I needed a Java 5.0 plugin. I tried to install it that requires 6 downloads. But it didn't even start at one. Finally I had to cancel it. It showed me errors being not able to fetch data from the servers specially the one mentioned above.
    I think it is because of overloaded servers.
    Hope that much information helps someone to fix this.

    Ubuntu user # 20905, Linux User # 467410,
    Dell Inspiron 1505, 2GB RAM, Dual Boot with Vista.

  2. #12
    Join Date
    Mar 2007

    Re: Update Manager freezes

    Do you have any 3rd party repositories in your sources.list?

    The update process will crash with 3rd party repo's.

    I had this problem upgrading to Gutsy, and again trying to get the Hardy upgrade going.

    Once I backed up my sources.list and then changed it back to just the default repo's (don't just inactivate them, you need to delete them from your sources.list) the upgrade process stopped locking up.

    My updater is downloading the new packages now.....1168 or 1603...and counting.....

  3. #13
    Join Date
    Nov 2006

    Re: Update Manager freezes

    FWIW, here is a screen shot of an upgrade just before it hangs. I invoked it with gksu "sh /cdrom/cdromupgrade"
    Attached Images Attached Images

  4. #14
    Join Date
    Oct 2004

    Re: Update Manager freezes

    @cayhorstmann: that's exactly where my upgrade hangs.

    And the visual effects grey out that window within a second or two.

    I tried disabling all the third-party repos in synaptic, then I tried upgrading from the alt CD: same hanging at same place.

    Next I tried removing third-party repos from synaptic, and now I'm trying to upgrade from the alt CD and it didn't hang at that same place. It asks if I want to check for the lastest online updates online and I click NO. But at the very next item on the checklist (as pictured in the above screenshot), it gave me the error message:

    Could not calculate the upgrade

    A unresolvable problem occurred while calculating the upgrade.

    This can be caused by:
    * Upgrading to a pre-release version of Ubuntu
    * Running the current pre-release version of Ubuntu
    * Unofficial software packages not provided by Ubuntu

    If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

    OK, and upgrade continues. Next time I see the screen, and all the signs of upgrade are gone, no windows or messages or alerts of completion though. But I see hundred of updates are available with the little star. I disable all online repos and force it to grab packages from CD. Now it's working on that, and once they've been installed, I'll switch back to online repos for the rest and hope it all works.

    *crossed fingers*

    so in short, totally removing those third-party repos has let me get further in the upgrade with hiccups. It may even work now. I'll let you know once everything's installed and I restart the system.

  5. #15
    Join Date
    Oct 2004

    Re: Update Manager freezes

    ...and no dice.
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 124154 files and directories currently installed.)
    Preparing to replace human-theme 0.9 (using .../human-theme_0.18_all.deb) ...
    Unpacking replacement human-theme ...
    dpkg: error processing /cdrom//pool/main/h/human-theme/human-theme_0.18_all.deb (--unpack):
     trying to overwrite `/usr/share/applications/screensavers/ubuntu_theme.desktop', which is also in package gnome-screensaver
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    I feel like it's getting my leftover gutsy packages confused with the hardy ones.

  6. #16
    Join Date
    Nov 2006

    Thumbs down Re: Update Manager freezes

    Following this bug report, I got a bit further with this procedure:
    1. As superuser,
      cd /tmp ; rm -rf tmp*
    2. Insert the alternate CD ROM
    3. If the autorun dialog comes up, select the upgrade option. Otherwise, run
      sudo sh /media/cdrom/cdromupgrade
    4. The program hangs in step 1. (If it doesn't hang for you,
      then that's great, and you can stop reading this.)
    5. Code:
      cd /tmp/tmp*
    6. Code:
      sudo ./hardy --frontend=DistUpgradeViewText --cdrom=/media/cdrom

    You'll get this text output:
    Reading cache
    Checking package manager
    Reading package lists: Done
    Reading state information: Done
    Reading state information: Done
    Reading state information: Done
    Include latest updates from the Internet? 
    The upgrade process can automatically download the latest updates and 
    install them during the upgrade. The upgrade will take longer, but 
    when it is complete, your system will be fully up to date. You can 
    choose not to do this, but you should install the latest updates soon 
    after upgrading.
    At this point, there presumably should have been a prompt, but I didn't get any. I boldly hit the ENTER key, and got
    Then the program proceeded. It might have been better to try to answer No because the internet download is so slow right now. Maybe someone can try this and report how it works.

Page 2 of 2 FirstFirst 12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts