Results 1 to 4 of 4

Thread: [SOLVED] Browser goes backwards when using the mouse wheel

  1. #1
    Join Date
    Jun 2006
    Location
    Caracas, Venezuela
    Beans
    418
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Unhappy [SOLVED] Browser goes backwards when using the mouse wheel

    Hi people, I posted this issue on Arch forums some weeks ago, but I didn't find a solution. The problem is, when I'm browsing a website on firefox and spin the mouse wheel downwards, sometimes happens that firefox goes one page backwards instead of scrolling down. It happens randomly, but mostly when I spin the wheel too fast. I guess maybe something is wrong with my xorg.conf, but it seems to be ok; anyway, here's a copy, just in case:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Feb 14 18:20:37 PST 2008
    
    Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/share/X11/rgb"
        ModulePath      "/usr/lib/xorg/modules"
        FontPath        "/usr/share/fonts/misc"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/TTF"
        FontPath        "/usr/share/fonts/Type1"
    EndSection
    
    Section "Module"
        Load           "xtrap"
        Load           "glx"
        Load           "dbe"
        Load           "record"
        Load           "extmod"
    #	Load  "dri"
        Load           "freetype"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "kbd"
        Option         "CoreKeyboard"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "es"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/input/mice"
        Option         "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    
    	#DisplaySize	  340   270	# mm
     ### Comment all HorizSync and VertRefresh values to use DDC:
        Identifier     "Monitor0"
        VendorName     "SAM"
        ModelName      "SyncMaster"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
    
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "SWcursor"           	# [<bool>]
            #Option     "HWcursor"           	# [<bool>]
            #Option     "NoAccel"            	# [<bool>]
            #Option     "ShadowFB"           	# [<bool>]
            #Option     "UseFBDev"           	# [<bool>]
            #Option     "Rotate"             	# [<str>]
            #Option     "VideoKey"           	# <i>
            #Option     "FlatPanel"          	# [<bool>]
            #Option     "FPDither"           	# [<bool>]
            #Option     "CrtcNumber"         	# <i>
            #Option     "FPScale"            	# [<bool>]
            #Option     "FPTweak"            	# <i>
            #Option     "DualHead"           	# [<bool>]
        Option          "RenderAccel" "true"
        Option          "NoLogo" "true"
        Identifier     "Card0"
        Driver         "nvidia"
        VendorName     "nVidia Corporation"
        BoardName      "G71 [GeForce 7300 GS]"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Card0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "True"
        SubSection     "Display"
            Viewport    0 0
            Depth       1
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       4
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       8
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       15
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       16
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       24
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection
    Does anyone have an idea about what could be wrong and how to fix the issue?

    Thanks in advance.

  2. #2
    Join Date
    Aug 2007
    Location
    Bowling Green, Kentucky
    Beans
    227
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Browser goes backwards when using the mouse wheel

    I have the same issue on my "testing" computer. I never did find a solution or even why it did that. But you're right, it usually happens when you scroll really fast. Really weird.

  3. #3
    Join Date
    Aug 2007
    Beans
    26
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Browser goes backwards when using the mouse wheel

    Im not positive, but I think it has to do with the emulate3 option , add it to your Xorg and make it false. That worked for me. I had the same issue, when scrolling really fast, it would jump back a page or two.

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "CorePointer"
    Option "Resolution" "1400"
    Option "SampleRate" "500"
    Option "Buttons" "7"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "ButtonMapping" "1 2 3 6 7"
    Option "Emulate3Buttons" "false"
    EndSection

    Thats mine.

  4. #4
    Join Date
    Jun 2006
    Location
    Caracas, Venezuela
    Beans
    418
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Browser goes backwards when using the mouse wheel

    Quote Originally Posted by Misbah View Post
    Im not positive, but I think it has to do with the emulate3 option , add it to your Xorg and make it false. That worked for me. I had the same issue, when scrolling really fast, it would jump back a page or two.
    Thank you a lot! I added the emulate3button option set to false, then restarted my X server and tested firefox scrolling on many websites and it worked fine; no jumps backwards.

    Thank you both for your answers!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •