Results 1 to 3 of 3

Thread: Ubuntu style - PXE booting in acronis true image enterprise server 9.1 (all)

  1. #1
    Join Date
    Apr 2007

    Ubuntu style - PXE booting in acronis true image enterprise server 9.1 (all)

    Hi People,

    This is a quick howto get a product called 'Acronis True image Enterprise 9.1 server' PXE booting using Ubuntu OS as the PXE imager, tftp server.

    Everyones setup will vary, but the setup I have in our school is as follows:

    2x Windows 2003 domain controllers, 6x Ubuntu Dapper servers (doing varies tasks)

    I would just like to share my experience of getting acronis true image server 9.1. ( running in this setup.

    Scenario: School in uk, for quick imaging to pc's and servers incase of disk failure.
    Don't want to mess around with CD's or floppys or any other silly removable media.

    PXE is the quick solution. Trialed out the acronis product, worked satisfactory.

    Then tried the pxe solution, EEK! refused to boot from any pc? Looked on acronis forum, a few people had the same problem. A few suggestions from people where posted, but no real solution to the issue. UNTIL NOW! Yipeee....

    OK!, here's how i got it working - not perfect, but works really well.

    First of all, the RIS on a windows server doesnt work. I had to use Ubuntu linux box to do all grunt work.

    Here's the Steps:

    1. This guy was the only one who seemed to get it to work

    A bit confusing, and not really telling you how to get it working?

    After searching around the internet i found these two articles.

    How to setup G4L (Ghost4Linux)
    and this

    How to setup PXE booting on Ubuntu

    Ok, i thought i'll put this to good use. I followed the instructions (testing on a spare pc), using a ubuntu dapper server 32bit and 64bit. then...

    2. On instruction number 11 (How to setup G4L (Ghost4Linux)
    ., i added this

    LABEL acronistrue
    MENU LABEL ^W: Acronis True Image
    kernel boot/kernel.dat
    append initrd=images/ramdisk.dat vga=791 ramdisk_size=32768 acpi=off quiet noapic

    To the Default and labeled it W (Reason being that the latest G4L is 0.22, and has changed the menu list, you'll see once you download g4l-0.22.iso)

    Obviously created the necessary folders in the /tftpboot folder = boot and images, then copyed the ramdisk.dat and kernel.dat from a pre made recovery iso image within acronis.

    3. I have two windows servers 2003 running the dhcp to the clients, so i had to add some entry's to the server options in the dhcp manager.

    Option 66 and 67

    Option 66 is the tftp server address, so i entered or the dns name
    then option 67
    Option 67 is filename for booting, i entered pxelinux.0

    If you dont enter the above then it takes the clients twice as long to find you tftp server, and most likely will have a "proxydhcp 40 error" come up on the client trying to boot.

    (NOTE: The 'How to setup PXE booting on Ubuntu' above tells you howto adjust DHCP for ubuntu.)

    Thats it!

    So now i have Acronis true image pxe booting and G4L (Ghost4Linux), Cool!!!

    If you are still a bit confused, send me a message or email me on for config files etc.
    Last edited by db260179; April 6th, 2007 at 09:19 AM.

  2. #2
    Join Date
    Feb 2005
    Kubuntu 7.10 Gutsy Gibbon

    Re: Ubuntu style - PXE booting in acronis true image enterprise server 9.1 (all)

    Thanks, your post was very useful. I'm currently working on getting a catch-all pxe server going. I've got PING and G4L going, and as soon as I can get my hands on an updated kernel module I'll have acronis as well. Now all that's left is a couple versions of ghost and I'll be covered. Thanks again!

  3. #3
    Join Date
    Apr 2007

    Re: Ubuntu style - PXE booting in acronis true image enterprise server 9.1 (all)

    No problem, hope this comes in use to you and other people


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts