Results 1 to 4 of 4

Thread: [SOLVED] Dosbox Discworld - no sound

  1. #1
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,455
    Distro
    Ubuntu Mate

    [SOLVED] Dosbox Discworld - no sound

    Hi,
    I installed Discworld on DosBox. There is no sound. Does anyone know how to get the sound to work?

    I have sound in all other dos box games.

    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  2. #2
    Join Date
    Sep 2007
    Location
    On a small blue planet.
    Beans
    Hidden!

    Re: Dosbox Discworld - no sound

    In the Discworld folder (in DOSBOX) run config.bat. Choose soundblaster 16 or sound blaster compatible for sound and midi.
    Then run discbat. Any sound?
    Pears for your heirs
    My GNU/Linux and Emulation blog.
    Resources for the nostalgic emulation enthusiast.

  3. #3
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,455
    Distro
    Ubuntu Mate

    Re: Dosbox Discworld - no sound

    Quote Originally Posted by FranMichaels View Post
    In the Discworld folder (in DOSBOX) run config.bat. Choose soundblaster 16 or sound blaster compatible for sound and midi.
    Then run discbat. Any sound?
    Hi, I ran config.bat under dosbox. I tried the various soundblaster options (there was no option to exit and save, just esc to exit). No luck.

    When you said run 'discbat' did you mean to say discworld?
    Last edited by Rytron; March 30th, 2008 at 12:23 PM. Reason: omissions
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  4. #4
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,455
    Distro
    Ubuntu Mate

    Re: Dosbox Discworld - no sound

    I found this solution:

    To save and have sound, do like so:
    After installing to folder DISCWLD, make a folder titled SAVE
    Run Config.bat and configure your sound and audio to Soundblaster Pro if you have it
    Open Disc.bat and choose Soundblaster Pro.

    The above steps must be done each time prior to playing Discworld on DosBox.
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •