Page 4 of 4 FirstFirst ... 234
Results 31 to 36 of 36

Thread: Installing Kubuntu 7.10 on Software RAID5

  1. #31
    Join Date
    Apr 2007
    Tucson, AZ, USA
    Ubuntu 15.10 Wily Werewolf

    Exclamation Re: Installing Kubuntu 7.10 on Software RAID5

    Fabulous post! I've been trying to solve this puzzle myself for a couple of weeks and now it's all laid out for me.

  2. #32
    Join Date
    Sep 2006

    Re: Installing Kubuntu 7.10 on Software RAID5


    Just tried doing this and everything seemed to work out pretty well with the following exception. On my md0 1 of the drives is not syncd up how do I force a sync on that drive:

    Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
    md6 : active raid5 sdd9[3] sdc9[2] sdb9[1] sda9[0]
    20506560 blocks level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

    md5 : active raid5 sdd8[3] sdc8[2] sdb8[1] sda8[0]
    14650944 blocks level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

    md4 : active raid5 sdd7[3] sdc7[2] sdb7[1] sda7[0]
    20506560 blocks level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

    md3 : active raid5 sdd6[3] sdc6[2] sdb6[1] sda6[0]
    20506560 blocks level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

    md2 : active raid5 sdd5[3] sdc5[2] sdb5[1] sda5[0]
    14650944 blocks level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

    md1 : active raid1 sda10[0] sdc10[3](S) sdb10[1]
    4883648 blocks [2/2] [UU]

    md0 : active raid1 sda1[0] sdd1[3] sdb1[1]
    128384 blocks [4/3] [UU_U]

    unused devices: <none>

  3. #33
    Join Date
    Oct 2008

    Re: Installing Kubuntu 7.10 on Software RAID5


    Thanks for all of the time and effort that you have expended in writing this “How To”. It is very detailed and easy to understand.

    I have only had one problem, I got all of the expected results until I got to the reboot step in the “Reboot to the RAID5 system!” section. The reboot worked up through and including my entering my userID and password. Then I got a dialog box that said “The following installation problem was detected while trying to start KDE. No write access to $HOME directory. KDE is unable to start.”

    After rebooting into my original installation partition I have looked at the permissions for both the non RAID home directory and the RAID home directory and found them to be identical. I have redone the installation two more times being very careful to follow the instructions correctly and still have the same results.

    Any pointers on where I should look for possible things that I may have done wrong?

    My installation is the same as yours except that I only have 3 drives in my array rather than the 5 drives that you used.

    Thanks again!


  4. #34
    Join Date
    Feb 2008

    Re: Installing Kubuntu 7.10 on Software RAID5


    First, I have to ask if you are installing 7.10. If you're installing 8.X, it could be different. I know there were some changes made to the RAID support in version 8. I haven't upgraded and so I haven't investigated how the changes affect my procedure.

    Assuming you're installing 7.10, then let me be sure I know just where you're experiencing the issue. You're at the point just before "Move /home to RAID5 and Clean Up". Correct? Assuming that is correct ...

    I'm not certain what is happening, since /home hasn't yet changed. It's still on the original installation partition. Check the /etc/fstab file that is used when booting from RAID and be sure that it doesn't have a /home mount point that isn't available after the boot. At this point you shouldn't have a separate mount point for /home. It should still be in / (root) and that would be the one it's using.

    Also check to see that the home directory is set correctly in the /etc/passwd file. Be sure you're checking the passwd file in the root RAID partition, not the original installed root. It's possible that $HOME is getting changed somewhere in a shell configuration file, e.g. .profile or .bashrc. But this is doubtful if you're doing a fresh installation.

    Those are some suggestions to try and track down the issue. I don't recall seeing your particular issue when I was doing the installation. So I'm not sure what the root issue is.

    Post back here with further questions, or the solution when you find it so others will know.


  5. #35
    Join Date
    May 2009

    Re: Installing Kubuntu 7.10 on Software RAID5

    Thanks alot for this! Great work LNK! I am currently waiting for the building of the /home array to finish after a succesful install of Ubuntu 8.04 LTS Server 64bit. Everything has gone perfectly well until now, and I hope the little remaining work will too. I have followed the instructions as close as possible and had no problems or error messages except for a typo here and there which of course is my own bad. The raid consists of 6x750GB with: 128MB /boot, 18GB /, 50GB /usr, 20GB /var, 10GB /tmp and 2GB swap. The rest is for the /home partition and consists of partitions with 720GB on each disk. I will test the raid when it's done building and the final steps are done. If anything shows up, I'll post it here.


  6. #36

    Re: Installing Kubuntu 7.10 on Software RAID5

    Keep up the great work!

Page 4 of 4 FirstFirst ... 234


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts