Results 1 to 2 of 2

Thread: Gutsy wireless connectivity

  1. #1
    Join Date
    Dec 2006
    Location
    Toddington, UK
    Beans
    12
    Distro
    Ubuntu 9.10 Karmic Koala

    Cool Gutsy wireless connectivity

    I have been trying to get the wireless card working on my wifes laptop without any success. It's a Lenovo 3000 n100. I tried following the documentation on the ubuntu website at https://help.ubuntu.com/7.10/internet/C/wireless.html
    but it didn't fix the problem. The results of these efforts are below. I tried everything with the network cable out, just to avoid any confustion. I also tried looking at the associated forum entries which were suggested at the top as I started to compose this thread. Any help would be most appreciated.

    Code:
    $ sudo lshw -C network
      *-network               
           description: Wireless interface
           product: BCM4312 802.11a/b/g
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: eth1
           version: 01
           serial: 00:16:cf:79:f4:2e
           width: 32 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=bcm43xx driverversion=2.6.22-14-generic latency=0 link=no module=bcm43xx multicast=yes wireless=IEEE 802.11b/g
      *-network
           description: Ethernet interface
           product: RTL-8139/8139C/8139C+
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 1
           bus info: pci@0000:05:01.0
           logical name: eth0
           version: 10
           serial: 00:0f:b0:cc:7b:ae
           size: 10MB/s
           capacity: 100MB/s
           width: 32 bits
           clock: 33MHz
           capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=64 mingnt=32 module=8139too multicast=yes port=MII speed=10MB/s
    Code:
    $ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11b/g  ESSID:"fender2"  Nickname:"Broadcom 4311"
              Mode:Managed  Frequency=2.472 GHz  Access Point: Invalid   
              Bit Rate=1 Mb/s   Tx-Power=18 dBm   
              RTS thr:off   Fragment thr:off
              Link Quality=0/100  Signal level=-256 dBm  Noise level=-256 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Code:
    $ ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:0F:B0:CC:7B:AE  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:21 Base address:0xa000 
    
    eth1      Link encap:Ethernet  HWaddr 00:16:CF:79:F4:2E  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:260 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:11830 (11.5 KB)
              Interrupt:17 Base address:0x8000 
    
    eth1:avah Link encap:Ethernet  HWaddr 00:16:CF:79:F4:2E  
              inet addr:169.254.7.214  Bcast:169.254.255.255  Mask:255.255.0.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              Interrupt:17 Base address:0x8000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:36 errors:0 dropped:0 overruns:0 frame:0
              TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:3200 (3.1 KB)  TX bytes:3200 (3.1 KB)
    Code:
    $ cat /etc/resolv.conf
    # generated by NetworkManager, do not edit!
    
    
    
    nameserver 192.168.1.1
    Code:
    $ dhclient 192.168.1.1
    Internet Systems Consortium DHCP Client V3.0.5
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    can't create /var/lib/dhcp3/dhclient.leases: Permission denied
    Can't create /var/run/dhclient.pid: Permission denied
    drop_privileges: could not set group id: Operation not permitted

  2. #2
    Join Date
    Jan 2008
    Beans
    3
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Gutsy wireless connectivity

    Have you installed wpasupplicant? I see you have a 169.254 IP address. Is WPA enabled on your AP?

    From the Terminal enter the command: sudo dhclient eth1

    That should help.

    Steve.
    Last edited by OldCodge; January 16th, 2008 at 10:28 PM. Reason: Reading and thinking properly!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •