Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: (64-bit) Build the latest of Pidgin

  1. #1
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    19,530
    Distro
    Ubuntu Budgie Development Release

    (64-bit) Build the latest of Pidgin

    Tested: Ubuntu 7.10 64-bit Gnome (should work as well on 32-bit)
    Homepage: http://www.pidgin.im/
    Original Guide: http://polarbeardk.blogspot.com/2008...710-64bit.html

    Pidgin is a multi-protocol Instant Messaging client that allows you to use all of your IM accounts at once.

    This guide show how to build the latest version of Pidgin, plus the following plugins:

    • talkfilter
    • Purple-Pluginpack (require talkfilter)
    • guification
    • Off-the-Record Messaging
    • Pidgin-Encryption
    • Pidgin extended preferences
    • ...more to come



    Click to enlarge


    ===========================================

    Before Installation

    First thing you need is to enable all the sources in your repository. You can do that by; System tab ---> Administration ---> Software Sources.
    You also need to enable medibuntu which you can find here; http://www.medibuntu.org/

    When that is done, open the terminal (Applications tab ---> Accessories ---> Terminal ).
    To build Pidgin from the source the right tools, libs and headers is needed, also the old pidgin needs to be uninstall, type this in the terminal;

    Code:
    sudo aptitude update && sudo aptitude safe-upgrade
    sudo aptitude remove pidgin pidgin-data
    sudo aptitude install build-essential linux-headers-`uname -r` checkinstall
    sudo aptitude install libexpat1-dev libintl-perl gettext bcp libx11-dev libgcrypt11-dev libgtk2.0-dev libxss-dev libsm-dev libstartup-notification0-dev libgtkspell-dev libsqlite3-dev libecal1.2-dev libncursesw5-dev libgconf2-dev libgstreamer0.10-dev libmeanwhile-dev libavahi-client-dev libavahi-glib-dev libavahi-compat-howl-dev libsilc-1.1-2-dev libgadu-dev libperl-dev libgnutls-dev doxygen xsltproc tcl8.4-dev tk8.4-dev check libnss3-dev dot2tex libecal1.2-dev libedata-book1.2-dev flex libnm-glib-dev libmng-dev mono mono-mcs libmono-dev libsasl2-dev libzephyr-dev libkrb5-dev
    Done. Now you're ready to compile Pidgin and its plugins.


    Installation

    Pidgin
    Pidgin is a multi-protocol Instant Messaging client that allows you to use all of your IM accounts at once.

    Code:
    cd ~/Desktop
    wget http://downloads.sourceforge.net/pidgin/pidgin-2.3.1.tar.bz2
    tar jxfv pidgin-2.3.1.tar.bz2
    cd pidgin-2.3.1
    ./configure --prefix=/usr --enable-mono --enable-cyrus-sasl --enable-nm --with-krb4
    make
    sudo checkinstall

    Plugins

    Talkfilter
    The GNU Talk Filters are filter programs that convert ordinary English text into text that mimics a stereotyped or otherwise humorous dialect. These filters have been in the public domain for many years, but now for the first time they are provided as a single integrated package. The filters include austro, b1ff, brooklyn, chef, cockney, drawl, dubya, fudd, funetak, jethro, jive, kraut, pansy, pirate, postmodern, redneck, valspeak, and warez. Each program reads from standard input and writes to standard output. The package also provides the filters as a C library, so they can be easily used by other programs.
    [Homepage]

    Code:
    cd ~/Desktop
    wget http://www.hyperrealm.com/talkfilters/talkfilters-2.3.8.tar.gz
    tar zxfv talkfilters-2.3.8.tar.gz
    cd talkfilters-2.3.8
    ./configure --prefix=/usr
    make
    sudo checkinstall

    Purple Plugin Pack
    Full plugin list you'll find here: http://plugins.guifications.org/trac/wiki/PluginPack
    [Homepage]

    Code:
    cd ~/Desktop
    wget http://downloads.guifications.org/plugins//Plugin%20Pack/purple-plugin_pack-2.2.0.tar.bz2
    tar jxfv purple-plugin_pack-2.2.0.tar.bz2
    cd purple-plugin_pack-2.2.0
    ./configure --prefix=/usr
    make
    sudo checkinstall

    Guification
    Guifications is a Pidgin plugin that displays "toaster" popups in a user-defined corner of the screen, similar to features that have been added to the official MSN Messenger (now called Windows Live Messenger), Yahoo! Messenger and AOL Instant Messenger clients. It's highly configurable, easy to use, and has theme support. It really is the end-all, be-all toaster pop-up plugin for Pidgin!
    [Homepage]

    Code:
    cd ~/Desktop
    wget http://downloads.guifications.org/plugins//Guifications2/pidgin-guifications-2.16.tar.bz2
    tar jxfv pidgin-guifications-2.16.tar.bz2
    cd pidgin-guifications-2.16
    ./configure --prefix=/usr
    make
    sudo checkinstall

    Off-the-Record Messaging
    Off-the-Record (OTR) Messaging allows you to have private conversations over instant messaging by providing: Encryption, Authentication, Deniability and Perfect forward secrecy.
    [Homepage]

    Code:
    cd ~/Desktop
    wget http://www.cypherpunks.ca/otr/libotr-3.1.0.tar.gz http://www.cypherpunks.ca/otr/pidgin-otr-3.1.0.tar.gz
    tar zxvf libotr-3.1.0.tar.gz && tar zxvf pidgin-otr-3.1.0.tar.gz
    cd libotr-3.1.0
    ./configure --prefix=/usr
    make
    sudo checkinstall
    cd ~/Desktop/pidgin-otr-3.1.0
    ./configure --prefix=/usr
    make
    sudo checkinstall

    Pidgin-Encryption
    Pidgin-Encryption transparently encrypts your instant messages with RSA encryption. Easy-to-use, but very secure.
    [Homepage]

    Code:
    cd ~/Desktop
    wget http://downloads.sourceforge.net/pidgin-encrypt/pidgin-encryption-3.0.tar.gz?modtime=1178510638&big_mirror=0
    tar zxfv pidgin-encryption-3.0.tar.gz
    cd pidgin-encryption-3.0
    ./configure --prefix=/usr
    make
    sudo checkinstall

    Pidgin extended preferences
    The Pidgin Extended Preferences Plugin adds additional preferences that have been commonly called for in the past from Pidgin that are either already implemented and hidden, or trivial to implement via a plugin.
    [homepage]

    Code:
    cd ~/Desktop
    wget http://downloads.sourceforge.net/gaim-extprefs/pidgin-extprefs-0.7.tar.gz?modtime=1177805917&big_mirror=0
    tar zxfv pidgin-extprefs-0.7.tar.gz
    cd pidgin-extprefs-0.7
    ./configure --prefix=/usr
    make
    sudo checkinstall

    That should be it. Request a plugin that isn't shown here if you need it.


    Enjoy

    Regards
    A.I. Dude

    ===========================================
    Other 64-bit guides:
    Build the latest of Audacious
    Install F-prot (anti-virus)
    Install AVG (anti-virus)
    Last edited by Perfect Storm; February 9th, 2008 at 10:52 AM.
    Shade of Z - icon theme: https://www.gnome-look.org/p/1516492/
    Shade of Z - GTK/Gnome-shell: https://www.pling.com/p/1550993

  2. #2
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,915
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: (64-bit) Build the latest of Pidgin

    Excellent guide, however I think you left some information out about the purple plugin pack, particularly how to activate the plugins that my default would not be compiled (like group message).

    Also I couldn't compile all the most recent purple plugins as of 1/3/2008. I received some errors with certain packages.

    Any possibilities that you could include some svn instructions for some plugins (if svn versions are availalble)?

    Other plugins I like are
    otr http://www.cypherpunks.ca/otr/ -- need libotr
    pidgin encryption - http://gaim-encryption.sourceforge.net
    Pidgin extended preferences - http://gaim-extprefs.sourceforge.net/

    Thanks

  3. #3
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    19,530
    Distro
    Ubuntu Budgie Development Release

    Re: (64-bit) Build the latest of Pidgin

    I'll take a look at it.
    Shade of Z - icon theme: https://www.gnome-look.org/p/1516492/
    Shade of Z - GTK/Gnome-shell: https://www.pling.com/p/1550993

  4. #4
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    19,530
    Distro
    Ubuntu Budgie Development Release

    Re: (64-bit) Build the latest of Pidgin

    Extensive Guide update.

    -- guide completly updated.
    -- missing libs added
    -- enabled mono (remove the flag if you don't want it and/or remove mono-dev from the guides before installation).
    -- added 3 new plugins: Off-the-Record Messaging, Pidgin-Encryption and Pidgin extended preferences.
    -- Link added to each plugin guide.
    Last edited by Perfect Storm; January 5th, 2008 at 10:25 AM.
    Shade of Z - icon theme: https://www.gnome-look.org/p/1516492/
    Shade of Z - GTK/Gnome-shell: https://www.pling.com/p/1550993

  5. #5
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,915
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: (64-bit) Build the latest of Pidgin

    Here is another plugin that I saw mentioned on another post. It prevents IM spam:

    http://sourceforge.net/projects/pidgin-bs/

  6. #6
    Join Date
    Jul 2007
    Location
    Canada
    Beans
    149
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: (64-bit) Build the latest of Pidgin

    My installation fails at the 'make' step .
    I'm currently using pidgin 2.2.1 on fiesty .

    Here is the error I get during 'make' :

    Code:
    make  all-recursive
    make[1]: Entering directory `/home/sid/pidgin-2.3.1'
    Making all in libpurple
    make[2]: Entering directory `/home/sid/pidgin-2.3.1/libpurple'
    make  all-recursive
    make[3]: Entering directory `/home/sid/pidgin-2.3.1/libpurple'
    Making all in gconf
    make[4]: Entering directory `/home/sid/pidgin-2.3.1/libpurple/gconf'
    make[4]: Nothing to be done for `all'.
    make[4]: Leaving directory `/home/sid/pidgin-2.3.1/libpurple/gconf'
    Making all in plugins
    make[4]: Entering directory `/home/sid/pidgin-2.3.1/libpurple/plugins'
    Making all in mono
    make[5]: Entering directory `/home/sid/pidgin-2.3.1/libpurple/plugins/mono'
    Making all in api
    make[6]: Entering directory `/home/sid/pidgin-2.3.1/libpurple/plugins/mono/api'
    mcs -t:library -out:PurpleAPI.dll ./BlistNode.cs ./BuddyList.cs ./Buddy.cs ./Contact.cs ./Debug.cs ./Event.cs ./PurplePlugin.cs ./Group.cs ./Signal.cs ./Status.cs
    /bin/bash: mcs: command not found
    make[6]: *** [PurpleAPI.dll] Error 127
    make[6]: Leaving directory `/home/sid/pidgin-2.3.1/libpurple/plugins/mono/api'
    make[5]: *** [all-recursive] Error 1
    make[5]: Leaving directory `/home/sid/pidgin-2.3.1/libpurple/plugins/mono'
    make[4]: *** [all-recursive] Error 1
    make[4]: Leaving directory `/home/sid/pidgin-2.3.1/libpurple/plugins'
    make[3]: *** [all-recursive] Error 1
    make[3]: Leaving directory `/home/sid/pidgin-2.3.1/libpurple'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/home/sid/pidgin-2.3.1/libpurple'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/sid/pidgin-2.3.1'
    make: *** [all] Error 2
    Advise please ?
    Long Live Ubuntu !

  7. #7
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    19,530
    Distro
    Ubuntu Budgie Development Release

    Re: (64-bit) Build the latest of Pidgin

    Check if libmcs headers/dev is installed. If it aren't there. If it aren't there - you need to compile it as well
    then make clean and run ./configure again
    Shade of Z - icon theme: https://www.gnome-look.org/p/1516492/
    Shade of Z - GTK/Gnome-shell: https://www.pling.com/p/1550993

  8. #8
    Join Date
    Jul 2007
    Location
    Canada
    Beans
    149
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: (64-bit) Build the latest of Pidgin

    hmm... 'libmcs' doesn't appear in synaptic . So I guess it isn't installed.
    Where can I download it from ? I was able to find a link but it seems dead : ( http://sacredspiral.co.uk/~nenolod/mcs/ )

    Edit: I think this is the intended page: http://atheme.org/projects/mcs.shtml
    Shall I download mcs 0.6.0 from there? I hope it is a trusted source and the latest one.
    Last edited by genbuntu; January 28th, 2008 at 01:10 PM.
    Long Live Ubuntu !

  9. #9
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    19,530
    Distro
    Ubuntu Budgie Development Release

    Re: (64-bit) Build the latest of Pidgin

    I'm not sure it's your problem, only a guess. You know that getdebs have binaries of pidgin latest, it is easier if you're not comftable with compiling (though with compiling you can customize the software yourself, if you know howto).

    http://www.atheme.org/projects/mcs.shtml
    Shade of Z - icon theme: https://www.gnome-look.org/p/1516492/
    Shade of Z - GTK/Gnome-shell: https://www.pling.com/p/1550993

  10. #10
    Join Date
    Jul 2007
    Location
    Canada
    Beans
    149
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: (64-bit) Build the latest of Pidgin

    I did compile a few programs from source but I'm still new to linux on the whole .
    The thing with getdeb is that for fiesty they only have pidgin 2.2.0 as the latest one. But for Gusty they have 2.3.1 . Shall I install the gusty one on my system then ?
    I hope it will preserve my settings .
    Edit: I am also not hesitant to compiling it myself , as that is the best way I can learn.
    Long Live Ubuntu !

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •