Results 1 to 4 of 4

Thread: PVR-350 X TV Out Problems

  1. #1
    Join Date
    Dec 2007

    PVR-350 X TV Out Problems

    Hello all. I am a newbie to Mythbuntu, but I have had MythTV running under Fedora for over a year. I am changing machines and decided to try Mythbuntu. So far, everything has been great. I got everything installed and even set up the LVM for my recordings. The last piece I need is to channel my X out through my Hauppauge PVR-350. I have been working on this problem for more than 6 hours and I have been following many posts and how-to sites without any luck, including a thread on this forum:

    So far, I have ivtv and ivtv-fb working. I know my frame buffer and BusId:

    # cat /proc/fb
    0 cx23415 TV out
    # lspci | grep "Internext"
    01:00.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
    01:01.0 Multimedia video controller: Internext Compression Inc iTVC15 MPEG-2 Encoder (rev 01)
    I have successfully displayed the test image on the tv:

    # rmmod saa7127
    # modprobe saa7127 test_image=1
    When I try to pipe /dev/video0 through /dev/video17 to see the video played on my tv:

    # dd if=/dev/video0 of=/dev/video17 bs=64k
    I get the video with a big black box in the middle of it. I Google'd that and found something that said I should add

    options ivtv-fb osd_compat=1
    to /etc/modprobe.d/aliases. But when I do, I get nothing at all when I use the dd command above (or maybe the black box just got bigger ).

    I have also tried setting my xorg.conf to display X through my PVR-350. Here is my xorg.conf:

    # xorg.conf (xorg X Window System server configuration file)
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "Files"
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"stylus"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"eraser"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"cursor"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    Section "Device"
    	Identifier	"Hauppauge PVR 350 iTVC15 Framebuffer"
    	Driver		"ivtvdev"
    	Option 		"fbdev" "/dev/fb0"
    	Option 		"ivtv" "/dev/fb0"
    	Option		"TVStandard" "NTSC-M"
    	Option          "VideoOverlay" "on"
            Option          "XVideo" "1"
            BusID           "PCI:1:01:0"
    #Section "Device"
    	#Identifier	"Intel Corporation 82865G Integrated Graphics Controller"
    	#Driver		"intel"
    	#Busid		"PCI:0:2:0"
    Section "Monitor"
            Identifier "TV"
            HorizSync 30-68
            VertRefresh 50-120
            DisplaySize 183 122
            Mode "720x480"
            DotClock 34.564
            HTimings 720 752 840 928
            VTimings 480 484 488 504
            Flags "-HSync" "-VSync"
    #Section "Monitor"
    	#Identifier	"Generic Monitor"
    	#Option		"DPMS"
    	#Horizsync	30-70
    	#Vertrefresh	50-160
    Section "Screen"
            Identifier "TV Screen"
            Device "Hauppauge PVR 350 iTVC15 Framebuffer"
            Monitor "TV"
            DefaultDepth 24
            DefaultFbbpp 32
            Subsection "Display"
            Depth 24
            FbBpp 32
            Modes "720x480"
    #Section "Screen"
    	#Identifier	"Default Screen"
    	#Device		"Intel Corporation 82865G Integrated Graphics Controller"
    	#Monitor		"Generic Monitor"
    	#Defaultdepth	24
    	#Option		"SecurityTypes"	"VncAuth"
    	#Option		"UserPasswdVerifier"	"VncAuth"
    	#Option		"PasswordFile"	"/root/.vnc/passwd"
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen "TV Screen"
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    Section "Module"
    	Load		"vnc"
    When I boot with this xorg.conf, it hangs for a minute, then dumps me into run-level 3 and prompts for the root login.

    Could somebody please point me in the right direction? My wife is getting a little upset that the myth box has been down for a couple of days.


  2. #2
    Join Date
    Dec 2007

    Re: PVR-350 X TV Out Problems

    I have posted a new HOWTO for Gutsy at . It looks like you have followed a lot of it, but you might want to take a look at it to see if there is anything you missed.

    When you are sending the output from /dev/video0 to /dev/video17, you are sending your TV In from some other card to the TV Out on your PVR-350. I think you realize that, but I thought I should check. If your TV Out on the PVR-350 is /dev/video17, the TV In on the same card should be /dev/video1. Maybe try hooking up the cable to the PVR-350 instead of the other card and changing the device in your dd command from /dev/video0 to /dev/video1 and see what happens.

    If you are in the U.S., you most likely want NTSC rather than PAL, which means you shouldn't need that

    options ivtv-fb osd_compat=1
    line. I would try getting rid of it.

    Were you already getting video to play on the TV Out, just not the X session? Or is that not working too?

    Regarding your xorg.conf, in your Device section, do not use "ivtvdev". Instead, use "ivtv". See the Gutsy HOWTO to make sure that you have the ivtv driver for xorg installed (it's not part of the main Mythbuntu distribution, at least not yet). Also, I'm not sure if it makes any difference, but my Module section reads:

    Section "Module"
        Load "ivtv"
        Load "dbe"
        Load "v4l"
        Load "extmod"
        Load "type1"
        Load "freetype"
    Let me know whether any of this helps.

  3. #3
    Join Date
    Dec 2007

    Re: PVR-350 X TV Out Problems

    When setting the BusID in xorg.conf, it must be converted properly. If you have a resulting busID of 01:05:00 for example manage it as shown below. (You may have different values)

    Remove any zeros preceding values so that the busID is entered as: 1:5:0

    So, BusId 01:01:00 becomes 1:1:0

    Maybe the how-to can explain this, it does make a difference and X will not work properly with the settings entered the way the how-to explains it.


  4. #4
    Join Date
    Dec 2007

    Re: PVR-350 X TV Out Problems

    I have noticed something:

    Almost all of the users in the forum here that are having major problems getting X to run on their PVR-350'd TV-Out and have posted their xorg.conf's have the busid setting wrong as described above. (they get a black screen or other anomaly)

    Those preceding Zeros inthe busid are not the correct spec for the busid setting entry.

    I had this issue and had tried installing mythbuntu, updating it, changing config's and beating the hell out of myself with late nights and lots of time spent on it only to get the same result each time. I looked at another users who had it working and that is when i noticed he had the same busid setting as I did but he had no preceding zeros. I took out one zero and bam! it worked and is now working great and yes its very good. (minor issue with TV overscan but I will get that too I am sure.)

    Stoopid syntax error!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts