Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 50

Thread: Howto: Lineage 2 - C6 in Ubuntu 7.10

  1. #21
    Join Date
    May 2008
    Ubuntu Development Release

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    I'm having some trouble with Lineage II too. When I first installed Ubuntu and couldn't make it run I just dualbooted windows for L2 (the only game I play, and the only thing I needed windows for) but now my other hard disk died and I'm trying to get it work on Ubuntu. I tried tons of different configurations and nothing turned to work. Now I seem to have the best setup so far but 4 different things happen when I run the game:
    1. The game crashes before the login screen.
    2. The game freezes after entering my login info and selecting the server.
    3. The game crashes after selecting the character.
    4. The game just works fine for some time but crashes in places with more people.
    All 4 options include an "AGP is deactivated..." error at launching the game.
    When the game crashes I get an "You have outdated nvidia drivers, please update to version ...". The thing is that I have an ATI Radeon 9250 card and I'm using the default Ubuntu drivers, not nvidia. I also tried removing all the visual effects (compiz, window fx, etc) but nothing seems to change.

    I looked all over the internet for a solution, seems like most people using ATI cards have the same issues. Should I get an nvidia gfx card or there's still hope for ati?

    Any help is appreciated.
    Last edited by Darkshade; June 12th, 2008 at 06:43 AM.

  2. #22
    Join Date
    Apr 2008

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    I know this post is a bit old but I'm trying to run L2 on my gutsy and I can't make it work. I get to run my server's updater, but when I try to run L2.exe (or click the "Start" button on the updater) it just doesn't work. I tried deleting Option.ini and also leaving it more than 5 minutes to see if it came back to life but nothing, the process goes "zombie" and does nothing, not even suck up my processor or RAM.

    This is my terminal output:

    fixme:reg:GetNativeSystemInfo (0x1ef9526) using GetSystemInfo()
    fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
    fixme:debugstr:CheckRemoteDebuggerPresent (0xffffffff)->(0x1f522d6): Stub!
    wine: Unhandled page fault on write access to 0x00e7d7e4 at address 0x101091c9 (thread 0009), starting debugger...
    Unhandled exception: page fault on write access to 0x00e7d7e4 in 32-bit code (0x101091c9).
    Register dump:
     CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
     EIP:101091c9 ESP:0034f574 EBP:0034f5b8 EFLAGS:00010206(   - 00      - RIP1)
     EAX:00000000 EBX:0034fe5c ECX:00e7d7e0 EDX:00000004
     ESI:00e7d798 EDI:109686b4
    Stack dump:
    0x0034f574:  00000004 007b8c96 00000004 00000000
    0x0034f584:  109686b4 0034fe5c 0034fe5c 0034fe68
    0x0034f594:  10916062 1096b008 0011043c 10970448
    0x0034f5a4:  10996f10 0034f584 0034fe5c 008ccab0
    0x0034f5b4:  ffffffff 0034fe68 10916970 656e694c
    0x0034f5c4:  32656761 75527349 6e696e6e 46744167
    =>1 0x101091c9 in core (+0x91c9) (0x0034f5b8)
      2 0x10916970 in l2 (+0x16970) (0x0034fe68)
      3 0x10922471 in l2 (+0x22471) (0x0034ff00)
      4 0x00000000 (0x0034fee0)
      5 0xcd02eb3e (0x00000000)
    0x101091c9: movl        $0x0,0x4(%ecx)
    Module  Address                 Debug info      Name (113 modules)
    PE        350000-  35f000       Deferred        ogg
    PE        360000-  39f000       Deferred        vorbis
    PE        3a0000- 20a3000       Deferred        engine
    PE       20b0000- 20c4000       Deferred        dsetup
    PE       20d0000- 217d000       Deferred        nvidia
    PE       29a0000- 29db000       Deferred        ifc23
    PE      10000000-1001c000       Deferred        vorbisfile
    PE      10100000-10352000       Export          core
    PE      10900000-10a01000       Export          l2
    PE      11000000-110ba000       Deferred        window
    ELF     7b800000-7b92a000       Deferred        kernel32<elf>
      \-PE  7b820000-7b92a000       \               kernel32
    ELF     7bc00000-7bca2000       Deferred        ntdll<elf>
      \-PE  7bc10000-7bca2000       \               ntdll
    ELF     7bf00000-7bf03000       Deferred        <wine-loader>
    ELF     7c301000-7c352000       Deferred
    ELF     7c352000-7c356000       Deferred
    ELF     7c356000-7c366000       Deferred
    ELF     7c366000-7c36e000       Deferred
    ELF     7c36e000-7c39c000       Deferred
    ELF     7c39c000-7c40c000       Deferred
    ELF     7c40c000-7c431000       Deferred
    ELF     7c431000-7c4b9000       Deferred
    ELF     7c4b9000-7c4e2000       Deferred
    ELF     7c4e2000-7c517000       Deferred
    ELF     7e002000-7e004000       Deferred
    ELF     7e004000-7e036000       Deferred        uxtheme<elf>
      \-PE  7e010000-7e036000       \               uxtheme
    ELF     7e036000-7e04b000       Deferred        midimap<elf>
      \-PE  7e040000-7e04b000       \               midimap
    ELF     7e04b000-7e072000       Deferred        msacm32<elf>
      \-PE  7e050000-7e072000       \               msacm32
    ELF     7e072000-7e08a000       Deferred        msacm32<elf>
      \-PE  7e080000-7e08a000       \               msacm32
    ELF     7e08a000-7e150000       Deferred
    ELF     7e150000-7e153000       Deferred
    ELF     7e163000-7e199000       Deferred        winealsa<elf>
      \-PE  7e170000-7e199000       \               winealsa
    ELF     7e199000-7e1a2000       Deferred
    ELF     7e1a2000-7e1bf000       Deferred        imm32<elf>
      \-PE  7e1b0000-7e1bf000       \               imm32
    ELF     7e1bf000-7e1c2000       Deferred
    ELF     7e1c2000-7e1c8000       Deferred
    ELF     7e1c8000-7e1d0000       Deferred
    ELF     7e1d0000-7e1d3000       Deferred
    ELF     7e1d3000-7e1dd000       Deferred
    ELF     7e1dd000-7e1e2000       Deferred
    ELF     7e1e2000-7e1e5000       Deferred
    ELF     7e1e5000-7e1ea000       Deferred
    ELF     7e1ea000-7e24b000       Deferred
    ELF     7e24b000-7e250000       Deferred
    ELF     7e250000-7e253000       Deferred
    ELF     7e253000-7e344000       Deferred
    ELF     7e344000-7e352000       Deferred
    ELF     7e365000-7e3f6000       Deferred        winex11<elf>
      \-PE  7e370000-7e3f6000       \               winex11
    ELF     7e444000-7e464000       Deferred
    ELF     7e464000-7e48f000       Deferred
    ELF     7e48f000-7e4a4000       Deferred
    ELF     7e4a4000-7e514000       Deferred
    ELF     7e514000-7e5b4000       Deferred        oleaut32<elf>
      \-PE  7e530000-7e5b4000       \               oleaut32
    ELF     7e5b4000-7e5c9000       Deferred        psapi<elf>
      \-PE  7e5c0000-7e5c9000       \               psapi
    ELF     7e5c9000-7e5f6000       Deferred        ws2_32<elf>
      \-PE  7e5d0000-7e5f6000       \               ws2_32
    ELF     7e5f6000-7e610000       Deferred        wsock32<elf>
      \-PE  7e600000-7e610000       \               wsock32
    ELF     7e610000-7e624000       Deferred        lz32<elf>
      \-PE  7e620000-7e624000       \               lz32
    ELF     7e624000-7e63e000       Deferred        version<elf>
      \-PE  7e630000-7e63e000       \               version
    ELF     7e63e000-7e693000       Deferred        ddraw<elf>
      \-PE  7e650000-7e693000       \               ddraw
    ELF     7e693000-7e777000       Deferred        wined3d<elf>
      \-PE  7e6b0000-7e777000       \               wined3d
    ELF     7e777000-7e7a6000       Deferred        d3d9<elf>
      \-PE  7e780000-7e7a6000       \               d3d9
    ELF     7e7a6000-7e7db000       Deferred        winspool<elf>
      \-PE  7e7b0000-7e7db000       \               winspool
    ELF     7e7db000-7e87c000       Deferred        comdlg32<elf>
      \-PE  7e7e0000-7e87c000       \               comdlg32
    ELF     7e87c000-7e88f000       Deferred
    ELF     7e8a2000-7e8c0000       Deferred        iphlpapi<elf>
      \-PE  7e8b0000-7e8c0000       \               iphlpapi
    ELF     7e8c0000-7e91a000       Deferred        rpcrt4<elf>
      \-PE  7e8d0000-7e91a000       \               rpcrt4
    ELF     7e91a000-7e9bc000       Deferred        ole32<elf>
      \-PE  7e930000-7e9bc000       \               ole32
    ELF     7e9bc000-7ea7b000       Deferred        comctl32<elf>
      \-PE  7e9d0000-7ea7b000       \               comctl32
    ELF     7ea7b000-7ead4000       Deferred        shlwapi<elf>
      \-PE  7ea90000-7ead4000       \               shlwapi
    ELF     7ead4000-7ebd7000       Deferred        shell32<elf>
      \-PE  7eaf0000-7ebd7000       \               shell32
    ELF     7ebd7000-7ec23000       Deferred        advapi32<elf>
      \-PE  7ebe0000-7ec23000       \               advapi32
    ELF     7ec23000-7ecbb000       Deferred        gdi32<elf>
      \-PE  7ec30000-7ecbb000       \               gdi32
    ELF     7ecbb000-7edf8000       Deferred        user32<elf>
      \-PE  7ece0000-7edf8000       \               user32
    ELF     7edf8000-7ee86000       Deferred        winmm<elf>
      \-PE  7ee00000-7ee86000       \               winmm
    ELF     7efa5000-7efb0000       Deferred
    ELF     7efb0000-7efc8000       Deferred
    ELF     7efc8000-7efed000       Deferred
    ELF     7efed000-7eff7000       Deferred
    ELF     7eff7000-7f000000       Deferred
    ELF     f7cc2000-f7cc6000       Deferred
    ELF     f7cc6000-f7e10000       Deferred
    ELF     f7e11000-f7e29000       Deferred
    ELF     f7e3c000-f7f50000       Deferred
    ELF     f7f52000-f7f70000       Deferred
    process  tid      prio (all id:s are in hex)
            00000023    0
    00000008 (D) C:\Program Files\Lineage II\system\L2.exe
            00000025    0
            00000024    0
            00000021    2
            00000020    2
            0000001f    2
            0000001e    2
            0000001d    2
            0000001c    2
            0000001b    2
            0000001a    2
            00000019    2
            00000018    2
            00000017    2
            00000016    2
            00000015    2
            00000014    2
            00000013    2
            00000012    2
            00000011    0
            00000010    0
            0000000f    0
            0000000e    0
            0000000d    0
            0000000c    0
            0000000a    0
            00000009    0 <==
    Any help would be appreciated.

    EDIT: Forgot my pc specs:
    Dual Core 2.0 GHz
    2 gigs DDR2
    Intel x3100 GPU (integrated)
    Ubuntu Gutsy
    Wine 0.9.49
    Last edited by hellramza; September 8th, 2008 at 05:56 PM.

  3. #23
    Join Date
    Apr 2007
    Ubuntu 10.10 Maverick Meerkat

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    This could also be an issue with the Option.ini. But to tell you the truth, I still can't find enough information on your bug or any kind of fixes for it either.

    I would say try to look into a Nvidia card. I have done some work with ATI cards, and to tell you the trust it was complete hell. First I can't couldn't my video card drivers install, next I couldn't get 3D supprt, and latest I couldn't get games working. They would always spit out the weirdest errors within my terminal. >.< It was hell. Getting a nvidia could help... a lot. Also you maybe running into issues with the Option.ini within the system folder of Lineage 2 directory. I found a lot of my crashes was being caused by this file. If you are still trying to get Lineage 2 running. Let me know and I can give you some tips on howto get Lineage 2 running without issues from the Option.ini.

    hellramza, I was talking to you through PMs a while back, and you stated that you gave up on trying to get Lineage 2 to work through Ubuntu. For people with the same issues, I will report what we try to do to get it working on Ubuntu. He tried, wine 1.0, wine 1.0.1, wine, 1.1.3, wine 1.1.4, and versions before wine 1.0. It seemed the core issue of his problems was his graphic card. Intel x3100 GPU (integrated) Intel isn't known for making great Linux drivers that support 3D acceleration.

    Good Luck,
    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues

  4. #24
    Join Date
    May 2008
    Ubuntu Development Release

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    Thank you for your reply, Sugi.
    I gave up on ATI as soon as I started to understand Ubuntu (when I first posted a couple of months ago I had just installed it for the first time).
    I talked to some people who are playing L2 on Linux, all of them were using Nvidia and the ones that tried with ATI had the same issues.
    I'm getting a Nvidia soon - something that I had to do long ago, and it'll hopefully solve all my problems (and not only with games, since my current video card is driving me crazy with all kind of stuff).
    If I have any trouble with it after that I'll post here.

  5. #25
    Join Date
    Apr 2007
    Ubuntu 10.10 Maverick Meerkat

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    Darkshade, I am sorry it took me soo long to reply back to you. I keep thinking this thread is dead, but when I check on it. It's alive and kicking. I am currently playing Lineage 2 again on Ubuntu about 5+ hours a day. >.< I'm that addicted to this game :-/ If you need anything, please feel free to ask away.

    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues

  6. #26
    Join Date
    Apr 2007
    Ubuntu 10.04 Lucid Lynx

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    I get stuck in the server selection screen, I click on either server and it does not advance anymore further than that window, any idea

  7. #27
    Join Date
    Apr 2007
    Ubuntu 10.10 Maverick Meerkat

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    smo0th, I think your problme is the host file and incorrect IP address for your sever.

    sudo nano /etc/hosts
    Open /etc/hosts as root and add the following line:EXAMPLE
    (^Please remember that is only an exmple, you will have to input the correct ip and server name most likely found on your server's website.)

    Remember most Lineage 2 server's has their own server (computer) just for login screen connections and then another server just for their actually Lineage 2 game.


    PS: The image is from my siege just over the weeken. To tell you the truth, the siege was terrible, but I got some oh kay screen shots.
    (VIEW: Front person mode without interface.)
    Attached Images Attached Images
    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues

  8. #28
    Join Date
    Apr 2007
    Ubuntu 10.04 Lucid Lynx

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    hey Sugi, thanks for replying, however that is not my problem, I have done the following:

    • checked very well my hosts file
    • installed most recent nvidia drivers (8200GT card)
    • wine version is 1.0
    • downloaded tweaked system folder from wine's website
    • updated wine's directx files (dpmodemx.dll, dpnet.dll, dpwsock.dll, dpwsockx.dll)
    • disabled gameguard by adding '* hard nofile 16383' inside '/etc/security/limits.conf'
    • added l2.exe and LineageII.exe to applications list using winecfg

    any ideas will be appreciated T-T

  9. #29
    Join Date
    Apr 2007
    Ubuntu 10.10 Maverick Meerkat

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    smo0th, You should check with your admin of your server to see if the gameguard is disable. A lot of servers disable it by default. If it is disable, you should roll back to the original limits.conf file to make sure that is not one of your issues.

    Tweak system files? For your Wine's Windows's system directory or your Lineage 2 system directory?

    Also, it seems like your Lineage 2 server's connection servers is either: under a lot of pressure, because of most logins (prime hour) or the conntection server is down or your Lineage 2 game server is down or an incorrect host file. Have you tried loging in other times and other days? My old Lineage 2 server was done all the time. I ended up just leaving for another server.

    Please note, L2j servers are bugging as hell and crash a lot. Find a nice serever with hand coded game clients and good hardware.

    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues

  10. #30
    Join Date
    Jul 2008

    Re: Howto: Lineage 2 - C6 in Ubuntu 7.10

    Hello I am Trying To Open L2.exe I have A Critical Saying General Protection Fault and i Have Edited the Line * hard nofile 16383
    So what may be The Problem Anyone KnowS plz Respond ,,,
    Ok All Problems SolVed
    Last edited by nackgr; December 1st, 2008 at 09:30 PM.

Page 3 of 5 FirstFirst 12345 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts