Results 1 to 4 of 4

Thread: HOWTO: HD (X264) Playback on Slow CPU

  1. #1
    Join Date
    Dec 2005
    Location
    Lund, Sweden
    Beans
    10

    HOWTO: HD (X264) Playback on Slow CPU

    After some experimenting I finally got a 1080p video working on my system (Pentium 4 3.4GHz 1GiB RAM nVidia GeForce 6800). I thought some people could possibly be interested in reading how I solved the audio-latency/heavy CPU-usage problems.

    Mplayer insisted that my system was too slow so I took its advice and tried to lower the settings. I have now found a functional setup that gives me a decent CPU-load and acceptable quality.

    Step 1
    Create the file /usr/local/bin/mplayer-x264

    Code:
    sudo -e /usr/local/bin/mplayer-x264
    Code:
    #!/bin/bash
    nice -n 0 mplayer -vfm ffmpeg -lavdopts lowres=2:fast:skiploopfilter=all:threads=8 "${1}"
    Step 2
    Make it executable

    Code:
    sudo chmod +x /usr/local/bin/mplayer-x264
    Step 3
    Play your video

    Code:
    mplayer-x264 *.mkv
    Newer systems (try this)
    • Lower the lowres option to 1 or 0

  2. #2
    Join Date
    Dec 2006
    Location
    Amsterdam, Netherlands
    Beans
    18
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: HD (X264) Playback on Slow CPU

    My Pentipruttel is even slower at 2.8 GHz. I tried overclocking the thing but it didn't help much. This fix improved things significantly but didn't completely solve it. 720p is acceptable but 1080p is still out of my league. Guess I really need a faster box...

    Anyway, as I wanted to use my desktop and not the command line to start my movies I created a new launcher. In the "name" box I entered "Mplayer x264", in the "Command" field "nice" then clicked OK. Then I brought up properties, and in the "Launcher" tab entered in the "Command" field
    Code:
    nice -n 0 gmplayer -vfm ffmpeg -lavdopts lowres=2:fast:skiploopfilter=all:threads=8
    Note that I used gmplayer to get the Mplayer UI on my desktop and do not pass a filename to it. I will just open it from Mplayer and browse like I always did.

    In the desktop launcher file (in ~/Desktop) I added somewhere
    Code:
    Icon=mplayer.xpm
    as the Mplayer icon is not available in the pick list.

    TJ
    Last edited by Regenpak; August 2nd, 2008 at 10:02 PM.

  3. #3
    Join Date
    Dec 2009
    Beans
    1

    Re: HOWTO: HD (X264) Playback on Slow CPU

    Sry for late post, but I've got the same problem, and almost found a solution to it.

    Try -autosync 30 (start mplayer from terminal, of course). Greatly improved the performance om my P4 (2,62Ghz) system when playing 1080p. Still, after a short time of playback, mplayer complains about too many video packets in the buffer. I, for some reason, then tried to add the flag -nosound, and what do you know, almost perfect playback.
    Last edited by Gaxnys; December 31st, 2009 at 10:19 AM. Reason: Just added some more text

  4. #4
    Join Date
    Jun 2006
    Beans
    82

    Re: HOWTO: HD (X264) Playback on Slow CPU

    Thanks for the tip, worked great to get my old P4 2.4 GHz to play a 720p file.
    Desktop: Opty 165 @ 289x9, 1.38v | 2x1GB G.Skill, 3-4-4-8, 2.6v | nVidia 7600GT | Sound Blaster Audigy 2
    Laptop: Intel Centrino Duo T2300 | 2 GB Ram | Intel 945GM Graphics | Intel 3945ABG Wireless

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •