Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Need help with USB support in VMware.

  1. #1
    Join Date
    Nov 2007
    Beans
    5

    Need help with USB support in VMware.

    I need the WINXP virtual windows to be able to detect when i connect a USB device to it.
    Anyone able to help with this? Any would be greatly appreciated.

  2. #2
    Join Date
    Oct 2007
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Need help with USB support in VMware.

    Not that this helps you, but I had a lot of problems with VMWare player. When I tried to plug in usb drives, VMWare would crash. I have looked around and it seems to be an issue with player, I think VMware server is more stable but I don't know. Might have better luck with that.

  3. #3
    Join Date
    Nov 2007
    Beans
    5

    Re: Need help with USB support in VMware.

    To be more specific, I'm using Kubuntu with VMware server console. I'm really new to this also. What i need is.... I need phones to be detected by vmworkstation virtual XP machine so i can load applications onto them.

    Thanks.

  4. #4
    Join Date
    Feb 2007
    Location
    Cameron Park CA USA
    Beans
    4,566
    Distro
    Ubuntu Development Release

    Re: Need help with USB support in VMware.

    To get USB devices to work with Gutsy you need to uncomment four lines in a file:

    Code:
    sudo gedit /etc/init.d/mountdevsubfs.sh
    Lines 42-45 get uncommented, starting with #mkdir -p /dev/bus/usb/.usbfs.

    That should do it. Feisty didn't have these lines commented out. I don't know why Gutsy does.
    Regards, frank, at http://yantrayoga.typepad.com/noname/
    Homebuilt Lian-Li PC-Q33WB, Intel i7-4790K 4.6GHz, SSDs,16G RAM | Dell Laptop 11.6" N3050.
    Oracle VBox w/ WinXP/Win8 running Xara Designer, PaintShopPro, and InDesign CS.

  5. #5
    Join Date
    Apr 2007
    Beans
    18

    Re: Need help with USB support in VMware.

    hmm...

    i uncommented the lines, restarted vmware server console and the virtual os, but still, in the VM - removable devices - usb devices meny it says EMPTY...

    i got a software in xp that needs a e.gate cyberflex usb dongle to work...

    ideas?

  6. #6
    Join Date
    Feb 2007
    Location
    Cameron Park CA USA
    Beans
    4,566
    Distro
    Ubuntu Development Release

    Re: Need help with USB support in VMware.

    You need to reboot to have it right. Or

    Code:
    sudo /etc/init.d/mountdevsubfs.sh start
    That should do it too.
    Regards, frank, at http://yantrayoga.typepad.com/noname/
    Homebuilt Lian-Li PC-Q33WB, Intel i7-4790K 4.6GHz, SSDs,16G RAM | Dell Laptop 11.6" N3050.
    Oracle VBox w/ WinXP/Win8 running Xara Designer, PaintShopPro, and InDesign CS.

  7. #7
    Join Date
    Aug 2007
    Beans
    2

    Re: Need help with USB support in VMware.

    fjgaude

    You're the BOMB! I looked everywhere for the fix to this and you had it! Thanks man.

  8. #8
    Join Date
    Feb 2007
    Location
    Cameron Park CA USA
    Beans
    4,566
    Distro
    Ubuntu Development Release

    Re: Need help with USB support in VMware.

    Bravo, and congrates. Now set this post to [SOLVED] whoever started it.
    Regards, frank, at http://yantrayoga.typepad.com/noname/
    Homebuilt Lian-Li PC-Q33WB, Intel i7-4790K 4.6GHz, SSDs,16G RAM | Dell Laptop 11.6" N3050.
    Oracle VBox w/ WinXP/Win8 running Xara Designer, PaintShopPro, and InDesign CS.

  9. #9
    Join Date
    Feb 2005
    Beans
    202

    Re: Need help with USB support in VMware.

    I also had this problem, although I followed this post:

    http://ubuntuforums.org/showthread.php?p=3879483

    which worked immediately.

    Does anyone know why this issue has suddenly started with Gutsy and has 2 different fixes?
    Last edited by psypher; December 4th, 2007 at 06:49 PM. Reason: subscription

  10. #10
    Join Date
    Feb 2007
    Location
    Cameron Park CA USA
    Beans
    4,566
    Distro
    Ubuntu Development Release

    Re: Need help with USB support in VMware.

    Doesn't seem those who know will speak up.

    I've put more "solutions" into my main box without troubles, so... I do think this will likely be fixed in Hardy in April '08. All this stuff is moving so fast. Virtualazation is moving into its own. Just wait until Xen gets there, likely with Hardy.
    Regards, frank, at http://yantrayoga.typepad.com/noname/
    Homebuilt Lian-Li PC-Q33WB, Intel i7-4790K 4.6GHz, SSDs,16G RAM | Dell Laptop 11.6" N3050.
    Oracle VBox w/ WinXP/Win8 running Xara Designer, PaintShopPro, and InDesign CS.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •