Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Ubuntu, VirtualBox, and OSX (Tiger) Intel

  1. #1
    Join Date
    Feb 2007
    Beans
    5

    Help Please!!!, Ubuntu, VirtualBox, and OSX (Tiger) Intel

    Hello I'm new to Ubuntu and VirtualBox, and I have a problem. My system is the following

    Apple 15-inch: 2.4GHz MacBook Pro (Tiger)

    • 2.4GHz Intel Core 2 Duo
    • 1440 x 900 resolution
    • 2GB memory
    • NVIDIA GeForce 8600M GT graphics with 256MB SDRAM


    and

    Apple Cinema HD Display (30" flat panel)

    • 2560 x 1600 resolution


    Now, I was able to install Ubuntu 7.10 via VirtualBox successfully, but the it will not go fullscreen.

    I have install guest additions in VirtualBox and press Left Apple - F and the resolution is still 1024x768. After installing the guest additions in VirtualBox my graphics card is vboxvideo is this correct and the resolution is set 1024x768.

    Am I skipping a step? Is there a way is to set the resolution to 1440x900 on my MacBook Pro and when its connected to my Cinema Display to set that to 2560x1600?

    I'm lost please help...
    Last edited by brothamann; November 14th, 2007 at 04:51 PM.

  2. #2
    Join Date
    Apr 2006
    Location
    /home
    Beans
    1,058

    Re: Help Please!!!, Ubuntu, VirtualBox, and OSX (Tiger) Intel

    On the Ubuntu VM, run this in the command-line:
    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    Just make sure that you pick resolutions for both full-screen and windowed mode.
    The former asjdfwejqrfjcvm msz34rq33
    UbuntuForums member #98464 | Ubuntu Help & Support
    Never run any command unless you understand exactly what it will do. [link]

  3. #3
    Join Date
    Feb 2007
    Beans
    5

    Re: Ubuntu, VirtualBox, and OSX (Tiger) Intel

    Thanks, I'm able to get 1440x900 but not 2560x1600, and now I have no cursor.

    What did I do wrong?

  4. #4
    Join Date
    Apr 2006
    Location
    /home
    Beans
    1,058

    Re: Ubuntu, VirtualBox, and OSX (Tiger) Intel

    Quote Originally Posted by brothamann View Post
    Thanks, I'm able to get 1440x900 but not 2560x1600, and now I have no cursor.

    What did I do wrong?
    Can you post the output of this command?
    Code:
    cat /etc/X11/xorg.conf
    The former asjdfwejqrfjcvm msz34rq33
    UbuntuForums member #98464 | Ubuntu Help & Support
    Never run any command unless you understand exactly what it will do. [link]

  5. #5
    Join Date
    Feb 2007
    Beans
    5

    Re: Ubuntu, VirtualBox, and OSX (Tiger) Intel

    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"ZAxisMapping"		"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"stylus"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"eraser"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"cursor"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"Generic Video Card"
    	Driver		"vboxvideo"
    	BusID		"PCI:0:2:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync	28-72
    	VertRefresh	43-60
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Generic Video Card"
    	Monitor		"Generic Monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Modes		"1440x900" "1280x960" "1024x768"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    
    # Uncomment if you have a wacom tablet
    #	InputDevice     "stylus"	"SendCoreEvents"
    #	InputDevice     "cursor"	"SendCoreEvents"
    #	InputDevice     "eraser"	"SendCoreEvents"
    EndSection

  6. #6
    Join Date
    Apr 2006
    Location
    /home
    Beans
    1,058

    Re: Ubuntu, VirtualBox, and OSX (Tiger) Intel

    OK, here's your file with the correct resolution settings:
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        Identifier    "Generic Keyboard"
        Driver        "kbd"
        Option        "CoreKeyboard"
        Option        "XkbRules"    "xorg"
        Option        "XkbModel"    "pc105"
        Option        "XkbLayout"    "us"
    EndSection
    
    Section "InputDevice"
        Identifier    "Configured Mouse"
        Driver        "mouse"
        Option        "CorePointer"
        Option        "Device"        "/dev/input/mice"
        Option        "Protocol"        "ImPS/2"
        Option        "ZAxisMapping"        "4 5"
        Option        "Emulate3Buttons"    "true"
    EndSection
    
    Section "InputDevice"
        Driver        "wacom"
        Identifier    "stylus"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"        "stylus"
        Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
        Driver        "wacom"
        Identifier    "eraser"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"        "eraser"
        Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
        Driver        "wacom"
        Identifier    "cursor"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"        "cursor"
        Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
    EndSection
    
    Section "Device"
        Identifier    "Generic Video Card"
        Driver        "vboxvideo"
        BusID        "PCI:0:2:0"
    EndSection
    
    Section "Monitor"
        Identifier    "Generic Monitor"
        Option        "DPMS"
        HorizSync    28-72
        VertRefresh    43-60
    EndSection
    
    Section "Screen"
        Identifier    "Default Screen"
        Device        "Generic Video Card"
        Monitor        "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
            Modes        "2560x1600" "1440x900" "1280x960" "1024x768"
        EndSubSection
    EndSection
    
    Section "ServerLayout"
        Identifier    "Default Layout"
        Screen        "Default Screen"
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
    
    # Uncomment if you have a wacom tablet
    #    InputDevice     "stylus"    "SendCoreEvents"
    #    InputDevice     "cursor"    "SendCoreEvents"
    #    InputDevice     "eraser"    "SendCoreEvents"
    EndSection
    Save this somewhere in your home folder, and then run this:
    Code:
    sudo cat /path/to/file > /etc/X11/xorg.conf
    This command will take the contents of the edited file, and put them in the real xorg.conf file.
    I hope it works.
    The former asjdfwejqrfjcvm msz34rq33
    UbuntuForums member #98464 | Ubuntu Help & Support
    Never run any command unless you understand exactly what it will do. [link]

  7. #7
    Join Date
    Feb 2007
    Beans
    5

    Re: Ubuntu, VirtualBox, and OSX (Tiger) Intel

    First I want to say thanks for everything.

    "2560x1600" did not work, but "1440x900" did. Now I have no cursor.

    What's next?

  8. #8
    Join Date
    Apr 2006
    Location
    /home
    Beans
    1,058

    Re: Ubuntu, VirtualBox, and OSX (Tiger) Intel

    Quote Originally Posted by brothamann View Post
    First I want to say thanks for everything.

    "2560x1600" did not work, but "1440x900" did. Now I have no cursor.

    What's next?
    That's to bad about the resolution. It could be that the VirtualBox driver simply can't support that high a resolution.

    To get your mouse back, run this and tell me what it says.
    Code:
    ls /etc/X11/
    The former asjdfwejqrfjcvm msz34rq33
    UbuntuForums member #98464 | Ubuntu Help & Support
    Never run any command unless you understand exactly what it will do. [link]

  9. #9
    Join Date
    Feb 2007
    Beans
    5

    Re: Ubuntu, VirtualBox, and OSX (Tiger) Intel

    ls /etc/X11/

    • app-defaults
    • cursors
    • default-display-manager
    • fonts
    • rgb.txt
    • x
    • xinit
    • xkb
    • xorg.conf
    • xorg.conf~
    • xorg.conf.bak
    • xorg.conf.failsafe
    • xorg.conf.failsafe.bak
    • Xresources
    • xserver
    • Xsession
    • Xsession.d
    • Xsession.options
    • Xwrapper.config

  10. #10
    Join Date
    Apr 2006
    Location
    /home
    Beans
    1,058

    Re: Ubuntu, VirtualBox, and OSX (Tiger) Intel

    Try running this:
    Code:
    cd /etc/X11/
    sudo mv ./xorg.conf.bak ./xorg.conf
    That should put your mouse back.
    The former asjdfwejqrfjcvm msz34rq33
    UbuntuForums member #98464 | Ubuntu Help & Support
    Never run any command unless you understand exactly what it will do. [link]

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •