Results 1 to 4 of 4

Thread: multiple x sessions on LTSP

  1. #1
    Join Date
    Jul 2006

    multiple x sessions on LTSP

    How can I run multiple x sessions on LTSP? I tried in the lts.conf


    I can log onto the first, then when I go to log on the starts to logon and the just kicks me back out. If I set one of the screens to
    SCREEN_09=startx all i get is a gray screen with an x courssor. If I set it to SCREEN_10=shell I get the console, but if I type startx -- :01 it fails.

    Any ideas???
    I'm trying to use this for automation, and If I could use this I could use one machine in place of four by using virtualization
    Last edited by bazz; November 4th, 2007 at 05:53 PM.

  2. #2
    Join Date
    Jul 2006

    Re: multiple x sessions on LTSP

    Well I kinda figured it out...for those of you who might like to know. I replaced ldm with gdm, and I did an edit to the gdm.conf. Where you comment out 0=Standard, and the uncomment out 0=Chooser. I than added two more choosers so it would look like this.

    I can start a new session by logging on to each chooser being the ctrl+alt+f7, ctrl+alt+f10, ctrl+alt+f11. The log ons have no problems....However when I go back to one of the other screens all I have is a blinking cursor. For example
    I log onto the ctrl+alt+f7 screen...logs on fine. I then goto ctrl+alt+f10 and log on. Logson fine. I then go back to ctrl+alt+f7 and I just have a black screen with a blinking cursor. Any ideas? ideas????

  3. #3
    Join Date
    Apr 2006
    Kubuntu Development Release

    Re: multiple x sessions on LTSP

    See if this thread helps :

    I think you can only run gdm once (gd, keeps running even after you log in). Best to disable GDM and boot to the command line & start X from there.

    You can also xinit -- :1
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  4. #4
    Join Date
    Jul 2006

    Re: multiple x sessions on LTSP

    Yes I saw that, but not what I'm looking for. I did find this though.

    Thin clients have grey screen showing only an X cursor

    Thin clients display grey screen with an X for a mouse pointer instead of login screen.

    Possible causes:


    XDMCP is disabled

    GDM is not running

    Thin clients are connecting to wrong server



    Check if XDMCP is enabled. To do this, go to the server (you may have to connect a display, keyboard and mouse), and click on the main menu button on the bottom of the screen. Go to the System Settings menu, and choose "Login" to modify your login settings. You will have to enter the root password. Then, click on the "XDMCP" tab, and ensure that the box that says "enabled" is selected.

    Check if GDM is running. You can gain access to the server by using a secure shell from one of the thin clients (refer to the section called “Using a secure shell from one of the thin clients”). To check if GDM is running (once logged in), type:

    #ps -e | grep " .dm"

    If GDM is running, you will see an output similar to this:

    1973 ? 00:00:00 gdm
    3226 ? 00:00:00 gdm

    If GDM is not running, or if you'd like to restart GDM, you can type:



    The server to be used for LTS (Linux Terminal Services) is specified in the lts.conf file using the "server" directive. This value is normally, but may be different depending on your specific setup:

    #from lts.conf:
    server =

    If you have more than one tuXlab server, or if you have more than one computer network in your school, then this address might have to be slightly different.

    So if I edit my lts.conf with
    SERVER=ip of ltsp server

    I can have multiple sessions. How ever I can not get my main account to log on, only other users. Also If I leave the session for a little while it will drop the session, so the GUI no longer works.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts