Page 1 of 7 123 ... LastLast
Results 1 to 10 of 68

Thread: ABAQUS: finite element analysis

  1. #1
    Join Date
    Nov 2005
    Location
    127.0.0.1
    Beans
    354
    Distro
    Ubuntu Development Release

    ABAQUS: finite element analysis

    Anyone here using ABAQUS? i am using it for my research. I have to learn python to do the scripting now. just wondering if anyone experienced with ABAQUS here could help with some questions...

    thnks

  2. #2
    Join Date
    Nov 2005
    Location
    vienna, austria
    Beans
    11
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: ABAQUS: finite element analysis

    I am working on PhD Thesis using ABAQUS. Scripting is explained in the "ABAQUS Scripting User's Manual".
    In case you are not familiar with Python - it is not necessary to learn all the details of the python language to be able to write ABAQUS scripts...
    Any specific questions?
    greetings,
    Robert

  3. #3
    Join Date
    Aug 2007
    Beans
    109

    Re: ABAQUS: finite element analysis

    Quote Originally Posted by ro314 View Post
    I am working on PhD Thesis using ABAQUS. Scripting is explained in the "ABAQUS Scripting User's Manual".
    In case you are not familiar with Python - it is not necessary to learn all the details of the python language to be able to write ABAQUS scripts...
    Any specific questions?
    greetings,
    Robert
    how did u install Abaqus on ubuntu
    i am trying to install Abaqus 6.7 on Ubuntu 7.10
    but no success so far,
    also the setup file in abaqus folder dont run

    it says :
    Code:
    bash: setup: command not found
    then I went into the folder which has "install.bin
    and used the following command
    Code:
     chmod a+x install.bin
    ./install.bin
    this went till some step , but in the end, it was not able to verify the installation and exit with error


    pls pls help me

  4. #4
    Join Date
    Nov 2005
    Location
    vienna, austria
    Beans
    11
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: ABAQUS: finite element analysis

    Quote Originally Posted by cherry316316 View Post
    how did u install Abaqus on ubuntu
    i am trying to install Abaqus 6.7 on Ubuntu 7.10
    but no success so far,
    also the setup file in abaqus folder dont run
    hi!
    unfortunately i have never installed abaqus myself - our system administrator is doing these things. i can not even ask him - he is on holiday. i remember he once said that installing abaqus in ubuntu (which is not officially suported) is quite tricky.
    good luck,
    robert

  5. #5
    Join Date
    Aug 2007
    Beans
    109

    Re: ABAQUS: finite element analysis

    Quote Originally Posted by ro314 View Post
    hi!
    unfortunately i have never installed abaqus myself - our system administrator is doing these things. i can not even ask him - he is on holiday. i remember he once said that installing abaqus in ubuntu (which is not officially suported) is quite tricky.
    good luck,
    robert
    well , Thanks

    in case you come to know something then do let me know

    cherry

  6. #6
    Join Date
    Aug 2007
    Beans
    109

    Re: ABAQUS: finite element analysis

    Quote Originally Posted by ro314 View Post
    hi!
    unfortunately i have never installed abaqus myself - our system administrator is doing these things. i can not even ask him - he is on holiday. i remember he once said that installing abaqus in ubuntu (which is not officially suported) is quite tricky.
    good luck,
    robert
    I want to install Abaqus on my computer Ubuntu 7.10 gusty.

    I am trying from many days, but no success so far.

    I also installed MESA separately but when i run "/media/cdrom0/setuo -sysinfo" it gives me following output
    if you have success of installing or running Abaqus so far, then please let me know. I am using Abaqus 6.7, but I also have
    cd for Abaqus 6.6

    I have also installed FORTRAN , g++ , sun-java6 and mesa , but it refuses to verify.

    when i tried to run abaqus installer according to the command given on your blog
    "/media/cdrom0/setup -nosystemchecks -jre /usr/lib/jvm/java-6-sun/jre/ -console"
    because when i write "-jre system" it says VM not found and stuff.

    so with the above command, it do runs and install the Abaqus, but when I run Abaqus after installation,
    it runs in full transparent mode, which I dont know how to fix. I have also attach the screen shot of the
    Abaqus when i run after this installation.




    my output from
    Code:
     "/media/cdrom0/setup -sysinfo"
    :


    Code:
    root@cherry-laptop:/home/cherry# /media/cdrom0/setup -sysinfo
    
    A scratch directory is required for the execution of the
    Abaqus installation procedure.
    
    TMPDIR is not defined on this system.  Provide the full path
    to the scratch directory.
    
    Scratch directory is: /tmp
    
    Checking system requirements for Abaqus.  This will
    take just a moment...
    Checking for GNU Lib C version 2.3.2 or newer.
    Pass - Found GNU Lib C Version 2.6.1.
    WARNING: Unknown Linux distribution type found on this system just setting base
             kernel version information.
    
    Running system configuration checks for Linux/x86-32.
    Please wait until all the needed information has been gathered...
    
    Current system configuration is:
    
    Hostname:             cherry-laptop
    Username:             root
    Date:                 Wed Nov  7 00:36:31 2007
    Processor:            Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz
    Number of CPUs:       2
    Linux Distribution:   Unable to determine Linux Distribution.
    Memory:               3545 Mb
    Graphics Card:        nVidia Corporation unknown chipset (0x0407) rev 161
    X11 Version:          Unable to determine X11 Version.
    OpenGL Version:       Unable to determine OpenGL version.
    X Server:
                          server glx version string: 1.4
                          client glx version string: 1.4
                          GLX version: 1.3
                          OpenGL version string: 2.1.1 NVIDIA 100.14.19
    
    
    System requirement status is:
    
    Requirement:          SuSE 9.3, 10.0 or 10.1, SuSE Enterprise Linux 9.0 or
                          10.0, SuSE Enterprise Desktop 10, Red Hat Enterprise 3.0
                          or 4.0
    Products:             All Abaqus Products
    Status:               Fail - Unable to determine Linux Distribution.
    
    Requirement:          GNU Lib C 2.3.2 or greater
    Products:             All Abaqus Products
    Status:               Pass - Found GNU Lib C 2.6.1.
    
    Requirement:          Linux Kernel 2.4.20 or newer
    Products:             All Abaqus Products
    Status:               Pass - Found Linux Kernel 2.6.22-14-generic.
    
    Requirement:          GNU Compiler Suite 3.2 or later
    Products:             Abaqus make utility with C++ and Abaqus make utility with
                          Fortran and Abaqus with user subroutines
    Status:               Pass - Found gcc version 4.1.3
    
    Requirement:          Intel 32-bits C++ Compiler 9.1
    Products:             Abaqus make utility with C++
    Status:               Fail - Unable to locate and/or determine the version of a
                          C++ compiler on this system.
    
    Requirement:          Intel 32-bits Fortran Compiler 9.1
    Products:             Abaqus make utility with Fortran and Abaqus with user
                          subroutines
    Status:               Fail - Unable to locate and/or determine the version of a
                          Fortran compiler on this system.
    
    Requirement:          HP-MPI 02.02.05.00
    Products:             Abaqus analyses using MPI-based parallelization
    Status:               Fail - Unable to locate a supported MPI implementation on
                          this system. For more information on the MPI-based
                          parallel functionality, see the section 'Parallel
                          processing modes in Abaqus' in the Abaqus Analysis User's
                          Manual.
    
    Requirement:          Mesa 4.3.0 or greater
    Products:             Abaqus/CAE and Abaqus/Viewer
    Status:               Fail - Unable to determine Mesa version.
    
    Requirement:          XFree86 or Xorg server must be configured to load the glx
                          module
    Products:             Abaqus/CAE and Abaqus/Viewer
    Status:               Pass
    
    Requirement:          Netscape 7.0, Mozilla 1.2, Firefox 1.0.1, or greater
    Products:             Abaqus Documentation
    Status:               Pass - Found Firefox 2.0.0.8
    
    Not all requirement checks succeeded.
    
    
    
    ...finished.

  7. #7
    Join Date
    Jan 2007
    Beans
    4

    Re: ABAQUS: finite element analysis

    It's a compiz problem.

    Insert this before "abaqus cae" command:

    XLIB_SKIP_ARGB_VISUALS=1

    ex: XLIB_SKIP_ARGB_VISUALS=1 /abaqus_dir/abaqus cae

    Or you have to disable desktop effects

  8. #8
    Join Date
    Aug 2007
    Beans
    109

    Re: ABAQUS: finite element analysis

    Dear Dandelo,

    Thanks a million.

    I tried many things from many days, I was in the impression, that there is problem in installation , or may be java etc etc . but nothing helped.

    Thanks again

    cherry

  9. #9
    Join Date
    Aug 2007
    Beans
    109

    Re: ABAQUS: finite element analysis

    Last edited by cherry316316; November 28th, 2007 at 10:46 PM.

  10. #10
    Join Date
    Jan 2008
    Beans
    60

    Re: ABAQUS: finite element analysis

    Hi cherry316316

    I have been following this topic with interest... sinc I am an engineer who wishes to shift completely from MScrap to Linux...

    The problem is that most of my productivity software tools are oriented to WinBlowze...

    Anyway, i am using a Laptop, ASUS F3Jr, and i have narrowed my distro search to three candidates:

    CentOS 5.1, Ubuntu 7.10, and Suse Linux 10.0.

    My choices are rather restrictive, i look for a distro that will "fit into" my hardware with the least tweaking possible (Ubuntu is the clear winner... ) AND will support the software that i use at work...

    So far i have managed to install CFD analysis codes in Ubuntu, CAD tools (pro/Engineer ), and i want to proceed to FEA multiphysics tools;

    I have two of them, one is ANSYS Multiphysics 10.0, and the other is Abaqus 6.7.

    As far as i know, simulia does not support Gutsy, so...

    I had tp convert the rpm of termcap w/ alien so as to extract the libtermcap package to /lib, so that the documentation install would not complain.

    Since Ubuntu is not supported, i installed the Abaqus product w/ the option /media/cdrom0/setup --nosystemcheck...

    Install went allright, started licence server, configured the product... ok.

    The only issue is that when i start /usr/local/abaqus/command/abaqus cae,
    the app states that there is an abaqus CAE kernel error, if i start it w/o the gui... like in /usr/local/abaqus/command/abaqus, i can run any job i want.

    Could you please give me a hint on what am i missing here? maybe some packege, or lib... ?

    So far i have only installed Abaqus in W***&5@ or Suse Linux 10.0, and used it without any problems...

    Personally, for my kind of work i don't think Multiphysics is a match for Abaqus...

    Is it possible to run abaqus Jobs in interactive environment under Ubuntu 7.10 so as i do in Suse Linux 10.0?
    If it is, what should i do to have abaqus CAE running under Ubuntu Gutsy 7.10?

    Thanks for your time.

    Alex

Page 1 of 7 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •