Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: HOWTO: Disable Ctrl-Alt-Backspace

  1. #1
    Join Date
    Mar 2005
    Beans
    423

    HOWTO: Disable Ctrl-Alt-Backspace

    I'm sure everyone has hit these three buttons before. So annoying! Here is how to disable them:
    • Open xorg.conf for editing
      Code:
      sudo gedit /etc/X11/xorg.conf
    • Add these 3 lines to the end:
      Code:
      Section "Serverflags"
      Option "DontZap"      "yes"
      EndSection
    • Save the file and close gedit

    Now all you have to do is run 'sudo invoke-rc.d gdm restart', hit ctrl-alt-backspace (last time it will work), or log out and ctrl-alt-backscape will be dead!
    Travis Watkins
    Blog: Realist Anew
    Projects: Compiz

  2. #2
    Join Date
    Mar 2006
    Location
    Suffolk County, NY
    Beans
    158
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    Actually I've discovered that ServerFlags is not the right section (at least not on the 2 Ubuntu 8.04 Desktop systems I just installed)

    On both my systems putting that in ServerFlags caused X to go into 640x480 and get stuck there. Not sure why, but putting it in ServerLayout worked perfectly. Now my users can't kick each other off when they lock the screen.

    BTW: If you want to prevent use switching from a locked screen I'd suggest changing the permissions on /usr/bin/gdmflexiserver to 750. User switching can still occur from unlocked sessions though.
    chown us:us -R /AllYourBase
    Quote Originally Posted by Black Razor View Post
    It takes an intelligent open minded individual to come from windows to Linux.

  3. #3
    Join Date
    May 2009
    Beans
    7

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    Quote Originally Posted by Amaranth View Post
    I'm sure everyone has hit these three buttons before. So annoying! Here is how to disable them:
    • Open xorg.conf for editing
      Code:
      sudo gedit /etc/X11/xorg.conf
    • Add these 3 lines to the end:
      Code:
      Section "Serverflags"
      Option "DontZap"      "yes"
      EndSection
    • Save the file and close gedit

    Now all you have to do is run 'sudo invoke-rc.d gdm restart', hit ctrl-alt-backspace (last time it will work), or log out and ctrl-alt-backscape will be dead!
    Can you please not have this as a default setting?
    users "accidently" hitting ctl-alt-backspace is laughable. This is a "core" function in linux and essential when X locks up your system.

  4. #4
    Join Date
    Aug 2006
    Beans
    278

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    Quote Originally Posted by marcus0263 View Post
    Can you please not have this as a default setting?
    users "accidently" hitting ctl-alt-backspace is laughable. This is a "core" function in linux and essential when X locks up your system.
    essential as X locks up all the time?
    why dont you just hit reset on your PC-Case if X locks up, for users this is pretty much the same as anything running on X will be killed and lost anyway if you hit Ctrl-Alt-Del.

  5. #5
    Join Date
    May 2009
    Beans
    7

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    Quote Originally Posted by Npl View Post
    essential as X locks up all the time?
    why dont you just hit reset on your PC-Case if X locks up, for users this is pretty much the same as anything running on X will be killed and lost anyway if you hit Ctrl-Alt-Del.
    Why reboot the system and do a hard reset, therefore increasing chances of file corruption when all you have to do is kill X?

    Serously the lame excuse of "accidently hitting ctrl-alt-backspace" is laughable.

  6. #6
    Join Date
    Mar 2005
    Beans
    423

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    This is an Xorg upstream default change, not an Ubuntu-specific change. We just agree with their decision so did not override it.

    If you want Ctrl-Alt-Backspace to work you are not a regular user (they have no idea what it is anyway) so you should have no problem turning it back on.

    Code:
    Section "Serverflags"
    Option "DontZap"      "no"
    EndSection
    Travis Watkins
    Blog: Realist Anew
    Projects: Compiz

  7. #7
    Join Date
    May 2009
    Beans
    7

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    Quote Originally Posted by Amaranth View Post
    This is an Xorg upstream default change, not an Ubuntu-specific change. We just agree with their decision so did not override it.

    If you want Ctrl-Alt-Backspace to work you are not a regular user (they have no idea what it is anyway) so you should have no problem turning it back on.

    Code:
    Section "Serverflags"
    Option "DontZap"      "no"
    EndSection
    Yeah I'll take this upstream, this is idiotic IMO. As to the "regular user", people I've converted over to Linux use this, why? If they've had X lock up on them I've told them just hit ctrl-alt-backspace and log back in. Just because a "newb" doesn't know how to use a feature doesn't mean it's useless let alone remove it.

    I've read the upstream thread on this, this change was brought about because "some" Emac's users hit it by mistake. So an extremely small (and shrinking BTW) group is behind this change?

    Anyway, thanks for responding

    Cheers

  8. #8
    Join Date
    Mar 2005
    Beans
    423

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    No, it has almost nothing at all to do with emacs users. One person mentioned that and everyone kind of jumped on it.
    Travis Watkins
    Blog: Realist Anew
    Projects: Compiz

  9. #9
    Join Date
    Dec 2007
    Location
    Behind you!!
    Beans
    977
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    I also agree that this is a bad change but whats done is done so instead I offer a quick-fire way of enabling/disabling this, install the package dontzap

    Code:
    sudo apt-get install dontzap
    Then to enable ctrl+alt+backspace issue this command

    Code:
    dontzap -d
    To disable it, run

    Code:
    dontzap -e
    Hope this helps,

    Bodsda
    computer-howto
    Linux is not windows
    Fluxbox & Flux menu how to
    Programming is an art. Learn it, Live it, Love it!


  10. #10
    Join Date
    Sep 2008
    Location
    London, UK
    Beans
    491

    Re: HOWTO: Disable Ctrl-Alt-Backspace

    Quote Originally Posted by Bodsda View Post
    I also agree that this is a bad change but whats done is done so instead I offer a quick-fire way of enabling/disabling this, install the package dontzap

    Code:
    sudo apt-get install dontzap
    Then to enable ctrl+alt+backspace issue this command

    Code:
    dontzap -d
    To disable it, run

    Code:
    dontzap -e
    Hope this helps,

    Bodsda
    Brilliant advice.

    This has been disabled as default in jaunty and it is more useful installed. I used it on the occasion x froze and i did not want to manual re-boot. I have never hit those three keys by accident. This is like saying they should remove terminal because you *could* rm your whole system. This link proves the vast majority think the same way http://ubuntu-virginia.ubuntuforums.....php?p=6645669
    For high-res minimalist and abstract wallpapers check out my Deviantart profile - http://hyperdude111.deviantart.com/

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •