Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Arabic input prob.

  1. #1
    Join Date
    Aug 2007
    Beans
    16
    Distro
    Ubuntu 9.10 Karmic Koala

    Arabic input prob.

    Hi,
    I just installed Ubuntu 7.04 using wubi
    on my Toshiba laptop, so now i have a dual boot! everything looks so great except the arabic input! i've tried many ways to get it work out! but so far no luck! and the SCIM is just driving me crazy!
    I really wanna get rid of Windows XP for good! but so far this prob. is holding me back!

    Please help me out!

    Many Thanks!

  2. #2
    Join Date
    Dec 2006
    Location
    Cairo, Egypt
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Arabic input prob.

    Hi. first of all, welcome to the forum! Let's see if we can help you really get rid of XP.. I have been Windows free since August 2006 (a year! woohoo!) and everything is completely eshta I would never go back.

    That SCIM thing had driven me crazy in the past, too. If I remember correctly, this is what I did to get rid of it.

    System > Administration > Language Support

    نظام > الإدارة > دعم اللغات

    Input your password, Uncheck the checkbox "Enable support to enter complex characters" "فعّل دعم إدخال المحارف المعقدة"

    I believe that should do it. Let me know if the problem persists.

    Welcome to the light side of the force

  3. #3
    Join Date
    Aug 2007
    Beans
    16
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Arabic input prob.

    Hi,
    I unchecked "Enable support to enter complex characters" as you said and now no more SCIM shows in the tool bar! and every thing now seems to work just fine , only when I type arabic in aMSN (0.97b) the arabic lettes wont connect in word and the reading dir. is from left to right! i.e. let say i want type fire fox it will show like س ك و ف ر ي ا ف but the other side will get like فايرفوكس is this aMSN prob. or my OS setting?

    Thanks for you support!

  4. #4
    Join Date
    Dec 2006
    Location
    Cairo, Egypt
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Arabic input prob.

    aMSN does the same on my machine, I believe that this is something wrong with aMSN itself.. I don't think it supports Arabic shaping. Hmmm.. maybe we should file a bug report.

    As you said, the recipient does not receive gibberish and is able to read what you write in Arabic normally. If it bothers you (being unable to read what THEY write easily), there are lots of other instant messaging programs for Ubuntu. I myself am using Kopete and it rocks... it does everything the Windows client does as far as I can see, with the only downside being that it is a KDE program. You can get it through Add/Remove Programs.

    Of course, You can also experiment with other programs and see which one suits you the best. Good Luck.

    Cheers.

  5. #5
    Join Date
    Jul 2007
    Beans
    1

    Re: Arabic input prob.

    Hello, I know that's seam like a stupid question, but how to install the arabic support language. I couldn't find it any where, even though in scim it's there. I want to write in open office in arabic.

    Thank you all for you time.
    Rami

  6. #6
    Join Date
    Dec 2006
    Location
    Cairo, Egypt
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Arabic input prob.

    No, it is not a stupid question at all Language options in Gnome are scattered everywhere.

    To add Arabic support, just go to System > Administration > Language Support ... enter your password, and check Arabic. This will download and install the necessary packages.

    Now, if you want, you can add an applet for changing the language (like the language bar in Windows) by right-clicking a panel > Add to Panel and drag and drop "Keyboard Indicator" to where you like on the panel.

    Also, you can change the interface language by selecting Options > Choose Language... at the login screen.

  7. #7
    Join Date
    Aug 2007
    Beans
    16
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Arabic input prob.

    Yeah! I beileve its Amsn bug! so i just uninstall it and everything in good shape now!

    Cheers!

  8. #8
    Join Date
    Sep 2006
    Location
    Alexandria
    Beans
    1,202
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Arabic input prob.

    Hi every one , this is a small guide to install and use the arabic language on your machines :

    If you can connect the Internet through the live cd , do sys>> admin. >> language support .it'll download / install the language package.

    If not , boot normally and connect to the Internet and then do sys. >> admin. >> software sources . this will download the univers and the multivers packages. then do sys>> admin. >> language support . this will download the Arabic language among other languages. tick the square in front of Arabic to start installing it.

    after that go for the upper panel and right click >> add to panel >> utilities >> keyboard indicator.>> add.

    after that you will find a word 'USA' appears on the panel. right click on it >> keyboard preference >> layouts >> add >> Arabic.
    this will ease the switch between languages during writing.

    Good luck
    Linux user #434738 - Ubuntu user #9391
    Be happy .....think of others and thank GOD.

    Kindly mark your thread [SOLVED] if it is done.

  9. #9

    Re: Arabic input prob.

    I tried it,but its asks you to insert the Widnows XP disk.

    Is there not a possibility to do it wihtout it.

    Seing the way you have described,seems there isnt one required.

    I wil apreciate your help.I only signed up to get some help off you.

    Thanks so much.

    Cheers!!

  10. #10
    Join Date
    Aug 2008
    Beans
    1

    Re: Arabic input prob.

    it's not just an Arabic input problem or even amsn related language issue, you wouldn't be able to see arabic font in a right direction "right to left" in flash player over sites use it for arabic contents, and in amsn official website the solution they suggested is :
    Linux: Installing the Arabic locale should solve this issue.
    lol, without saying any steps, as if a beginner typed that guide, all of us have the arabic locale installed, it's not the problem i'm sure, i'm searching for a solution for it, once got it i'll show it here

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •