Results 1 to 4 of 4

Thread: Unreal Tournament 2004 only blob shadows

  1. #1
    Join Date
    Sep 2005
    Chicago, IL USA
    Ubuntu 10.04 Lucid Lynx

    Unreal Tournament 2004 only blob shadows

    For some reason, Unreal Tournament 2004 options only allow me to select shadows up to Blob shadows. Is there a way to turn up shadows further?
    Phenom FX-5000 Quad Core @ 2.9Ghz, 4GB DDR2
    NVidia 9800GT 512MB w/Accelero S1+Turbo Module
    Dell XPS M1330, 13" LCD, 4GB ram, Intel gfx accelerator

  2. #2
    Join Date
    Mar 2007

    Re: Unreal Tournament 2004 only blob shadows

    All I can tell you is that's the only option (other than none) that I have ever seen when running the linux vesion.

    Perhaps you could try altering the config (.ini?) files directly, but I'm guessing the dev's did that on purpose.

  3. #3
    Join Date
    Sep 2007

    Re: Unreal Tournament 2004 only blob shadows

    Full, dynamic shadows are available for UT2004 for Linux! Icculus seemingly made a mistake in the latest patch (3369.2) for UT2004, in both the Linux and Mac versions. Follow these instructions for full shadows and note, you'll need that patch (3369.2) for this:

    First of all, ensure that UT2004 isn't running.

    Go to the .ut2004 directory in Home, by opening the file manager and pressing Ctrl + H. .ut2004 will appear. Then navigate to the System directory.

    Edit the UT2004.ini file - in the [OpenGLDrv.OpenGLRenderDevice] section, ensure that 'UseRenderTargets=True'.

    Then edit the User.ini file - in the [UnrealGame.UnrealPawn] section, ensure that 'bPlayerShadows=True' and 'bBlobShadow=False'; and ensure that in the [Engine.Vehicle] section, 'bVehicleShadows=True'.

    With these changes, you can now run UT2004. Edit any of the in-game settings as you wish, however, and this is quite important, DO NOT edit the Shadow settings. You'll see that it is a menu list with nothing in it, where it would say 'None, Blob', originally. Just leave it as it is - empty. Then run your favourite map, press F4 for third-person view....

    Et voila! Full shadows are now yours! People, cars and even Static Meshes all cast shadows!

    Find a screenshot below presenting full dynamic shadows in UT2004 for Linux! Also, according to the Linux Questions wiki, the UT2004 client for Linux is incapable of 'rendering-to-texture', leaving car license plates, among other (more important) things, un-rendered and blank. Well, not if you set UseRenderTargets to True, as above - see below! Enjoy.

    Furthermore, for extra quality in OpenGL rendering, assuming your computer is capable of handling it, edit these settings in the aforementioned UT2004.ini file:

    DetectedVideoMemory=(Number in MB, usually set to 0 by default)

    CacheSizeMegs=(Number in MB, usually set to 64. Set higher for better performance)

    UseVSync=True (Set False by default. 'True' provides a more consistent framerate.)
    UseVBO=True (Gives access to the OpenGL VBO. Set True for performance gain.)
    UseVSync=True (This appears twice in the settings, for some reason. Set this to True as well.)
    UsePixelShaders=True (Set to False by default. Gives access to, well, pixel shaders.)
    Last edited by Lathilde; November 26th, 2008 at 03:27 AM. Reason: Adding screenshots for reference purposes, as well as tips for OpenGL performance and quality improvement in-game.

  4. #4
    Join Date
    Sep 2006
    Ubuntu 10.04 Lucid Lynx

    Re: Unreal Tournament 2004 only blob shadows

    Setting UseVBO=True may have the opposite effect depending on hardware. On a 3.2GHz P4 system with an 875P chipset and an AGP HD2600 (ATI) running Jaunty Alpha 6 it slowed it down to a crawl.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts