Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 48

Thread: World of Warcraft - Unable to start up 3D Acceleration

  1. #21
    Join Date
    Apr 2007
    Beans
    21

    Re: World of Warcraft - Unable to start up 3D Acceleration

    I too am having this issue. I'm running an NVIDIA GeForce Ultra on Ubuntu Feisty. I installed the proper Nvidia drivers, reconfigured Xorg, and installed the nvidia-settings package. Unfortunately when I try to use nvidia-settings, i get a box with only one set of options in it, none of them pertaining to 3d acceleration -- "Display tooltips, show status bar, slider text entries, include x display names, and show "really quit?" dialog" is all I get for options. I'm assuming there should be more. Running nvidia-settings as sudo does nothing. Please help! I want to play some WoW!

  2. #22
    Join Date
    Jan 2007
    Beans
    592
    Distro
    Gutsy Gibbon Testing

    Re: World of Warcraft - Unable to start up 3D Acceleration

    NVIDIA GeForce Ultra
    which type of ultra
    please run
    lspci | grep -i vga

    I have script. Can you use my diagnostic tool as it will tell me lots of things about your setup.

    Code:
    mkdir ~/Xinfo
    cd ~/Xinfo
    wget -O xinfo.sh  http://fractaldimension.org.uk/ubuntu/xinfo.txt
    chmod a+x ./xinfo.sh
    ./xinfo.sh
    please attach the *xinfo.tar.gz

    view script
    http://fractaldimension.org.uk/ubuntu/xinfo.txt
    [mouse-drag-select] == COPY && [mouse-middle-click]== PASTE
    ---- 3D Desktop xorg.conf's ---

    ubuntu guide ---- Ubuntu Document Storage Facility ---- "Mark thread as [SOLVED]" using "Thread tools"

  3. #23
    Join Date
    Apr 2007
    Beans
    21

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Thank you sir, I don't have access to that computer right now but I will post it up as soon as I get back to campus tomorrow.

  4. #24
    Join Date
    Apr 2007
    Beans
    21

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Output of lspci | grep -i vga:

    Code:
    01:00.0 VGA compatible controller: nVidia Corporation NV15BR [GeForce2 Ultra, Bladerunner] (rev a4)
    *xinfo.tar.gz is attached. Thank you so much for your time.
    Attached Files Attached Files

  5. #25
    Join Date
    Jan 2007
    Beans
    592
    Distro
    Gutsy Gibbon Testing

    Re: World of Warcraft - Unable to start up 3D Acceleration

    from Xorg.0.log
    (EE) GLX is not supported with the Composite extension

    make a xorg.conf backup
    add this to the bottom of xorg.conf
    Section "DRI"
    Mode 0666
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "off"
    EndSection

    Section "Extensions"
    Option "Composite" "Disable"
    EndSection
    in the screen section
    Option "AddARGBVisuals" "True"
    Option "AddARGBGLXVisuals" "True"
    add Section "Module"
    Load "dri"
    Try with XGL
    sudo apt-get install xserver-xgl
    restart
    [mouse-drag-select] == COPY && [mouse-middle-click]== PASTE
    ---- 3D Desktop xorg.conf's ---

    ubuntu guide ---- Ubuntu Document Storage Facility ---- "Mark thread as [SOLVED]" using "Thread tools"

  6. #26
    Join Date
    Apr 2007
    Beans
    21

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Dougfractal, you are a GOD. A GOD, I say. Thank you so much.

    EDIT: Garrr I'm afraid I spoke too soon. It works... kind of. I can sign in and get to the select character screen without a bit of lag, but then it hangs at about 66% of the loading bar after clicking "Enter World". Anyone got any ideas?

    EDIT v2.0: SOLVED by upgrading to the newest version of Wine. That's a big DOH on my part. Thanks to all who helped
    Last edited by Allysan; September 19th, 2007 at 10:52 PM.

  7. #27
    Join Date
    Dec 2004
    Location
    California
    Beans
    14
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Hey everyone, sorry to bump up this post but I seem to have run into the mentioned problem. The card is a Radeon 9600.

    here.s the file you requested in previous posts

    please bare with me, as i am a linux noob.

    Much thanks.
    Attached Files Attached Files
    Last edited by sgnlfive; September 20th, 2007 at 09:02 AM.

  8. #28
    Join Date
    Jan 2007
    Beans
    592
    Distro
    Gutsy Gibbon Testing

    Re: World of Warcraft - Unable to start up 3D Acceleration

    sgnlfive
    (II) fglrx(0): Desc: ATI FireGL DRM kernel module
    (WW) fglrx(0): Kernel Module version does *not* match driver.
    ) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
    (II(EE) fglrx(0): [drm] removed 1 reserved context for kernel
    (II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x2000 at 0xb733c000
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    You've been "Envyed" or similar.
    Uninstall flglx with envy if that what you used.

    Then reinstall fglrx

    sudo apt-get install --reinstall xorg-driver-fglrx linux-restricted-modules-2.6.20-16-generic
    [mouse-drag-select] == COPY && [mouse-middle-click]== PASTE
    ---- 3D Desktop xorg.conf's ---

    ubuntu guide ---- Ubuntu Document Storage Facility ---- "Mark thread as [SOLVED]" using "Thread tools"

  9. #29
    Join Date
    Dec 2004
    Location
    California
    Beans
    14
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Appreciate the help dougfractal. Did what ya said and now it is working great. Much thanks.

  10. #30
    Join Date
    Jan 2007
    Beans
    592
    Distro
    Gutsy Gibbon Testing

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Can you run the Xinfo script again so that I can add you to the list.

    http://fractaldimension.org.uk/ubuntu/xorg/xorg.xml

    cheers
    Doug
    [mouse-drag-select] == COPY && [mouse-middle-click]== PASTE
    ---- 3D Desktop xorg.conf's ---

    ubuntu guide ---- Ubuntu Document Storage Facility ---- "Mark thread as [SOLVED]" using "Thread tools"

Page 3 of 5 FirstFirst 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •