Page 20 of 70 FirstFirst ... 10181920212230 ... LastLast
Results 191 to 200 of 699

Thread: HOWTO: Lexmark Printers

  1. #191
    Join Date
    Oct 2005
    Rome, Ga
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: Lexmark Printers

    Raavea, have you gotten the scanner to work yet?

  2. #192

    Re: HOWTO: Lexmark Printers

    I have a z750 and I think I got the drivers working, but when I try to print, it just shoots blank paper out. I have to get this printer working or else I have to go back to windows, and we all know we don't want that...

  3. #193
    Join Date
    Dec 2006
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Lexmark Printers

    Installation went great on a P707 Lexmark printer, installed on Edgy.
    Hmm, I never had to go get the 'tail' file.

    But .. .. it prints as though the printer heads need to be aligned.

    How can I fix this?

  4. #194
    Join Date
    Nov 2006
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Lexmark Printers

    I have a Lexmark X1150 and I followed instructions steps by Black Hole Sun to a T to no avail. I have been trying to install the 600z driver for about 3 month (the time I have been using Ubuntu). I was able to installed the lexmark 35 driver but that only made my X1150 pass a paper (as if it were GAS! NO PRINTING). Well, I would go on to other project and come back to my lexmark from time to time only to be frustrated and look for an alternative printer that might work with Ubuntu. After a while I just hoped I could get the printer to work forget the scanner,lol. After several self imposed projects in Ubuntu I decide to try again, I figured I have learned a little and I do mean a little more. I could not get passed the first two commands. so l just extracted the file on my desktop by double clicking on the downloaded tar.gz file. Then I used BLACK HOLE SUN'S original codes from line 4 on. From there all was smooth sailing, seem like I had found a way to this. I got up to code line 12, where the terminal acknowledged that I have installed the driver, hooray!!! But wait! The next steps is where it all crapped out again. when I added these code :
    "$ cd /usr/lib/cups/backend
    $ ./z600"
    I got nothing!!! Well I did what Black Sun Hole suggested we do and nothing! Could not get it to work. I looked at the printer setup to see if by some miracle the driver would be there, "after all the driver did install". Well no such luck. I tried this about three time, when it occurred to me that maybe I can get the printer setup to install the driver. I remembered that there was a button that can install driver from printer setup and it had a CD icon. I then set out to find the location of the driver that was pretty easy "etc/cups/ppd". I installed it using the printer setup and ... ready for this??? Hooray!!! it installed!!! Now the next step was to have the printer print, doooh!! Ok, lets not panic, proceeded to Say a little prayer, crossed my fingers and got on my knees before attempting to print. I found a text file to print and set up the printer 600z as default using Openoffice sent the job to the printer. yeahhhhhhhhhhhh!!! I got my first print, perfect!!! Thank you to all of you for the help specially Black Hole Sun for initiating these instructions. Best of luck to you all maybe these unconventional instructions will work for some one out there. After countless hours of fun I got Ubuntu to do all I need it to do...for now No more singing the Blues, unless I want to do so!
    Desktop->Ubuntu 11.10 x64, Gamer-> Windows 7 x64 & Home Server-> Ubuntu 10.04LTS 32 bit.

  5. #195
    Join Date
    Feb 2007

    Re: HOWTO: Lexmark Printers

    Is it possible to do this with the X75?

  6. #196
    Join Date
    Jun 2006
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: Lexmark Printers

    My System:
    Kubuntu 7.10 Feisty Fawn (still in development)
    Printer: Lexmark Z25

    I used this HOWTO when setting up my Lexmark Z25 printer. Everything seemed to install properly but I could not print a test page. When I looked at my CUPS log I found this error message:

    02/03/2007 04:11:13 PM	[Job 1] Unable to open printer port "/dev/usblp0": Permission denied
    I couldn't find much through searching but I think i figured out the problem, hopefully this will help you out if you have the same troubles.

    In my case, the systemuser: "cupsys" did not have access to /dev/usblp0 because that user was not a member of the plugdev group. By adding "cupsys" to the "plugdev" group using the user management dialog I was able to allow cups to access my printer.

    Once you have added that user to the group, restart the cups daemon:
    sudo /etc/init.d/cupsys restart
    Good luck!

  7. #197
    Join Date
    Feb 2007
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Lexmark Printers

    I have a lexmark x2470 attached to a windows machine set up as a shared printer. I followed this guide completely and it seemed to be setup. When I selected the z600 model in cups and then tried to print a test page the printing dialogue came up on my windows machine. However, after the whole document was transferred my printer failed to print. It seems to be kind of slow transferring as well. I guess the driver just isn't very compatible with the x2470. I thought maybe if I could find the actual driver on the original CD I could use that, but I seem to have lost the CD.

  8. #198
    Join Date
    Feb 2007
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Lexmark Printers

    This Forum has been abundantly helpful to me in the past week or so during my endeavors in switching from MS to NIX, specifically UBUNTU(K,U,X), and for that I thank you all in advance and in retrospect.

    This post has a dual purpose: First commending the code that lead to my printers inevitable usage(even though I think my ink is dried up from it's rest in the attic) and also to point out a couple code strings that not only didn't work, but weren't required to install and use the driver.

    One quick, and confused comment before the strings....When I ran the tail command my terminal screen scrolled like a mad penguin full of strange characters, probably binary code of some sort due to the inscribed action 'tail' is supposed to perform, and left me at a /dir with this:

    /home/sotec/Desktop/lexmark# 62;9;c62;9;c62;9;c62;9;c;9;c62;9;c62;9;c62;9;c62;9 ;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c 62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62 ;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9 ;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c 62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62 ;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9;c62;9 ;c62;9;c62;9;c62;9;c62;9;ctar

    Any explanation? All I know is that after the confusion ceased to interest me, I decided to skip that part and move ahead to the commands :

    $ sudo ldconfig # DO NOT SKIP THIS STEP or your printer backend won't find required libraries
    $ cd /usr/share/cups/model
    $ sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz # unzip the ppd, which should _not_ be gzipped

    Which in fact did as they were supposed to; they config'd, moved to dir and unzipped the driver, which was cake to find in the /usr/share/cups/model dir.

    The printer works now and I couldn't be happier! But I wanted to post and share with you all the fact that the commands:

    $ tail -n +143 > install.tar.gz # the sh script is broken for newer systems. use `tail` to extract the binary portion of the script.
    $ tar -xvzf install.tar.gz # extract the contents produced by tail
    $ alien -t z600cups-1.0-1.i386.rpm # convert unusable rpm packages to tgz.
    $ alien -t z600llpddk-2.0-1.i386.rpm # convert unusable rpm packages to tgz.
    $ sudo tar xvzf z600llpddk-2.0.tgz -C / # extract the tgz's to / putting the files in their right place
    $ sudo tar xvzf z600cups-1.0.tgz -C / # extract the tgz's to / putting the files in their right place

    ...didn't work...not did they need to on my machine.
    So thank you for the awesome Tutorial!
    (now if I could only get my ink to fire on the paper....)

    Anyone know how to perform the maintenance printer actions? i.e. head cleaning?


  9. #199
    Join Date
    Apr 2006
    Skelmersdale. uk.
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Lexmark Printers

    Using Edgy.
    I have a Lexmark Z715 and followed all of the Howto as given by Black Hole Sun and everything
    went fine but when I rebooted and tried to add the new printer in the Gnome printer Cups
    system the z600 wasn't listed.
    Can anyone help. What could I have missed.

  10. #200
    Join Date
    Dec 2006
    Xubuntu 6.06 Dapper

    Re: HOWTO: Lexmark Printers

    i simply made a shell script out of the tutorial called
    it spits this output :

    creating ~/.lexmark dir
    downloading CJLZ600LE-CUPS-1.0-1.TAR.gz
               => `CJLZ600LE-CUPS-1.0-1.TAR.gz'
    Connecting to||:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 4,301,167 (4.1M) [application/x-tar]
    100%[===================================================================================>] 4,301,167      1.08M/s    ETA 00:00
    12:57:55 (725.52 KB/s) - `CJLZ600LE-CUPS-1.0-1.TAR.gz' saved [4301167/4301167]
    extracting it
    repairing nessessary shell script
    extracting the contents of installer
    coverting rpm packets to tgz
    Warning: Skipping conversion of scripts in package z600cups: postinst postrm preinst
    Warning: Use the --scripts parameter to include the scripts.
    z600cups-1.0.tgz generated
    Warning: Skipping conversion of scripts in package z600llpddk: postinst postrm preinst prerm
    Warning: Use the --scripts parameter to include the scripts.
    z600llpddk-2.0.tgz generated
    extracting tgz and puting the files in their right places
    finding required libs
    unzipping the ppd
    restarting cups daemon
     * Restarting Common Unix Printing System: cupsd                                                                        [ ok ] 
    checking back end
    all done :)
    test it by running  ./z600
    output should look similar to:
    direct z600:/dev/usb/lp0 Lexmark Lexmark Z600 Series Lexmark Printer
    sh4d3z@nix-machine:~$ ./z600
    bash: ./z600: No such file or directory
    sh4d3z@nix-machine:~$ cd /usr/lib/cups/backend
    sh4d3z@nix-machine:/usr/lib/cups/backend$ ./z600
    direct z600:/dev/usblp0 "Lexmark  Lexmark Z700-P700 Series" "Lexmark Printer"
    this worked fine on dapper, but not so great on edgy... it just sits there like a friggin' tard when i try to print test page
    i'm using a z705... we'll see what i can do later, i've been in front of this machine way too long and needa break before i resort to using sledgehammer to fix the problem lol

Page 20 of 70 FirstFirst ... 10181920212230 ... LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts