Results 1 to 4 of 4

Thread: World Of Warcraft. I can't use OpenGL, help!

  1. #1
    Join Date
    Jun 2007
    Beans
    16

    World Of Warcraft. I can't use OpenGL, help!

    I have done all the tutorials on how to wine WoW.

    But even after that, I learned I have an ATI graphics card, which apparently doesn't support the command OpenGL in the Config.wtf file.

    So, other than Direct X, is there anything else that works? Or maybe a way to make Direct X work?



    Any Help is appreciated.

    John

  2. #2
    Join Date
    Jun 2007
    Beans
    16

    Re: World Of Warcraft. I can't use OpenGL, help!

    Please, doesn't anybody know how to make WoW work on an ATI card?

  3. #3
    Join Date
    Aug 2006
    Location
    tuesday
    Beans
    6,502
    Distro
    Kubuntu Development Release

    Re: World Of Warcraft. I can't use OpenGL, help!

    There are many existing WoW threads on this forum which cover running WoW under wine (and some even with an ATI card).

    Please read through them, and ask your questions in an existing WoW thread.
    Also make sure your card is supported by the linux drivers and that they are installed corrently.

  4. #4
    Join Date
    Nov 2006
    Beans
    Hidden!

    Re: World Of Warcraft. I can't use OpenGL, help!

    this is a year too late, but oh well, just incase there are people out there who'd like to know a possible way for getting World of Warcraft to run on ubuntu "7.04", not have quite done it for 7.10 yet.
    I got it running and this was it working at around 1fps, :O omg, slow down!, but then after reading a couple of things on forums and stuff, noticed something/someone mention about using the opengl flag when running wow from console..... so typed it in and now wow works no worries on ubuntu.
    Anyway, the graphics card i was using was fx5700 by nvidia, xfx i think, but i sure this would apply after installing your ati cards.
    Follows these instructions the best you can to get your graphics card to work with your games, so you can actually "open" catalyst control center : https://help.ubuntu.com/community/BinaryDriverHowto/ATI .
    Then what i did was simply copy my wow folder from my windows machine to the ubuntu (home/username/World of warcraft) (made a folder then when its done copying, you won't believe how easy it is.
    sudo su
    'home/username/WorldofWarcraft//WoW.exe' - opengl

    bingO!

    if that helps, your welcome, if not, sorry, but at least i tried

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •