Results 1 to 10 of 49

Thread: Lubi: Wubi for Linux: Install *ubuntu on any Linux, no partitioning needed

Threaded View

  1. #11
    Join Date
    Mar 2006
    Palo Alto, CA
    Ubuntu 12.04 Precise Pangolin

    Re: Lubi: Wubi for Linux: Install *ubuntu on any Linux, no partitioning needed

    Thought I'd report on my progress (or lack thereof) with Lubi in Sabayon on my Gateway CX210X. I got it installed, but every time it tried booting the X server would crash and I was unable to resolve that with any of the methods I tried. I changed display devices, attempted to change drivers, but was unable to install new video drivers because for some reason the onboard NIC in my laptop was unable to properly get an IP, I got an IRQ error. The only way I got it to boot was in VGA mode, but no distro released recently is optimized for it and so I couldn't see half of the information that was trying to be displayed so I gave up. I've booted an Ubuntu LiveDVD on the laptop without any issues so I know the hardware support is there, not quite sure what the issue is.
    Interesting issue... this Ubuntu LiveDVD you booted with, is it a standard Feisty (Ubuntu 7.04) version? Or is it an older Edgy (6.10) or Dapper (6.06LTS) release? I've heard that there were some regressions on Xorg support for some ATI cards in Feisty, that might be the issue... Also, is it a CD or DVD? The standard Ubuntu disks aren't on DVDs, but on CDs... perhaps you were using the "Ultimate Edition" or some similar version with extra bundled drivers (fglrx, in particular)? My guess would be that your Radeon card isn't supported by Feisty, only through the fglrx drivers (included in unofficial Ubuntu DVD versions, and Sabyon by default) or maybe by the default drivers of some older Ubuntu versions... Maybe the same issue would be the same with the networking...

    Unless the issue has something to do with the partitioning scheme and the mounting process in booting, which apparently worked, Lubi/Wubi shouldn't technically be the cause of these issues, since it just uses the standard Ubuntu d-i code used in the installer...

    Have you tried doing a sudo dpkg-reconfigure xserver-xorg and selected a different resolution, or tried the "vesa" or "radeon" driver? Those might help with the video card issues... Apart from that, I have no clue, if you were using a different version of Ubuntu than 7.04 as your live disk, or some unofficial DVD version, could you try booting with the Ubuntu 7.04 Desktop CD, to see if it really is a bug with the Wubi/Lubi/Lupin hardware configuration process, or is just a general Feisty hardware regression issue?

    2 other potential issues: 1) Are you using LVM on your Sabayon install? Lubi won't work if you are... 2) Did you use the alternate i386 k/x/ubuntu iso, and verified its MD5sums for corruption?
    Last edited by tuxcantfly; May 30th, 2007 at 08:02 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts