Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

  1. #11
    Join Date
    Jun 2006
    Location
    $ pwd _
    Beans
    3,999
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    This is unbelievably cool. I never thought it would be possible to mount FTP host as a filesystem. Thanks a million to geco for letting me know about this wonderful tool.

    I use an ftp site that has tons of media but no search facility neither does my ftp client. With curlftpfs, I can now use regular expressions with find command to search what I need (as if I'm searching a filesystem locally). Thanks again.

  2. #12
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    I use kubuntu Gutsy and I have the same problem of Jonne, It mounts fine but:

    monteleo:~# cd /media/upnp/
    monteleo:upnp# cd Videos/
    monteleo:Videos# ls
    ls: reading directory .: Input/output error
    monteleo:Videos#
    how to solve the I/O read error?
    Thanks for your help

  3. #13
    Join Date
    Oct 2005
    Location
    Belgium
    Beans
    249
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    just FYI, I solved the problem by using smb anyway. If you're mounting a NAS or something, smb works fine. (I wanted to use FTP because of a bug in the firmware of the NAS, but that bug got fixed).

  4. #14
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    I got it to work, but I have one problem-- it doesn't mount through fstab with the rest of the drives when I boot up. I actually need to "mount -a" in order for it to show up. Any ideas?

  5. #15
    Join Date
    Jul 2008
    Beans
    6

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    Quote Originally Posted by simd View Post
    OK, fixed my own problem and curlftfs is now working (or seems to be from the limited testing I've carried out).

    In short the solution seems to be:

    ...

    Best wishes,
    David.
    That did the trick for me - Thank you very much !
    I had the same problem when trying to save/delete/rename a file it would say "transport endpoint not connected", and I could not access the mount-point anymore (the directory was listed using ls, but there was no access to it) untill I wrote
    sudo fusermount -u <mount-point>
    to unmount it.
    But now it works - Thanks !
    /Anders
    using 7.10 gutsy gibbon (32 bit version)
    PS: I've also only done limited testing with this solution, but it seems to work fine.

  6. #16
    Join Date
    Mar 2007
    Location
    Drogheda/Dublin
    Beans
    14
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    Right, I had set my mount point to be my home directory, using the nonempty option... bad idea... lost access to all my files, apart from my mounted ftp.

    Won't be doing that again.

    Best advice is just to use your an empty folder for your mounts.

    As for the person who has to mount everytime, just add a command like

    sleep 30 && mount -a to your sessions, or add the same to your /etc/rc.local

  7. #17
    Join Date
    May 2007
    Location
    San Francisco, California
    Beans
    5,851
    Distro
    Ubuntu

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    Nice tutorial.

  8. #18
    Join Date
    Jul 2005
    Location
    Gent
    Beans
    286
    Distro
    Ubuntu Gnome 17.04 Zesty Zapus

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    This is my fstab line:

    Code:
    curlftpfs#login:Password,with,commas@ftp.host.com /media/host curlftpfs  rw,allow_other,uid=skerit,gid=skerit 0 0
    It keeps giving me this error:
    Code:
    Error connecting to ftp: Access denied: 530
    Login and password are correct (There are commas in the password, though)

    If I remove the first "curlftpfs#" or if I use "fuse" instead of "curlftpfs" I get this error:

    Code:
    fuse: unknown option `MEK'
    Edit: I tried it with a user which has NO commas in the password, and it DID work, so that must be it? Can the password be saved outside of the fstab file?
    Last edited by Skerit; December 5th, 2008 at 11:04 AM. Reason: More info

  9. #19
    Join Date
    Oct 2005
    Location
    Belgium
    Beans
    249
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    have you tried escaping the commas ( \, ) or urlencoding ( %2C ) them?
    as for external files, i know you can do that with smb/cifs ( ... curlftpfs credentials=/path/to/file/pwd,rw,allow,... , not sure if you can do it with ftp)

  10. #20

    Re: [HOWTO] mount an FTP host as a filesystem using CurlFtpFS

    That's one of the best tutorial. Thanks

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •