Page 7 of 7 FirstFirst ... 567
Results 61 to 62 of 62

Thread: HOWTO: Tascam US-122 in Fiesty

  1. #61
    Join Date
    Feb 2008

    Re: HOWTO: Tascam US-122 in Fiesty

    Here is the problem, it appears that my computer is not recognizing the tascam interface...

    Here are the udev rules I have
    BUS=="usb", ACTION=="add", SYSFS{idProduct}=="8006", SYSFS{idVendor}=="1604", RUN+="/bin/sh -c '/sbin/fxload -D %N -s /lib/firmware/usx2yloader/tascam_loader.ihx -I /lib/firmware/usx2yloader/us122fw.ihx'"
    BUS=="usb", ACTION=="add", SYSFS{idProduct}=="8007", SYSFS{idVendor}=="1604", RUN+="/bin/sh -c '/usr/bin/usx2yloader'"

    KERNEL=="pcmC[D0-9cp]*", ACTION=="add", PROGRAM="/bin/sh -c 'K=%k; K=$${K#pcmC}; K=$${K%%D*}; echo defaults.ctl.card $$K > /etc/asound.conf; echo defaults.pcm.card $$K >>/etc/asound.conf'"
    KERNEL=="pcmC[D0-9cp]*", ACTION=="remove", PROGRAM="/bin/sh -c 'echo defaults.ctl.card 0 > /etc/asound.conf; echo defaults.pcm.card 0 >>/etc/asound.conf'"
    When I lsusb, I get

    Bus 005 Device 004: ID 0644:800e TEAC Corp.
    Bus 005 Device 003: ID 05ca:1836 Ricoh Co., Ltd
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 003: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000

    But it should be

    Bus 005 Device 004: ID 8006:1604 Tascam US-122 Audio/Midi Interface

    Somehow, the ID numbers aren't correct...

    sudo usx2yloader gives
    usx2yloader: no US-X2Y-compatible cards found

    cat /proc/asound/cards
    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xd2300000 irq 23

    which is my sound card, but no Tascam. Also maybe something with /etc/asound.conf?
    Last edited by Intolucidity; July 22nd, 2008 at 06:22 AM.

  2. #62
    Join Date
    Nov 2006
    Chaidari, Athens, Greece
    Kubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Tascam US-122 in Fiesty

    Quote Originally Posted by RgnKjnVA View Post
    If you don't have any TEAC components on your machine, maybe you downloaded the wrong driver from the ALSA page. (?) I can't recall all the hoops I had to go through but seems odd that a TEAC usb device would be showing up. It wasn't listed when you initially ran lsusb I presume?

    BTW I was able to upgrade to Hardy and set up Pulseaudio using the "Almost perfect Pulseaudio set up" thread on these forums and it pretty much just worked. I was pleasantly surprised and it solved all of my Gutsy audio problems. I can pause without an annoying buzzing sound, my software mixer works now, I can play audio from multiple apps at the same time and I no longer get XINE errors in Amarok. I still don't know how to get real-time monitoring going when recording in Ardour but that's my last challenge audio-wise but I suspect I can't do it with a usb audio interface.
    Well, did you managed to get Pulseaudio working on Hardy using TASCAM US-122 or with another usb audio card?

Page 7 of 7 FirstFirst ... 567

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts