Results 1 to 2 of 2

Thread: Fish Tycoon in Wine -- help please

  1. #1
    Join Date
    Oct 2005

    Fish Tycoon in Wine -- help please

    Hi all,

    Trying to play Fish Tycoon in wine here. The AppDB claims it's platinum, but I'm gettin the following error:

    "Failed initializing DirectDraw. only 16-bit and 32-bit displays are supported in windowed mode."
    Console output:

    fixme:d3d:IWineD3DDeviceImpl_GetAvailableTextureMem (0x170438) : stub, simulating 64MB for now, returning 64MB left
    fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x16fc28)->(0x1002e,00000008)
    fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x16fc28)->(0x1002e,00000008)
    fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x16fc28)->((nil),00000008)
    fixme:d3d:IWineD3DStateBlockImpl_Release Releasing primary stateblock
    I've tried both 0.9.33 (feisty) and 0.9.36 (winehq), same results.

    If 3d drivers come into the equation I've got a Radeon Mobility X1600 with fglrx. fglrxinfo says my vendor string is ATI and glxinfo says direct rendering: yes, so I assume it's not an fglrx problem.

    Any ideas? How would I make it run in full screen?

  2. #2
    Join Date
    Apr 2007
    Ubuntu 10.04 Lucid Lynx

    Re: Fish Tycoon in Wine -- help please

    I have this problem with a game called shadow of legend. I fixed it by changing the default color depth to 16 bit in /etc/X11/xorg.conf. The game ran fine after that. But i don't want to run my desktop in 16 bit all the time just for 1 game There needs to be a better fix for this
    ASUS M2N32-SLI DELUXE WI-FI edition
    AMD x2 6000+
    CORSAIR 4GB DDR2-800
    ASUS NVIDIA 8800 Ultra, AUDIGY 2 ZS


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts