So i received the drives yesterday, and i really hope you guys can help me on this one, 'cause by now i'm out of ideas. mdadm only adds 2 out of 3 drives, no matter what i do.

Code:
~# mdadm --create /dev/md0 --level=5 --raid-devices=3 --size=max /dev/sda1 /dev/sdb1 /dev/sdc1
raid5: raid level 5 set md0 active with 2 out of 3 devices, algorithm 2
mdadm: array /dev/md0 started
~# cat /proc/mdstat
Personalities : [raid6] [raid5] [raid4]
md0 : active raid5 sdc1[3] sdb1[1] sda1[0]
1285199744 blocks level 5, 64k chunk, algorithm 2 [3/2] [UU_]
So far i've tried; changing SATA cables, changing the order of the drives, changed from Ubuntu 9.10 to Debian 5.04, moved the drives to another motherboard, tried with and without partitioning the drives and i even tried making a partition on each drive with about 50% of the total space.

The drives can be read and written without any problems and i can even make RAID 1 array with all three drives for a total of 4.5 tb without and troubles at all. But no matter what, i can't get a working RAID 5 array.

I really hope someone here is able to help me out.

BTW; the motherboards i've tried are based on Intel 965 and G35, each with a C2D processor and a 32 bit kernel. I think both of them carry the ICH9 south bridge. The drives are all Western Digital WD15EARS.