Page 29 of 32 FirstFirst ... 192728293031 ... LastLast
Results 281 to 290 of 320

Thread: How-To: install pSX on AMD64

  1. #281
    Join Date
    Aug 2006
    Beans
    99

    Re: How-To: install pSX on AMD64

    Thanks dfreer. This solution from another thread solved the permissions problem, and I can now launch as a regular user (thanks to Grishka):

    Code:
    1. kill pulseaudio (sudo killall pulseaudio)
    2. run pSX as root (sudo ./pSX)
    3. find the "sound" tab in the configuration and switch the "device" setting from "default" to your soundcard (plughw:0,0 in my case). apply. close pSX.
    4 open /root/.pSX/psx.ini in a text editor (gksudo gedit /root/.pSX/psx.ini). find the "device" string under [Sound] section (I have "b7d317a4" there).
    5. paste this string into the relevant section in ~/.pSX/psx.ini, in place of all zeroes. save. if you don't have this file in your user directory, run pSX and cancel just after choosing language, on the bios selection screen. pSX should save settings then.
    
    now pSX runs fine even after reboot.
    This answer also solved my 'error while loading shared libraries: libGL.so.1' problem:

    Code:
    Try this only after verifying that you do in fact have the identified files in the stated locations.
    sudo unlink /usr/lib/libGL.so.1
    sudo unlink /usr/lib32/libGL.so.1
    sudo rm /usr/lib/libGL.so.1.2
    sudo synaptic
    
    From there I reinstalled IA32 libraries using synaptic.
    Arch 3.3.1-1 (x86_64) w/Gnome 3.2
    ASUS P7P55-E-Pro, Geforce GTX460, i5-750, 8GB
    Dell XPS m1330, Geforce 8400M, 4965AGN
    HP Folio 13 Ultrabook

  2. #282
    Join Date
    Jul 2008
    Location
    Woodstock Cape Town RSA
    Beans
    989
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: How-To: install pSX on AMD64

    Thank you for the new links, I installed psx32frontend_1.11-3.1_gutsy-amd64 and it's now working

  3. #283
    Join Date
    Jun 2008
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How-To: install pSX on AMD64

    Thanks for the great work dfreer. It took some work (not bad for a saturday afternoon) but pSX is working great now.

    Here's a question...does anyone know of a way to copy "my precious" saves off of psx memory cards to USB on the PS2?

    I would love to access my saves.

  4. #284
    Join Date
    Feb 2006
    Location
    Kentucky
    Beans
    567
    Distro
    Ubuntu

    Re: How-To: install pSX on AMD64

    PSX is working great for me too, but only as root. I followed the directions in the earlier post about copying the sound device info into ~HOME/.pSX/psx.ini, but that didn't work. Whenever I try to run it as a normal user I get the following:
    Code:
     * PulseAudio configured for per-user sessions
    Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
    /usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
    Failed to load module: /usr/lib/gio/modules/libgiogconf.so
    /usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class: ELFCLASS64
    Failed to load module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
    /usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
    Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [src/linux/sound.cpp, line 582]: 'snd_pcm_open(&pcm_handle,dev->info->device_fname,SND_PCM_STREAM_PLAYBACK,0)' returned 'Device or resource busy'
    pSX: ../../../src/pcm/pcm_params.c:2259: snd_pcm_hw_refine: Assertion `pcm && params' failed.
    Aborted
    "Civilization is the limitless multiplication of unnecessary necessities."
    -- Mark Twain

  5. #285
    Join Date
    Aug 2007
    Location
    Dallas
    Beans
    60
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: How-To: install pSX on AMD64

    First of all i would like to say that this truly is the best emulator out their for linux that i've tried. at least for my system. the video is sooo much smoother and it uses literally half the resources. props to the author and dfreer for the packages. I was however posting for another reason than to extend my thanks... i get horrible sound. when i run from the command line i get "sound: underrun" repeating. any suggestions?
    "Come to the Dark Side... We have KookieS" <--haha.. its True.

  6. #286
    Join Date
    Jan 2006
    Beans
    2,031

    Re: How-To: install pSX on AMD64

    You can try increasing the sound latency within pSX by 10 MS or so, I wouldn't recommend increasing it by any more than that. Beyond that, I don't have any suggestions, sorry

  7. #287
    Join Date
    Aug 2007
    Location
    Dallas
    Beans
    60
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: How-To: install pSX on AMD64

    yeah... I've tried that. and a few other tweaks involving sound and graphics. i got the biggest difference by turning the display off of 32 bit. but still pretty choppy. if anyone else might know anything i would be grateful. BTW thanks dfreer for the quick reply.
    "Come to the Dark Side... We have KookieS" <--haha.. its True.

  8. #288
    Join Date
    Nov 2007
    Beans
    56
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How-To: install pSX on AMD64

    Try increasing the nice setting, when I had my old pc I used to set the nice setting higher than usual to fix the sound choppiness.
    You can do this through the system monitor or using the command:
    "nice -n -12 psx" or "nice -n -12 psx32"
    I only ever used to change it through the priority setting in system monitor, but recently I have been running Myst with wine and was recomended to run it with "nice -n #" in front so I guess it should work here too.

  9. #289
    Join Date
    Jun 2007
    Beans
    145
    Distro
    Xubuntu 8.10 Intrepid Ibex

    Re: How-To: install pSX on AMD64

    I've tried to install pSX but when I run it all i get is this ./pSX: error while loading shared libraries: libgtkglext-x11-1.0.so.0: cannot open shared object file: No such file or directory

    I can't seem to fix the problem. I'm using Jaunty 64 bit.

  10. #290
    Join Date
    Sep 2007
    Beans
    498

    Re: How-To: install pSX on AMD64

    Quote Originally Posted by marcusdean.adams View Post
    PSX is working great for me too, but only as root. I followed the directions in the earlier post about copying the sound device info into ~HOME/.pSX/psx.ini, but that didn't work. Whenever I try to run it as a normal user I get the following:
    Code:
     * PulseAudio configured for per-user sessions
    Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
    /usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
    Failed to load module: /usr/lib/gio/modules/libgiogconf.so
    /usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class: ELFCLASS64
    Failed to load module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
    /usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
    Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [src/linux/sound.cpp, line 582]: 'snd_pcm_open(&pcm_handle,dev->info->device_fname,SND_PCM_STREAM_PLAYBACK,0)' returned 'Device or resource busy'
    pSX: ../../../src/pcm/pcm_params.c:2259: snd_pcm_hw_refine: Assertion `pcm && params' failed.
    Aborted
    Try using pasuspender. Pulseaudio is taking up the sound card and it works with root because root has higher preference with the sound card than pulseaudio which is run by your user.

Page 29 of 32 FirstFirst ... 192728293031 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •