Results 1 to 5 of 5

Thread: xdvi couldn't allocate enough colorsx

  1. #1
    Join Date
    Mar 2007
    Beans
    309

    xdvi couldn't allocate enough colorsx

    After switching from tetex to texlive, I now get the following warning from xdvi:

    Couldn't allocate enough colors - expect low data quality

    I can click ok and the message disappears, but it is annoying to have to do that every time. I am running a fairly new Thinkpad T43 with Ubuntu edgy, so there shouldn't be any problems with colour allocation.

    Does anyone know how to remove this annoying messsage?

  2. #2
    Join Date
    Mar 2007
    Beans
    309

    Re: xdvi couldn't allocate enough colorsx

    Anyone?

  3. #3
    Join Date
    Nov 2004
    Location
    Nyack NY USA
    Beans
    988
    Distro
    Ubuntu Development Release

    Re: xdvi couldn't allocate enough colorsx

    Hmm interesting problem. I have the solution (after reading the whole error message ):
    Add the -thorough flag after xdvi.

    xdvi -thorough
    "Linux is evolution, not intelligent design." - Linus Torvalds

  4. #4
    Join Date
    Mar 2007
    Beans
    309

    Re: xdvi couldn't allocate enough colorsx

    Many thanks! Worked

    I wonder if this is something to do with my having Xubuntu installed rather than ubuntu. On my pure ubuntu PC at work I don't get this problem. Anyway, I'll just make a nice alias to take care of this in future.

  5. #5
    Join Date
    Nov 2004
    Location
    Nyack NY USA
    Beans
    988
    Distro
    Ubuntu Development Release

    Re: xdvi couldn't allocate enough colorsx

    I have a full Ubuntu and am getting this as well so I doubt it is Xubuntu causing the problem. My suspicion is that it has something to do with texlive. I only had the problem following the switch from tetex to texlive.
    "Linux is evolution, not intelligent design." - Linus Torvalds

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •