Quote Originally Posted by fou-lu View Post
hey i was wondering if anyone could help me with my D2 problem.
im using ubuntu 9.04 jaunty
wine 1.1.13
i have D2 installed (not LoD) and the latest patch
it will play the first two videos and then it will go black and i can only hear the music but see nothing. the only thing i can do is press escape to close the window.
if someone could please help me that would be great

I have a similar problem but with ubuntu 10.04 and wine 1.2. Someone replied to this post to say that he should update wine, but my wine is the latest version.

Basically, I try to run Diablo 2 and the two Blizzard opening videos run fine, but the main menu won't load. There's just a black screen with a hint of the ubuntu tool bars around and I can only hit esc to close everything and go back to the ubuntu desktop.

I've run the video test and it suggested the 3d mode. I've tried both the 3d and 2d video and both have the same result.

Any help would be greatly appreciated.