Results 1 to 6 of 6

Thread: Disable ALT in Linux while playing WoW

  1. #1
    Join Date
    May 2006
    Location
    Iowa
    Beans
    249
    Distro
    Ubuntu 7.04 Feisty Fawn

    Question Disable ALT in Linux while playing WoW

    In World of Warcraft, many add-ons use the ALT key as a modifier but in Linux the ALT key does other things... in WoW for example, one add-on wants me to use ALT click to drag the item around but if I do that it moves the entire WOW window. ALT Drag isn't the only ALT combo I want to use in-game.

    I'd like the alt key to function as intended when I'm not in WoW but I want WoW to have full control over ALT when I'm in the game.
    Linux Knowledge >> << My Head

  2. #2
    Join Date
    May 2006
    Location
    Iowa
    Beans
    249
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Disable ALT in Linux while playing WoW

    Is there no way to do this?
    Linux Knowledge >> << My Head

  3. #3
    Join Date
    Mar 2006
    Location
    Faroe Islands
    Beans
    917

    Re: Disable ALT in Linux while playing WoW

    I think you can justify asking this question in the "Desktop Environments" support room, as it's really more of a Gnome question than a game question.

  4. #4
    Join Date
    Oct 2006
    Location
    Bellingham, WA
    Beans
    4
    Distro
    Ubuntu 6.10 Edgy

    Re: Disable ALT in Linux while playing WoW

    Go to System > Preferences > Windows, and set the movement key.

  5. #5
    Join Date
    May 2006
    Location
    Iowa
    Beans
    249
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Disable ALT in Linux while playing WoW

    Thanks leanbeaf.

    Is there any way to do this via shell script? I would really prefer to just disable it while playing WoW then enable it when I quit WoW.
    Linux Knowledge >> << My Head

  6. #6
    Join Date
    Jan 2006
    Beans
    1,237
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Disable ALT in Linux while playing WoW

    I needed the same thing for Diablo II.
    There is another way to do this but It may cause another problems.
    Go to winecfg window. "add application" and select wow's exe. then go to graphics tab and unselect "Allow the window manager to control the windows". It will disable the window manager for WoW. Wine will handle the window management so it may cause other problems... If it does let us know...
    here is a screenshot
    Attached Images Attached Images
    Last edited by cb951303; February 24th, 2007 at 10:54 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •