Page 5 of 5 FirstFirst ... 345
Results 41 to 48 of 48

Thread: HOWTO: Set-up a gameport gamepad or joystick

  1. #41
    Join Date
    Oct 2005
    Kubuntu 9.04 Jaunty Jackalope

    Unhappy Re: HOWTO: Set-up a gameport gamepad or joystick

    Logitech Thunder Pad Digital here and it is connected to my ASUS motherboard (built in sound "snd_via82xx") on the GAME port.

    gameport module was already loaded.

    joydev and

    adi modules

    did not work with kcontrol or jscalibrator.

    I did not have a any js device names until I made them with
    sudo MAKEDEV js
    in the /dev/input folder. I don't even know if I should have done that.


  2. #42

    Re: HOWTO: Set-up a gameport gamepad or joystick

    for those that want to play games that dont have native joystick control

  3. #43

    Re: HOWTO: Set-up a gameport gamepad or joystick


  4. #44
    Join Date
    Jan 2006
    BC, Ca
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Set-up a gameport gamepad or joystick

    Not finding what I need...

    A friend just passed me a "REVEAL" Joystick.
    It's a serial connection to my sound card.
    I find allot of help with modules for other stick's - except this one.
    Does anyone have this brand working???
    TIA ~~!

  5. #45
    Join Date
    Aug 2008

    Re: HOWTO: Set-up a gameport gamepad or joystick

    I've got an old "PC Propad 4" hooked up to my SB Audigy's game port.

    I followed this guide and jscalibrator reports everything OK. Both axes report feedback and all the buttons register when I press them, but on three different emulators (GFCE Ultra, XSNES and ePSXe) I cant get any response from the D-pad. I map out all my buttons other than the D-pad and they work fine but when I try to map my UP button to UP in the emulator's settings, It wont register that I'm pressing anything.

    Am I missing some config setting?

    *edit* I also got a hold of an old Radio Shack game pad and get the same results. Buttons are fine but no D-pad support in my programs other than jscalibrator
    Last edited by HittingSmoke; December 3rd, 2008 at 08:25 AM.
    And the thread title of the year award goes to...
    " Supositories not working - On the verge of losing it here - help!"

  6. #46
    Join Date
    Sep 2008
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Set-up a gameport gamepad or joystick

    Quote Originally Posted by 1337 View Post
    Is this normal I got the same when I try to type a command line for the "analog" module, my joystick was detected wrong and it is not working fine because of that however there is an option:

    Type | Meaning
    none | No analog joystick on that port
    auto | Autodetect joystick
    2btn | 2-button n-axis joystick
    y-joy | Two 2-button 2-axis joysticks on an Y-cable
    y-pad | Two 2-button 2-axis gamepads on an Y-cable
    fcs | Thrustmaster FCS compatible joystick
    chf | Joystick with a CH Flightstick compatible hat
    fullchf | CH Flightstick compatible with two hats and 6 buttons
    gamepad | 4/6-button n-axis gamepad
    gamepad8 | 8-button 2-axis gamepad <-------- I got this one

    Where add this js=gamepad8 option to make this work and not get:

    FATAL: Error inserting analog (/lib/modules/2.6.20-15-generic/kernel/drivers/input/joystick/analog.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    error, anybody?
    Just managed to get my old analog CH Flightstick pro working in 9.10.
    Heres how you do it. When loading the analog module you have to add map=chf (for flightstick pro).

    sudo modprobe analog map=chf

    I managed to get my vintagestick up and running again, happy times.

  7. #47
    Join Date
    Feb 2010

    Thumbs down Re: HOWTO: Set-up a gameport gamepad or joystick

    I have a problem with EMS Dualshooter, Ubuntu (Karmic) doesn't recognize the device and the ps2 controller will not work, any ideas?
    All i have found about this issue is fanboys screaming that usb devices work like magic, well, it doesn't.
    Anyone else run into this problem?

  8. #48
    Join Date
    Jul 2010

    Re: HOWTO: Set-up a gameport gamepad or joystick

    Hi guys! I've found this thread via Google when searching for a solution for my problem: I've got four analog gamepads an analog joystick and none of these input devices is working correctly.

    In the detail: No axis is working! The buttons work fine but there is a strange acitivity …

    1. When pressing the A button for example in a web browser on any of my gamepads, it acts like a mouse click. Lets say the mouse cursor is placed over a word. Pressing the A button twice selects the word. Pressing the A button three times selects the whole line. Just like clicking with the left mosue button.

    2. Pressing the B button acts like Shift+Input / Strg+V (pasting the content from the clipboard).

    3. Pressing the C button makes a context menu pop up.

    And this is what I've made and tried …

    First I've installed the following applications from the Ubuntu repository:
    sudo apt-get install joystick jstest-gtk
    Then I've added the following line to /etc/modules:

    analog map=gamepad8
    … and loaded the module into the memory:

    sudo modprobe analog map=gamepad8
    Adding/loading the joydev-module doesn't help, too.

    Now I've tried to use the gamepad with several games but it the problem is a described above.

    So I've first tried calibrating the gamepad with jstest-gtk and then with jscal -c /dev/input/js0 and also tried running /etc/init.d/joystick restart but it didn't work. I've restarted Ubuntu but it didn't help, too.

    Somewhere I've red about creating a symbolic link like this, to solve the problem: sudo ln -s /dev/input/js0 /dev/js0 … but it also didn't work.

    The soundcard I'm using is a Terratec SoundSystem Sixpack 5.1+.

    Can anybody help me please?

    PS: Sorry for my bad english!

Page 5 of 5 FirstFirst ... 345


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts