Page 3 of 17 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 167

Thread: HOWTO: Flash BIOS, The Ubuntu Way

  1. #21
    Join Date
    Sep 2006
    Denver, Colorado
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    Hi, Alanholt.

    We don't do any testing or work with your computer model, so I'm not sure where to point you.
    Flashing the BIOS on our computers requires no jumpers.

    Try going into your BIOS menu and seeing if there is a setting anywhere that removes the BIOS write-protection.

    To err is human, to forgive is very ... dog-like.

    Thomas Aaron
    FetchMasters, LLC

  2. #22
    Join Date
    Jun 2005
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    I'm a little confused - when I run the command to create an ISO, I get the following:
    ~/Desktop$ sudo mkisofs -o Bootable-CD-BIOS-Image.iso -b FDOEM.144 FDOEM.144
    I: -input-charset not specified, using utf-8 (detected in locale settings)
    genisoimage: No such file or directory. Invalid node - 'FDOEM.144'.
    I'm not clear on how mkisofs is supposed to know where FDOEM is if I've unmounted /mnt/temp.

  3. #23
    Join Date
    Apr 2006
    Kubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    I can't move my BIOS exe file into the mounted directory. Write access is denied, and impossible to change once FDOEM.144 is mounted. I can move it there before it is mounted but it disappears once I mount.
    I got the APIC error 40(40) and this is my last resort. Windows is NOT an option.

    Please help.

    EDIT: After extracting the .exe using cabextract to get a lot of files I realized that the image would be too big to fit the mount. I found a 12-year-old 2 gig HD, unplugged all other HDDs, installed XP-StrippedToTheBone and updated the BIOS through there instead. Solved!
    Last edited by aparigraha; September 3rd, 2007 at 03:07 AM.

  4. #24
    Join Date
    Mar 2006
    Tokyo, Japan
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    I've done everything as per instructions, but when I boot into Freedos and type the command AFLASH.EXE or AFLASH i get an error saying the system cannot find the Bios' hook.

    Any clue as to what I should do?

  5. #25
    Join Date
    Jun 2006
    A galaxy far, far away...

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    When I try to extract the exe, it gives me this:

    aren@aren-laptop:~/Installs/bios junk$ unzip sp32790.exe 
    Archive:  sp32790.exe
      End-of-central-directory signature not found.  Either this file is not
      a zipfile, or it constitutes one disk of a multi-part archive.  In the
      latter case the central directory and zipfile comment will be found on
      the last disk(s) of this archive.
    unzip:  cannot find zipfile directory in one of sp32790.exe or
  , and cannot find sp32790.exe.ZIP, period.
    Any ideas?

    EDIT: I think I got it, I had to extract the main one with cabextract first, then unzip the exe that produced. Now to see if it works.

    EDIT2: another snag: the extracted files are too big for the image. I'm using a cd, so is there any way to increase the space?
    Last edited by reacocard; July 31st, 2007 at 05:33 PM.
    "Whoever said sunshine brings happiness has never danced in the rain." - K. Jackson
    Exaile Media Player | Arch Linux
    Click here to have your brain eaten

  6. #26
    Join Date
    Oct 2006
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    I'm running a bootable cd and i get the flash utility up and running it gives me "source file not found" when I attempt to flash it. I only have so many files and I've tried to get it to work. What could I be doing wrong?

  7. #27
    Join Date
    Dec 2006

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    got the same problem as thomasaaron
    freedos 1.4m
    sp30341.exe DON'T fit

    otherwise howdo i make ados bootable cdrom

    Last edited by fugative; August 16th, 2007 at 09:49 PM. Reason: messed up 1st time

  8. #28
    Join Date
    Jan 2007

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    I used the CD approach here on Debian to upgrade the BIOS of my Dell XPS M1710 laptop, and it worked perfectly. Thanks for the guide!

  9. #29
    Join Date
    Oct 2006

    Re: HOWTO: Flash BIOS, The Ubuntu Way


    Great post!

    It does not work for me, though!

    I've tried the steps many times with no luck.

    I'm using the bios from Gigabytes webpage. I go through the steps with out any errors. However, when I run the flash.exe I always get the following error. And nothing happens.

    Error 10 : Bus ID error

    Ive also tried using AwardBios. That utility complained about the Program File's part number does not match your system! And it did nothing.

    So, has anyone seen this error, and then was able to get around it? Any suggestions about a possible work around? I've been searching for hours with no good leads!

    Thanks a million!


    OS: Debian etch
    MotherBoard: GA-K8NSC-939 nForce3 250Gb chipset
    CPU: AMD64 x2 4200+
    Floppy: NONE!!!!!!!!!

  10. #30
    Join Date
    Sep 2007
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Flash BIOS, The Ubuntu Way

    sweet, I will have to try this.... of course on a test workstation - you can never be too cautious.

Page 3 of 17 FirstFirst 1234513 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts