View Poll Results: Was this helpful to you?

Voters
1159. You may not vote on this poll
Page 150 of 152 FirstFirst ... 50100140148149150151152 LastLast
Results 1,491 to 1,500 of 1518

Thread: Master Kernel Thread

  1. #1491
    Join Date
    Aug 2009
    Location
    Norfolk, Virginia
    Beans
    56
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Master Kernel Thread

    Quote Originally Posted by emshains View Post
    I apologize if I am not the first one to mention this, but the kernel compiles heck of a lot faster if you use make -j 2 (or 4 or whatever number of cores/cpu's you've got/are willing to use). Isn't there a way to do this while making a .deb package ? I hope I made sense.
    export CONCURRENCY_LEVEL=`getconf _NPROCESSORS_ONLN`
    Will set the compile to use your maximum number of currently available processors, or just

    export CONCURRENCY_LEVEL=$WhateverNumberYouWant #not to exceed your current number of available processors

    In the guide it defines this value before doing the compile process, within the same line

    https://wiki.ubuntu.com/KernelTeam/GitKernelBuild
    |||||||||||||||||||||||||||||||||||||||||||||||||
    \\\\\\\\\\\\\\\\\\\\\\\//////////////////////////
    ################################################## ##############
    CONCURRENCY_LEVEL=`getconf _NPROCESSORS_ONLN` fakeroot make-kpkg --initrd --append-to-version=-custom kernel_image kernel_headers
    ################################################## ##############

  2. #1492
    Join Date
    Aug 2009
    Location
    Norfolk, Virginia
    Beans
    56
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Master Kernel Thread

    Quote Originally Posted by jwach View Post
    I got the same error. I'm not sure of a cause or a real fix, but it has to do with the plus sign being added to the end of the kernel name. I was able to find a workaround, but it isn't ideal at all, and there is probably a better way.

    You have to run make-kpkg again (i.e. repeat step 8 at https://wiki.ubuntu.com/KernelTeam/GitKernelBuild) and then, while it is running (and before it returns to the point of the error), edit the debian config file at ~/linux-2.6/debian/control. In that file, replace every instance of "linux-image-2.6.35-rc5-custom" with "linux-image-2.6.35-rc5-custom+"; replace every instance of "linux-source-2.6.35-rc5-custom" with "linux-source-2.6.35-rc5-custom+"; and replace every instance of "linux-headers-2.6.35-rc5-custom" with "linux-headers-2.6.35-rc5-custom+".

    The trouble with this is that make-kpkg will automatically regenerate the debian/control file, so you have to watch and be sure that you edit that file after it does.

    Anybody know a better solution?
    This is going to sound weird... but in newer kernels, when doing the make $AnyOfTheConfigTypes (EX: make menuconfig) you have an option to embed a subversion string, with the Ubuntu kernel compile options, this is not supported. And that's where the error is. If you do use make menuconfig, under general configuration (like the third option down) Blank that out. Instead, in the example:

    fakeroot make-kpkg --initrd --append-to-version=-some-string-here kernel-image kernel-headers

    The --append-to-version= is what you will want for the information to show up on the kernel, and --revision= will apply to the .deb revision number. If you blank that string in your make $ConfigType and instead put that string in --append-to-version it will compile without any issues.

  3. #1493
    Join Date
    Aug 2010
    Beans
    1

    Re: Master Kernel Thread

    This is exactly what I did and I still get an extra plus sign (+) at the end.

    Using the overlay-dir option found on the KernelTeam/GitKernelBuild page, I get a different error than the dpkg-gencontrol error:
    Code:
    This is kernel package version 12.032.
    The changelog says we are creating 2.6.35
    However, I thought the version is 2.6.35+
    exit 1
    so without the overlay (and without the --append-to-version) I get
    Code:
    dpkg-gencontrol: error: package linux-image-2.6.35+ not in control info
    Help please!!

  4. #1494
    Join Date
    Sep 2008
    Beans
    76
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Master Kernel Thread

    I just used these instructions to upgrade my kernel to 2.6.34-mk (i686). I am now trying to install some graphics drivers - fglrx - and get the following message:

    Error! Bad return status for module build on kernel: 2.6.34-mk (i686)
    Consult the make.log in the build directory
    /var/lib/dkms/fglrx/8.723.1/build/ for more information.

    The make log says:

    DKMS make.log for fglrx-8.723.1 for kernel 2.6.34-mk (i686)
    Tue Aug 10 08:46:03 BST 2010
    AMD kernel module generator version 2.1
    cat: /lib/modules/2.6.34-mk/build/include/linux/utsrelease.h: No such file or directory
    Error:
    kernel includes at /lib/modules/2.6.34-mk/build/include do not match current kernel.
    they are versioned as ""
    instead of "2.6.34-mk".
    you might need to adjust your symlinks:
    - /usr/include
    - /usr/src/linux

    What does this mean? What do I do?

  5. #1495
    Join Date
    Sep 2007
    Location
    Riga Latvia
    Beans
    343
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Master Kernel Thread

    FYI, if you are trying to compile 2.6.32 with the bfs patch, your wi-fi won't work, compiling 2.6.34 with bfs patch works.
    Originally Posted by rugbert
    Are there any plans to make it not suck so hard any time soon?
    ROFL!

  6. #1496
    Join Date
    Aug 2010
    Beans
    10

    Re: Master Kernel Thread

    What is the reason for the following error?

    When compiling to 2.6.30 (sorry for the early version, but I am using a Ubuntu 8.04 diskless installation with kernel 2.6.15.7)

    When the last step was doing compiling new kernel, it poped up with:

    tar: ./postinst: file changed as we read it
    tar: ./md5sums: file changed as we read it

    and failed there.

    What's this for? How to fix. Thanks for opinions!

  7. #1497
    Join Date
    Nov 2009
    Beans
    7

    Re: Master Kernel Thread

    hello guys. I need some help. I build an custom kernel from a vanilla one WITHOUT of support of initrd image. The kernel is working fine, but some packages after update are triggering the rebuild of initrd which is not available. The question is: how i can disable this behavior? I'm on 10.04.
    Thanks in advance!

  8. #1498
    Join Date
    Apr 2006
    Beans
    26

    Re: Master Kernel Thread

    Quote Originally Posted by jeff.dagenais View Post
    This is exactly what I did and I still get an extra plus sign (+) at the end.

    Using the overlay-dir option found on the KernelTeam/GitKernelBuild page, I get a different error than the dpkg-gencontrol error:


    so without the overlay (and without the --append-to-version) I get


    Help please!!
    Anyone been able to fix this?

  9. #1499
    Join Date
    Dec 2009
    Beans
    9

    Re: Master Kernel Thread

    Hello,

    I have been trying to install the kernel mentioned above on 9.04....I run to an error on the line 'sudo cp /usr/share/kernel-package/examples/etc/kernel/postinst.d/initramfs /etc/kernel/postinst.d/', because there is no such directory. The file tree terminates at /etc/
    with only 5 single files in there, non of them being the target files. Were the files meant to be copied during the previous lines or are the folders naturally in a different location with 9.04?

    Would love some help, I have tried a few different approaches. My aim is to get a kernel/kernel tree above 2.6 to allow development of drivers for external hardware. So if anybody can give advice on how to get a development system up and running I would be grateful.
    Thanks.

  10. #1500
    Join Date
    Nov 2010
    Beans
    40

    Re: Master Kernel Thread

    Quote Originally Posted by master_kernel View Post
    A. Note to everyone: The append-to-version option has absolutely nothing to do with the kernel at all. It is simply a short title for your kernel. 64 bit users can even put --append-to-version=64 or don't even include the append-to-version at all. 64-bit users can enable 64-bit options in the kernel under Processors.
    Does this mean that by selecting the processor type, for say specific/generic 686 support, you get a 686 optimized kernel?

    Adding this to the make-kpkg command saved me some hassle, 'modules_image'. A lot of other tutorials skip right over this, thanks.

Page 150 of 152 FirstFirst ... 50100140148149150151152 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •