Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 51

Thread: HOWTO: MIDI in Hoary

  1. #41
    Join Date
    Mar 2005

    Re: HOWTO: MIDI in Hoary is dead, which is a major problem because that is where the extraction utility should be. Does anyone know where a utility to extract sfark files can be located?

    EDIT: There seems to be some strange routing problems! Using a proxy that website works. This is strange because every other website (including ubuntu forums) works fine.
    Last edited by AgenT; November 11th, 2005 at 08:51 PM.
    Before you sign up to Dropbox, click here to read my post showing you how to get an additional 500mb free! That's 2.5GB of free space!

  2. #42
    Join Date
    May 2005
    Ubuntu Breezy 5.10

    Re: HOWTO: MIDI in Hoary

    This is kind of annoying, it would be better if you could just double click the darn file and have Totem play it.

  3. #43
    Join Date
    Nov 2005
    Ubuntu Intrepid Ibex (testing)

    Re: HOWTO: MIDI in Hoary

    Thanks for the guide, works great with SB Audigy!
    I tried with ALSA driver.
    Last edited by mlind; March 1st, 2006 at 08:49 AM.

  4. #44
    Join Date
    Sep 2005

    Re: HOWTO: MIDI in Hoary with a Hardware Synthesizer

    Very helpfull! Thanks!
    My SB Aydigy 2 (value) plays perfectly with Fluid_R3_GM

  5. #45
    Join Date
    Jun 2006

    Sound Blaster Live! 24 bit 7.1 and NO MIDI...

    Went to buy the sound blaster live (24bit, the only sound blaster live that was on sale) today in the hope to finally get a sound card with linux-compatible midi. Followed all steps of your guide, but when I installed the awesfx, it said something about not being able to configure it and:

    No Emux synth hwdep device is found

    the loading of the modules before went smoothly. Trying to load a soundfont leads to the same error.

    doing cat /dev/sndstat
    gave me:

    Sound Driver:3.8.1a-980706 (ALSA v1.0.10rc3 emulation code)
    Kernel: Linux schlumpfhausen 2.6.15-25-386 #1 PREEMPT Wed Jun 14 11:25:49 UTC 2006 i686
    Config options: 0

    Installed drivers:
    Type 10: ALSA emulation

    Card config:
    Live! 7.1 24bit [SB0410] at 0xe400 irq 5

    Audio devices:
    0: CA0106 (DUPLEX)

    Synth devices: NOT ENABLED IN CONFIG

    Midi devices:
    0: CA0106 MPU-401 (UART)

    7: system timer

    0: mixer00

    I have an onboard sound chip (AC97), which I enabled in the BIOS before installing the SB Live. The SB Live works ok for normal audioplayback, only MIDI is not working. I am on (K)Ubuntu 6.06.

    What could possibly be the reason for my problems?
    Last edited by papaschlumpf; June 26th, 2006 at 10:28 PM.

  6. #46
    Join Date
    Jun 2006

    Re: Sound Blaster Live! 24 bit 7.1 and NO MIDI...

    ok, apparently MIDI for the SB Live 24 bit is not supported yet.
    Also I figured out that it does not work with the snd-emu10k1 driver, but uses snd-ca0106.
    I looked around on the ALSA page and zillions of other pages, but couldn't find anything Linux-MIDI-related about the SB Live 24 bit, so I am giving up and bringing the darn thing back tomorrow. Guess I'll have to try to get one of those older SB Live somewhere to get MIDI working

  7. #47
    Join Date
    Jul 2006
    Canada, eh?
    Ubuntu 9.10 Karmic Koala

    Talking Excellent howto

    Hi! Just writing in to say that this method ALSO WORKS IN DAPPER, as of 5 days before Edgy is being released.

    I am running an old Audigy MP3+, which is basically just an Audigy 1. It works fine with the ALSA [drivers?] but I had to change the MIDI device in my MIDI-playin' programs from the default to one of the "Emu10K Wavetable... etc" ones for it to work. Other than that, it's fine.

    I'd also like to say that it took me several hours of frustrated fighting with my computer, trying to get MIDI playback to work, before I found this thread by accident and solved the problem in a matter of minutes. This little guide is excellent... I just wish it had been more visible to start with, because I went through a Lot of threads that said nothing except "I can't get it to work!", "It's too hard to do... just use Timidity instead..." and "After hours of grewling searching and experimenting trying to get it to work, it works! but instead of telling everybody how I did it, I'm going to post more questions that nobody will be able to answer..."
    Last edited by jem7v; October 22nd, 2006 at 07:48 PM. Reason: noticed a formatting mistake

  8. #48
    Join Date
    Jul 2005

    Re: HOWTO: MIDI in Hoary

    FACKIN' OUT like a master at 100,0000 kilometers per hour.

    I recently found an old soundcard with an OPL3 chip on it... - a little info here.
    I think several different soundcards from several different manufacturers had this chip. Anyway, it gives the ability of hardware MIDI synthesis. It doesn't sound very good, but it works.

    If you have an Avance Logic ALS4000 or another card with the OPL3 chip, this is how to get it working.

    Install package "pmidi"

    Load these modules

    snd-opl3-synth (or perhaps it is called "opl3", I can't quite remember)

    Now, do this command:

    aplaymidi -l

    And in the list that it outputs, you should see something in it which looks like "65:0 OPL3 FM synth". Here's a screenshot of how it looked in my case:

    Then, you must install the package "alsa-tools". It was not in the breezy repositories, but it is in the dapper repositories.

    That package should include "sbiload", and two files: std.o3 and drums.o3

    Now you have installed that package, locate the two files "std.o3" and "drums.o3", so you know where they are in the system. (I assume that they come with the "alsa-tools" package, but I can't remember. I do not have that computer system available to me now.)

    Now do this command:

    sbiload -p65:0 --opl3 std.o3 drums.o3

    And then test to see if it worked.

    aplaymidi -p 65:0 testfile.mid

    You should be hearing some wonderful synthesized music noises.
    Here's a little sound clip I made in case you'd like to know what it would sound like. - OPL3 FM synth playing "segarally.mid" - source midi file
    Like I said, it doesn't sound so good. But maybe someone would like to use it with linux, so I thought I'd post this.

    Let me know if you found this helpful or interesting.

  9. #49
    Join Date
    Jul 2006
    Canada, eh?
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: MIDI in Hoary with a Hardware Synthesizer

    For the record, I've tried it out and Deusiah's method works in Edgy too.

  10. #50
    Join Date
    Oct 2007

    Re: HOWTO: MIDI works fine on SB AUDIGY 4 PRO

    Hello from france.

    Thanks a lot.

    All of this tips works fine with my Sound Blaster Audigy 4 PRO under Feisty.

    I see someone complaining about his PC to slowdown after loading the Fluid set. Well you have to know that sound bank is effectively loaded in main memory. So such a big bank with only 256M ram is not recommended.

    Have a nice day

    lspci for info about my sound card :

    02:08.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
    Subsystem: Creative Labs Unknown device 2007
    Flags: bus master, medium devsel, latency 64, IRQ 22
    I/O ports at 9c00 [size=64]
    Capabilities: [dc] Power Management version 2

Page 5 of 6 FirstFirst ... 3456 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts